none
SCOM 2012 DISCOVERING LINUX "SSH connection error"

    Question

  • Hi, 

    i having this problem when doing SCOM 2012 discovery for Redhat 6, any solution on this ?


    


    Sunday, July 08, 2012 11:00 AM

Answers

  • As suggested by others, you will want to test ssh connectivity to the host.  Using PuTTY or another ssh utility, can you access the host and login?  If so, is it slow to login?  If it is very slow to login via ssh, you could try disabling reverse lookups on ssh by adding the line:  UseDNS no to /etc/ssh/sshd_config. I've seen this fix a similar issue in the past.

    www.operatingquadrant.com

    Tuesday, July 24, 2012 8:59 PM

All replies

  • Hi

    Make sure you have port 22 and port 1270 open for that machine on the network and on your Linux box as well.

    Further troubleshooting issues and solutions see here http://technet.microsoft.com/en-us/library/ff358634.aspx.

    Stefan


    Blog: http://blog.scomfaq.ch

    Sunday, July 08, 2012 8:42 PM
  • Hi,

    The port 22 and port 1270 are open, but still having same problem, the linux box still not able to discover. 

    Monday, July 09, 2012 12:17 AM
  • Enable logging and see if it will point you to the issue.

    http://technet.microsoft.com/en-us/library/ee344801.aspx

    Can you SSH into the box from the SCOM server? Install PuTTY and verify as, by default, RHEL has the firewall turned on and this will block the discovery.

    -Steve

    Monday, July 09, 2012 1:02 PM
    Moderator
  • Hi

    Install telnet client feature on the SCOM management Server and try each command

    Telnet [Linux Server IP] 22 and then Telnet [Linux Server IP] 1270 from the SCOM management Server. You should get a response...

    SSH Deamon is up and running on Linux?

    Stefan


    Blog: http://blog.scomfaq.ch

    Monday, July 09, 2012 6:48 PM
  • Hi

    Is this Problem solved?


    Blog: http://blog.scomfaq.ch

    Monday, July 23, 2012 7:16 PM
  • As suggested by others, you will want to test ssh connectivity to the host.  Using PuTTY or another ssh utility, can you access the host and login?  If so, is it slow to login?  If it is very slow to login via ssh, you could try disabling reverse lookups on ssh by adding the line:  UseDNS no to /etc/ssh/sshd_config. I've seen this fix a similar issue in the past.

    www.operatingquadrant.com

    Tuesday, July 24, 2012 8:59 PM
  • This actually solved my issue. Now, I must figure out why this WAS working previously, and now not working unless I disable reverse lookup. Thanks for the tip and helping me get my environment running again!
    Monday, June 03, 2013 4:23 PM
  • Thank you.. This trick works flawlessly.
    Thursday, March 02, 2017 10:57 AM