none
Linux Agent Discovery fails SCOm 2012 SP1 RRS feed

  • Question

  • Getting the following : while trying to discover and install SCOM 2012 SP1 agent on Linux (Red Hat)

    This server do not have SCOM agent installed. 

    (I was following  http://blogs.technet.com/b/kevinholman/archive/2012/03/18/deploying-unix-linux-agents-using-opsmgr-2012.aspx)

    Unexpected DiscoveryResult.ErrorData type.  Please file bug report.
    ErrorData: Microsoft.SystemCenter.CrossPlatform.ClientLibrary.MPAbstractions.WSManUnknownErrorException
    The SSL connection cannot be established. Verify that the service on the remote host is properly configured to listen for HTTPS requests. Consult the logs and documentation for the WS-Management service running on the destination, most commonly IIS or WinRM. If the destination is the WinRM service, run the following command on the destination to analyze and configure the WinRM service: "winrm quickconfig -transport:https". 
       at System.Activities.WorkflowApplication.Invoke(Activity activity, IDictionary`2 inputs, WorkflowInstanceExtensionManager extensions, TimeSpan timeout)
       at System.Activities.WorkflowInvoker.Invoke(Activity workflow, IDictionary`2 inputs, TimeSpan timeout, WorkflowInstanceExtensionManager extensions)
       at Microsoft.SystemCenter.CrossPlatform.ClientActions.DefaultDiscovery.InvokeWorkflow(IManagedObject managementActionPoint, DiscoveryTargetEndpoint criteria, IInstallableAgents installableAgents)

    Thursday, January 24, 2013 10:03 AM

All replies

  • Can you SSH into the RHEL system? Discovery uses SSH to discover and push the agent to the system then install it. Once running the agent runs on port 1270, make sure that port is open on the firewall. By default it is blocked on RHEL.

    Regards,

    -Steve

    Thursday, January 24, 2013 1:40 PM
    Moderator
  • Hi,

    Did u installed package with right version ? I got similar error at begining, when I used a wrong package. The one works for me is  "ACS package 7.4.3507.0"

    Lu


    • Edited by Lu Xin Thursday, January 24, 2013 11:04 PM
    Thursday, January 24, 2013 11:04 PM
  • @Steve - We can SSH , but i am not sure about port 1270

    is there a way i can check that

    @Lu We are not able to discover the Linux machine. I dont know when ACS package will be needed maybe that is after the install.

    Friday, January 25, 2013 10:06 AM
  • Port 1270 will only be open once the agent is actually installed. Is the agent installed on the RHEL server? Do a (scxadmin -status) on the RHEL server to check. Once the agent gets installed, discovery will try to talk to the agent over port 1270. If port 1270 is open you should be able to telnet to it from another system. It will not return anything but it should connect.

    As for the ACS MPs, you only need them if you are  going to use the ACS features in OpsMgr itself. If you have no plans to use ACS at this time they are not needed.

    Regards,

    -Steve

    Friday, January 25, 2013 2:18 PM
    Moderator
  • Hi Steve, 

    The agents are not installed as i am in the process of installing , but discovery is the first stage. 

    I havent been able  to go beyond discovery as yet so i think port 1270 doesnt come in picture. My discovery is failing with the message i have posted 

    Any other advice on this.
    • Edited by Kitaab Sunday, January 27, 2013 8:00 AM
    Saturday, January 26, 2013 8:18 AM
  • Enable logging --> http://technet.microsoft.com/en-us/library/ee344801.aspx  and retry discovery. See if that helps determine the cause.

    Regards,

    -Steve

    Monday, January 28, 2013 2:27 PM
    Moderator
  • I had done that already , however this doenst give me any information as well.
    Tuesday, January 29, 2013 11:45 AM
  • Others have run across this before and a reboot of the SCOM server has helped. Not sure if you've tried that but worth a try. Have you tried that? Verify the following URL is not causing the issue.

    http://operatingquadrant.com/2012/01/12/opsmgr-unixlinux-heartbeat-failures-after-applying-kb2585542

    When you say the logging does not give you any information, are there logs getting generated after you run Discovery and it fails?

    -Steve

    Tuesday, January 29, 2013 1:22 PM
    Moderator
  • I can recommend to check the trace. It has helped me in most cases.

    Also check if the sftp on the server is responding.

    Monday, February 4, 2013 7:52 PM