none
SharePoint 2013 Error - admin component is not up and running RRS feed

  • Question

  • Hi,

    We are unable to start the Search service application on the Search Service app page in CA in SP2013. These are the errors at different locations. We have deleted and recreated search. Cleared cache.ini method. Nothing worked

    In SharePoint logs
    Content Plugin can not be initialized - list of CSS addresses is not set.
    Failed to extract required parameter FastConnector:ContentDistributor, hr=0x80070002  [pluginconfig.cpp:81]  search\native\gather\plugins\contentpi\pluginconfig.cpp

    In Search Service app page in CA
    Administrative status Running
    Crawler background activity None
    Recent crawl rate 0.00 items per second
    Searchable items All Errors
    Recent query rate  0.00 queries per minute

     

    Search Application Topology
    Unable to retrieve topology component health states. This may be because the admin component is not up and running

    FYI - All the services related  to search in services.msc are up and running

     

    In the event viewer: event id 6482
     
    Application Server Administration job failed for service instance Microsoft.Office.Server.Search.Administration.SearchServiceInstance (9ea77252-916a-460b-9abe-4e7294120e7d).

    Reason: A call to SSPI failed, see inner exception.

    Technical Support Details:

    System.ServiceModel.Security.SecurityNegotiationException: A call to SSPI failed, see inner exception. ---> System.Security.Authentication.AuthenticationException: A call to SSPI failed, see inner exception. ---> System.ComponentModel.Win32Exception: The target principal name is incorrect

    --- End of inner exception stack trace ---

    at System.Net.Security.NegoState.StartSendAuthResetSignal(LazyAsyncResult lazyResult, Byte[] message, Exception exception)

     

    Tuesday, April 8, 2014 6:13 PM

Answers

All replies

  • Hi VimalVT,

    According to your description, my understanding is that you got the error 6482 when you used SharePoint 2013 Search.

    Firstly, make sure that the search service account have dbowner role on all search databases, then restart the server, compare the result.

    If this issue still exists, please check the service accounts of SharePoint Timer Serivce and SharePoint Search Host Controller service, add a SPN entry for each the service account as the following command:

    Setspn.exe -A HTTP/<the name of SharePoint server> <service account>

    After the above, do an IISREST.

    I hope this helps.

    Thanks,

    Wendy

    Wendy Li
    TechNet Community Support

    Wednesday, April 9, 2014 6:51 AM
    Moderator
  • Thanks Wendy,

    I tried the First option and the account has rights in all the databases pertaining to search. Restarted to see that the Search service in services.msc got stopped. Restarted this manually. No difference.

    When I tried to run the command in Elevated command prompt it threw me error saying insufficient permissions to execute the operation. So does this have anything to do with the permission setting in AD?

    Wednesday, April 9, 2014 5:47 PM
  • Hi VimalVT,

    If you need to allow delegated administrators to configure service principal names (SPNs), you must ensure that their user accounts have the Validated write to service principle name permission.

    More information, please refer to the link:

    http://technet.microsoft.com/en-us/library/cc731241.aspx

    I hope this helps.

    Thanks,

    Wendy


    Wendy Li
    TechNet Community Support

    Friday, April 11, 2014 9:07 AM
    Moderator