SCSM Setup fails when using Remote SQL with "Access to the SQL Server Instance was denied" Error message.


  • Hi Friends,<o:p></o:p>

    I'm running with trouble while installing SCSM Management server and SCSM DWH Management server (each in different box).<o:p></o:p>

    It fails with "Access to the SQL Server Instance was denied" Error message at the database configuration page.<o:p></o:p>

    I want to use one of my Central SQL Server for all the DB's but for SCSM it's not working out but when I install the SQL Server locally into that server it works fine (but I do not want to do that).<o:p></o:p>

    Environment: SQL 2K8R2 SP1, Windows 2K8R2 SP1, SCSM 2010 SP1  <o:p></o:p>

    PS: Installation account has got all the SQL Server role privilege and is also part of local administrator of SQL Box.<o:p></o:p>

    Please help me to resolve this issue. Error files have been attached for your reference.<o:p></o:p>

    Thanks in Advance.<o:p></o:p>

    Thanks, Akhilesh

    Friday, February 10, 2012 1:21 PM

All replies

  • I would just like to confirm that you have configured the "SQL Network Configuration"

    Have you enabled the network part of TCP/IP.

    Have you also then enabled it on a per IP basis.

    As long as you learn something new every day, the day is not wasted.

    Friday, February 10, 2012 1:53 PM
  • <Partially SOLVED><o:p></o:p>

    This is solved by change the Windows Firewall to allow incoming connections on the TCP port of SQL Server.  But on "Configure the reporting server for the data warehouse page" I'm getting “The SSRS Web service URL is not valid” error message. I'm not able to browse the URL with installation account also; I know there is some permission issue on SQL box but don't know exactly where. Can anyone pls let me know where should I check for this issue? Thanks<o:p></o:p>

    I have assigned all the SQL Server role for the Reporting DB to the SCSM Installation account but still not working.<o:p></o:p>

    Thanks, Akhilesh

    Monday, February 13, 2012 8:45 AM
  • You'll need to install and configure SSRS on the server you intend to use for reporting.  You'll also need to copy a dll file to the computer hosting SSRS.

    As always, double check your firewall settings.

    Allen Anderson Systems Analyst Arizona State University - OKED Knowledge Informatics

    Monday, February 20, 2012 6:54 PM
  • Firewall settings do absolutely have piss poor documentation
    Wednesday, January 30, 2013 4:25 PM
  • I had same issue, with exact same error message.

    My problem was the name for my database server. It was default SQL02.

    I changed this to the fqdn, SQL02.DOMAIN.LOCAL and the problem was solved.

    Wednesday, August 14, 2013 8:41 AM