none
Error after adding VMM component RRS feed

  • Question

  • installed the virtual machine manger component

    however on the service status screen it has

    "Unable to retrieve data" for both Helth and Updates

    Also missing some of the computer groups on the left hand side. It used to list "all windows servers", "all windows clients" etc

    Now it only shows "All Windows Computers (64), Server (0), Workstations (0) 

    (servers and workstations are AD folders)

    When I try to add the groups in it gives error saying that they already exist. 

     

    This is the error from Overview page when i click on details...

    Date: 14/07/2011 4:33:51 PM
    
    Application: System Center Essentials
    
    Application Version: 7.0.2432.1
    
    Severity: Error
    
    Message: 
    
    
    
    Microsoft.UpdateServices.Administration.WsusObjectNotFoundException: The specified item could not be found in the database.
    
       at Microsoft.UpdateServices.Internal.BaseApi.SoapExceptionProcessor.DeserializeAndThrow(SoapException soapException)
    
       at Microsoft.UpdateServices.Internal.DatabaseAccess.AdminDataAccessProxy.ExecuteSPGetTargetGroupById(Guid id)
    
       at Microsoft.UpdateServices.Internal.BaseApi.ComputerTargetGroup.GetById(Guid id, UpdateServer updateServer)
    
       at Microsoft.UpdateServices.Internal.BaseApi.UpdateServer.GetComputerTargetGroup(Guid id)
    
       at Microsoft.SystemCenter.Essentials.OpsMgrSdkHelper.GetComputerGroup(Guid scomGroupId, ManagementGroup managementGroup, IUpdateServer updateServer, MonitoringObjectGroup& scomGroup, IComputerTargetGroup& wsusGroup)
    
       at Microsoft.SystemCenter.Essentials.UI.Common.ComputerSpace.DataModel.DataAdapter.OverviewUpdateSoftwareTileDataAdapter.DoAction(DataQueryBase query, IList`1 dataSources, IDictionary`2 parameters, IList`1 inputs, String outputCollectionName)
    
       at Microsoft.EnterpriseManagement.UI.ViewFramework.ListSupportAdapter.DoAction(DataQueryBase query, IList`1 dataSources, IDictionary`2 parameters, IList`1 inputs, String outputCollectionName)
    
       at Microsoft.EnterpriseManagement.UI.DataModel.QueryQueue.StartExecuteQuery(Object sender, ConsoleJobEventArgs e)
    
       at Microsoft.EnterpriseManagement.Mom.Internal.UI.Console.ConsoleJobExceptionHandler.ExecuteJob(IComponent component, EventHandler`1 job, Object sender, ConsoleJobEventArgs args)
    
    

     


    • Edited by Robert Kruk Friday, July 15, 2011 3:16 AM updates
    Thursday, July 14, 2011 6:36 AM

Answers

  • Hello,

    Did you selecte to install the Virtualization Management feature while installing Essentials server components? Or did you install the virtual machine manger component on a working Essentials server? Did you install Essentials 2010 on a virtual machine?

    For the problem "Unable to retrieve data", please check the following thread to see if it helps:

    SCE2010: Computeroverview - Unable to retrieve Date
    http://social.technet.microsoft.com/Forums/en-US/systemcenteressentials/thread/f2564a05-2dbb-44b4-91e4-2e3cdd282610

    Thanks,


    Yog Li -- Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Robert Kruk Monday, July 18, 2011 2:00 AM
    Friday, July 15, 2011 12:05 PM
    Moderator
  • Thanks Yog,

    Just incase anyone else needs to do this:

    you will need to download the System Center Essentials 2010 Resource Kit from http://www.microsoft.com/download/en/details.aspx?id=191

    and do the following:

    Usage

    1. Click Start, click All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator.
    2. Navigate to the System Center Essentials 2010 installation directory, usually located in %programfiles%\System Center Essentials.
    3. Start the Computer Group Repair Tool by double-clicking LinkDG.exe.
    Monday, July 18, 2011 2:03 AM

All replies

  • Hello,

    Did you selecte to install the Virtualization Management feature while installing Essentials server components? Or did you install the virtual machine manger component on a working Essentials server? Did you install Essentials 2010 on a virtual machine?

    For the problem "Unable to retrieve data", please check the following thread to see if it helps:

    SCE2010: Computeroverview - Unable to retrieve Date
    http://social.technet.microsoft.com/Forums/en-US/systemcenteressentials/thread/f2564a05-2dbb-44b4-91e4-2e3cdd282610

    Thanks,


    Yog Li -- Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Robert Kruk Monday, July 18, 2011 2:00 AM
    Friday, July 15, 2011 12:05 PM
    Moderator
  • Hi Yog Li,

    thanks for your reply.

    I installed the VMM component on a working MSSCE server that has been running for about a month.

    I am currently running the server as a VM on an ESXi host. (i think I read that VMM should be on a physical).

    Regards

    Rob

    Sunday, July 17, 2011 11:45 PM
  • Thanks Yog,

    Just incase anyone else needs to do this:

    you will need to download the System Center Essentials 2010 Resource Kit from http://www.microsoft.com/download/en/details.aspx?id=191

    and do the following:

    Usage

    1. Click Start, click All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator.
    2. Navigate to the System Center Essentials 2010 installation directory, usually located in %programfiles%\System Center Essentials.
    3. Start the Computer Group Repair Tool by double-clicking LinkDG.exe.
    Monday, July 18, 2011 2:03 AM
  • Hello Fezman,

    Very glad to hear the issue resolved. And thanks for sharing your experience, which can help other community members facing similar problems.

    Also, if you have any further concerns, please do not hesitate to let us know and we are happy to be of further assistance.

    Thanks,


    Yog Li -- Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, July 19, 2011 11:05 AM
    Moderator