none
VMST 3.0 - Template Servicing Jobs don't work RRS feed

  • Question

  • Hi,

     

    I'm trying to implement the Virtual Machine Servicing Tool 3.0. 

    At first our Environment:

     

    - Cluster with 2 Hosts and Hyper-V on Win2008 R2 (Test-Lab)

    - SCVMM and VMST 3.0 on Win2008 R2 (VM)

    - WSUS on Win2008 R2 (VM)

    - Library on the Cluster

     

    I created a "Virtual Machine Template Group" successfully.

    Then I tried to start a servicing job. At first everything seems to be successfull - the Job-Status is "completed" - but the task only took around 1 minute. At the details of the task the preogress Status is "failed".

     

    There is one thing in the "Getting started guide" I didn't understand. I should create a maintenance host group. What is a maintenance host group? I took one Host out of the placing in VMM for testing. Is this enough?

    Is this nessecary to get VMST working?

     

    Here's the log of the failed job:

     

    - <Root>
      <Message Timestamp="01.12.2010 08:52:26">JobName:test12345</Message>
      <Message Timestamp="01.12.2010 08:52:26">Current Process is Microsoft.OfflineVMServicing.Job Process ID is 4628 Process Start Time is 12/01/2010 08:52:23</Message>
      <Message Timestamp="01.12.2010 08:52:26">Script Status is 0</Message>
      <Message Timestamp="01.12.2010 08:52:26">Entering Function : PreRequisite_Execute</Message>
      <Message Timestamp="01.12.2010 08:52:26">C:\Program Files\Microsoft Offline Virtual Machine Servicing Tool\Script</Message>
      <Message Timestamp="01.12.2010 08:52:32">Virtual Machine Status Reterived for Virtual Machine :Gold_W2k3_R2-Std_SP2_x86_DE with hash Table Count as :2 with Status as : True Hard Disk Size : 4.25081586837769 Memory : 4096</Message>
      <Message Timestamp="01.12.2010 08:52:32">Exiting Function : PreRequisite_Execute</Message>
      <Message Timestamp="01.12.2010 08:52:32">Entering Function : CheckPrivateNetwork</Message>
      <Message Timestamp="01.12.2010 08:52:32">Exiting Function : CheckPrivateNetwork</Message>
      <Message Timestamp="01.12.2010 08:52:32">Entering Function : IfNoPrivateNetwork</Message>
      <Message Timestamp="01.12.2010 08:52:32">No Private Network selected for the job.</Message>
      <Message Timestamp="01.12.2010 08:52:32">Exiting Function : IfNoPrivateNetwork</Message>
      <Message Timestamp="01.12.2010 08:52:32">Entering Function : RemoveVMsInIncorrectState_ExecuteCode</Message>
      <Message Timestamp="01.12.2010 08:52:32">Gold_W2k3_R2-Std_SP2_x86_DE: Virtual Machine is in the expected Stored state.</Message>
      <Message Timestamp="01.12.2010 08:52:32">Exiting Function : RemoveVMsInIncorrectState_ExecuteCode</Message>
      <Message Timestamp="01.12.2010 08:52:32">Entering Function : ExcludeCheckpointedVMsForTemplate_ExecuteCode</Message>
      <Message Timestamp="01.12.2010 08:52:32">Exiting Function : ExcludeCheckpointedVMsForTemplate_ExecuteCode</Message>
      <Message Timestamp="01.12.2010 08:52:32">Entering Function : CreateHostVMListForShutdownVMs_ExecuteCode</Message>
      <Message Timestamp="01.12.2010 08:52:32">Exiting Function : CreateHostVMListForShutdownVMs_ExecuteCode</Message>
      <Message Timestamp="01.12.2010 08:52:32">Entering Function : StartPerHostWorkflows_ExecuteCode</Message>
    - <HostList>
    - <Host Name="JUS-HV-LIT10">
      <Message Timestamp="01.12.2010 08:52:32">*************Per Host Workflow START for: JUS-HV-LIT10*************</Message>
      <Message Timestamp="01.12.2010 08:52:34">Host limit iteration 0/7</Message>
      <Message Timestamp="01.12.2010 08:52:34">Total number of Move and Store operations on JUS-HV-LIT10.justiz.sachsen.de host = 0</Message>
      <Message Timestamp="01.12.2010 08:52:34">Total number of allowed Move and Store operations on per host as mentioned in Config = 10</Message>
      <Message Timestamp="01.12.2010 08:52:34">Total number of possible Virtual Machine Servicings that can be started on this host = 10</Message>
      <Message Timestamp="01.12.2010 08:52:34">There are 1 more VMs which are pending to be serviced</Message>
      <Message Timestamp="01.12.2010 08:52:34">Entering Function : GetPendingVMsThatCanBeServiced_ExecuteCode</Message>
      <Message Timestamp="01.12.2010 08:52:49">Maintenance Host rating status is False</Message>
      <Message Timestamp="01.12.2010 08:52:49">Entering Function : HandleGetHostRatingFailures</Message>
      <Message Timestamp="01.12.2010 08:52:49">Unable to retrieve the maintenance host rating.</Message>
      <Message Timestamp="01.12.2010 08:52:49">Unable to mount the virtual machine on maintenance host.</Message>
      <Message Timestamp="01.12.2010 08:52:49">No VM-Host mapping available</Message>
      <Message Timestamp="01.12.2010 08:52:49">Exiting Function : HandleGetHostRatingFailures</Message>
      <Message Timestamp="01.12.2010 08:52:49">No VMs can be serviced on the host JUS-HV-LIT10</Message>
      <Message Timestamp="01.12.2010 08:52:49">Entering Function : CreateListOfVMsToService</Message>
      <Message Timestamp="01.12.2010 08:52:49">Exiting Function : CreateListOfVMsToService</Message>
      <Message Timestamp="01.12.2010 08:52:49">Exiting Function : GetPendingVMsThatCanBeServiced_ExecuteCode</Message>
      <Message Timestamp="01.12.2010 08:52:49">Entering Function : StartPerVMWorkflows_ExecuteCode</Message>
      <VMMObjectList />
      <Message Timestamp="01.12.2010 08:52:49">Exiting Function : StartPerVMWorkflows_ExecuteCode</Message>
      <Message Timestamp="01.12.2010 08:52:49">Host limit iteration 0/7</Message>
      <Message Timestamp="01.12.2010 08:52:49">Total number of Move and Store operations on JUS-HV-LIT10.justiz.sachsen.de host = 0</Message>
      <Message Timestamp="01.12.2010 08:52:49">Total number of allowed Move and Store operations on per host as mentioned in Config = 10</Message>
      <Message Timestamp="01.12.2010 08:52:49">Total number of possible Virtual Machine Servicings that can be started on this host = 10</Message>
      <Message Timestamp="01.12.2010 08:52:49">No more VMs that can be serviced</Message>
      <Message Timestamp="01.12.2010 08:52:49">*************Per Host Workflow END for: JUS-HV-LIT10*************</Message>
      </Host>
      </HostList>
      <Message Timestamp="01.12.2010 08:52:49">Exiting Function : StartPerHostWorkflows_ExecuteCode</Message>
      <Message Timestamp="01.12.2010 08:52:49">Entering Function : PostUpdate_Execute</Message>
      <Message Timestamp="01.12.2010 08:52:50">Exiting Function : PostUpdate_Execute</Message>
      <Message Timestamp="01.12.2010 08:52:50">Entering Function : CleanUpUpadteWorkflow_ExecuteCode</Message>
      <Message Timestamp="01.12.2010 08:52:50">Exiting Function : CleanUpUpadteWorkflow_ExecuteCode</Message>
      </Root>

     

    Thank you guys

    Robert

    Wednesday, December 1, 2010 9:07 AM

Answers

  • This post is older than 30 days or we have not heard back from you.  Did this issue get resolved?  If so, please share with community how you resolved.  Otherwise, re-activate post if you still require assistance.


    Carmen M. Summers (MSFT) --Posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, March 29, 2011 10:58 PM

All replies

  • I can't offer any help, but getting assistance with VMST 3.0 seems non-existent.  I've found the tool more problematic that the problems it is supposed to resolve.

     

     

    Wednesday, December 15, 2010 5:20 AM
  • This post is older than 30 days or we have not heard back from you.  Did this issue get resolved?  If so, please share with community how you resolved.  Otherwise, re-activate post if you still require assistance.


    Carmen M. Summers (MSFT) --Posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, March 29, 2011 10:58 PM