none
Runbooks not appearing while making Rest call to Orchestrator web service. RRS feed

  • Question

  • Hi, 

    I have a small problem whenever i make a rest call through my browser 

    i.e : http://orchServer:81/Orchestrator2012/Orchestrator.svc/Runbooks 

    im not able to see all the runbooks in my orch server. But i can see them throughh the web console.

    I need to see the runbooks so that i can call them through mule server.

    Thanks

    Vineet


    Thanks Vineet

    Wednesday, January 28, 2015 8:57 AM

Answers

  • Hi Vineet,

    Have you over 50 runbooks ? if yes  :

    "For performance reasons, the Orchestrator web service limits the number of entries that are returned by a single request. If you want to retrieve a number of members of a particular collection that exceeds the maximum number for that collection, then you must retrieve multiple pages using multiple requests. For most kinds of objects this limit is 50, but it can be changed through the configuration of the Orchestrator 2012 application in Internet Information Services."

    https://msdn.microsoft.com/en-us/library/hh921660.aspx


    Remy BOVI

    • Proposed as answer by BOVI Rémy Wednesday, January 28, 2015 10:53 AM
    • Marked as answer by VineetReloaded Wednesday, January 28, 2015 11:57 AM
    Wednesday, January 28, 2015 10:53 AM

All replies

  • Hi Vineet,

    Have you over 50 runbooks ? if yes  :

    "For performance reasons, the Orchestrator web service limits the number of entries that are returned by a single request. If you want to retrieve a number of members of a particular collection that exceeds the maximum number for that collection, then you must retrieve multiple pages using multiple requests. For most kinds of objects this limit is 50, but it can be changed through the configuration of the Orchestrator 2012 application in Internet Information Services."

    https://msdn.microsoft.com/en-us/library/hh921660.aspx


    Remy BOVI

    • Proposed as answer by BOVI Rémy Wednesday, January 28, 2015 10:53 AM
    • Marked as answer by VineetReloaded Wednesday, January 28, 2015 11:57 AM
    Wednesday, January 28, 2015 10:53 AM
  • Hi Remy BOVI,

    Thanks buddy.
    I increased the limit from the application settings in IIS.

    Regards,

    Vineet


    Thanks Vineet

    Wednesday, January 28, 2015 12:00 PM