none
SCSM 2012 Portal Install with Wildcard Certificate - Can't get it to work.

    Question

  • Hello,

    I have recently done an install of SCSM 2012 which all went smoothly until I got to the portal install.  This is the first time I have done the install with SSL so I don't have previous installs to base it on but when trying to install both the Web Content Server and SharePoint web parts the installation would fail if the wildcard certificate was selected.  To get the installs to work I used a self-signed cert and then changed the certificates to the wildcard cert after the installs.

    The problem I have is that the portal page loads but the content section is white, I have tried everything I can find online such as changing the Application Setting to include the FQDN but nothing will fix it.

    I have created a DNS record for the web content server address which conforms to the wildcard cert domain and I am able to access the service without getting a certificate warring by browsing to the https:// address, even from the SharePoint server.  The is also a DNS record for the SharePoint portal and Alternate Access Mapping in SharePoint to match.  I can also get to the SharePoint site using https:// without a certificate warning.

    Does anyone have any suggestions?  I have spend a couple of days trying to figure this out.  This post it my last resort before seeing if MS Premier can help.

    Thanks,
    Dustin

    Friday, May 04, 2012 3:28 PM

Answers

  • To close this post out I did get the portal working with HTTPS using wildcard certificates on both servers.

    The problem with the error message about not being able to connect to the WCF was a result of reinstalling the web content server with only HTTP.

    After changing 2 lines that referenced HTTP to HTTPS in the web.config file on the web content server under Service Host it started working.

    • Marked as answer by D. Elliott Monday, May 21, 2012 7:43 PM
    Monday, May 21, 2012 7:43 PM
  • So the problem is half fixed.

    It turns out there must have been an issue with the installation of IIS on the Web Content Server.  After an uninstall and re-install of both IIS and the Web Content Server software for SCSM the portal is successfully running over HTTP.  The problem I was having with not seeing the content of the Settings.xml file is also fixed.

    I have gotten a step further than I was before when attempting to use HTTPS but instead of a blank white screen I now see the "Need Help?" and background of the Silverlight web parts but at the bottom there is an error in red stating that the WCF can't be accessed.  See bottom of screenshot.

    Has anyone been successful in getting the portal running over HTTPS using a wildcard certificate for both the SharePoint site and the Web Content Server?

    Thanks,

    Dustin




    • Edited by D. Elliott Friday, May 11, 2012 9:08 PM
    • Marked as answer by D. Elliott Monday, May 21, 2012 7:43 PM
    Friday, May 11, 2012 8:42 PM

All replies

  • To expand on Dustin's detail.  We have also found the Application Setting for the WebContent_URL to be point to the path within the .svc service declaration and not directly to the path as mentioned in Travis' post (or many other posts) which is the /ContentHost/ClientBin.

    Here is the link to Travis Wright's post: http://blogs.technet.com/b/servicemanager/archive/2012/05/04/faq-why-is-my-self-service-portal-service-catalog-blank.aspx?wa=wsignin1.0&CommentPosted=true#commentmessage

    Any light on this will be greatly appreciated.


    Enrique Lima | Pinnacle of Indiana | http://geekswithblogs.com/enriquelima


    Friday, May 04, 2012 5:37 PM
  • To add to this I am also getting a blank white page when trying to browse directly to the Setting.xml file on the web content server using https://<WebSiteAddress>:443/ContentHost/Clientbin/Settings.xml

    In Travis Wright's post referenced in Enrique's post above he shows it displaying the contents of the XML file.

    I have confirmed I can view the contents of the file when opening it directly from the file system on the web content server.

    Thanks,

    Dustin




    • Edited by D. Elliott Saturday, May 05, 2012 7:47 PM
    Saturday, May 05, 2012 7:46 PM
  • Not sure I can help here, but I can certainly add my experience of this. I have setup our SCSM SSP using a wildcard cert, although i only used it for the sharepoint site. For the web content server i just used a domain CA certificate. And it all works fine.

    However to begin with i got the blank screen, and i messed around with the settings, as like you it seemed to be a conflict between SharePoint and the web content server. But i had tried to install the web content server so as not to use SSL with some random port. So I went back to the beginning, not total as i had a clone just before SSP install luckily, and tried again. This time i followed this technet article to the letter... http://technet.microsoft.com/en-za/library/hh667343%28en-us%29.aspx

    I knew my wildcard cert was working for SharePoint so it must be the web content server that was kicking up a fuss, so that's why in the end i created a Domain cert, so the common name was correct and everything. Hopefully that's fine, only tested internally so far.

    Andrew


    Tuesday, May 08, 2012 9:05 PM
  • So the problem is half fixed.

    It turns out there must have been an issue with the installation of IIS on the Web Content Server.  After an uninstall and re-install of both IIS and the Web Content Server software for SCSM the portal is successfully running over HTTP.  The problem I was having with not seeing the content of the Settings.xml file is also fixed.

    I have gotten a step further than I was before when attempting to use HTTPS but instead of a blank white screen I now see the "Need Help?" and background of the Silverlight web parts but at the bottom there is an error in red stating that the WCF can't be accessed.  See bottom of screenshot.

    Has anyone been successful in getting the portal running over HTTPS using a wildcard certificate for both the SharePoint site and the Web Content Server?

    Thanks,

    Dustin




    • Edited by D. Elliott Friday, May 11, 2012 9:08 PM
    • Marked as answer by D. Elliott Monday, May 21, 2012 7:43 PM
    Friday, May 11, 2012 8:42 PM
  • To close this post out I did get the portal working with HTTPS using wildcard certificates on both servers.

    The problem with the error message about not being able to connect to the WCF was a result of reinstalling the web content server with only HTTP.

    After changing 2 lines that referenced HTTP to HTTPS in the web.config file on the web content server under Service Host it started working.

    • Marked as answer by D. Elliott Monday, May 21, 2012 7:43 PM
    Monday, May 21, 2012 7:43 PM