none
Authoring tool

    Question

  • am trying to install SCSM 2010 Authoring tool on my Laptop " Windows 7 Enterprrise 64 Bit " however am getting error message indicates that i should have VS Shell 2008 SP1 .

    i installed the required software and restarted my machine but am getting the same error message every time.


    Kareem Behery

    Wednesday, February 8, 2012 1:21 PM

Answers

  • I've had this error many times and I'm not really sure what's causing it (thought it might be Visual Studio 2010).

    To get around it, locate the Authoring_PrerequisiteInputFile.xml in the installation media for the Authoring tool and delete the section about checking for Visual Studio Shell 2008.

      <Check Order="03">
        <Id>298B6ABE-8D0E-439e-A692-0C669AF17323</Id>
        <Components>
          <Component>AUTHORING</Component>
        </Components>
        <Title>Microsoft Visual Studio Shell 2008 Check</Title>
        <PassedDescription>Microsoft Visual Studio Shell 2008 is installed</PassedDescription>
        <FailedDescription>Microsoft Visual Studio Shell 2008 is not installed</FailedDescription>
        <Resolution>
          {Hyperlink NavigateUri='..\Prerequisites\VS2K8Shell\en\vs_shell_isolated.exe'}Install Microsoft Visual Studio Shell 2008{/Hyperlink}
          {LineBreak/}The Visual Studio Shell 2008 SP1 setup wizard will start shortly after the file extraction is completed.</Resolution>
        <LogicDelegates>
          <LogicDelegate LogicType="and"
                         DelegateId="vsShell2k8-Error"
                         DelegateNameSpace="Microsoft.SystemCenter.Essentials.SetupFramework.BuiltInDelegates,Microsoft.SystemCenter.Essentials.SetupFramework"
                         DelegateName="RequiredVsShell">{97E3C3BF-76AC-4DEA-BF8A-434F1EA5F272},*,2</LogicDelegate>
        </LogicDelegates>
      </Check>

    Save the file and re-run the setup.

    Regards
    //Anders


    Anders Asp | Lumagate | www.lumagate.com | Sweden | My blog: www.scsm.se

    • Marked as answer by Kareem Behery Thursday, February 9, 2012 11:48 AM
    Thursday, February 9, 2012 8:12 AM
    Moderator
  • http://blogs.technet.com/b/thomase/archive/2014/02/11/problem-installing-the-scsm-authoring-console.aspx

    Please follow above one , it should fix it.

    Tuesday, October 28, 2014 11:26 AM

All replies

  • I had this issue a minute ago as well. But on my computer the SCSM 2010 Authoring Tool was installed already together with the VB Shell 2008 SP1. I deinstalled the SCSM 2010 Authoring Tool and the VB Shell 2008 SP1. If the Prerequisite Check and the Info VB Shell 2008 Sp1 is missing I clicked on "Install ..." in the setup wizard. After the installation finished I did a prereq check again and it is working now.  

    Andreas Baumgarten | H&D International Group


    Wednesday, February 8, 2012 1:56 PM
    Moderator
  • That is what I did , i clicked on Install and the inistallatin wizard appeard and finished successfully. and still the same issue

    Kareem Behery

    Wednesday, February 8, 2012 2:11 PM
  • I've had this error many times and I'm not really sure what's causing it (thought it might be Visual Studio 2010).

    To get around it, locate the Authoring_PrerequisiteInputFile.xml in the installation media for the Authoring tool and delete the section about checking for Visual Studio Shell 2008.

      <Check Order="03">
        <Id>298B6ABE-8D0E-439e-A692-0C669AF17323</Id>
        <Components>
          <Component>AUTHORING</Component>
        </Components>
        <Title>Microsoft Visual Studio Shell 2008 Check</Title>
        <PassedDescription>Microsoft Visual Studio Shell 2008 is installed</PassedDescription>
        <FailedDescription>Microsoft Visual Studio Shell 2008 is not installed</FailedDescription>
        <Resolution>
          {Hyperlink NavigateUri='..\Prerequisites\VS2K8Shell\en\vs_shell_isolated.exe'}Install Microsoft Visual Studio Shell 2008{/Hyperlink}
          {LineBreak/}The Visual Studio Shell 2008 SP1 setup wizard will start shortly after the file extraction is completed.</Resolution>
        <LogicDelegates>
          <LogicDelegate LogicType="and"
                         DelegateId="vsShell2k8-Error"
                         DelegateNameSpace="Microsoft.SystemCenter.Essentials.SetupFramework.BuiltInDelegates,Microsoft.SystemCenter.Essentials.SetupFramework"
                         DelegateName="RequiredVsShell">{97E3C3BF-76AC-4DEA-BF8A-434F1EA5F272},*,2</LogicDelegate>
        </LogicDelegates>
      </Check>

    Save the file and re-run the setup.

    Regards
    //Anders


    Anders Asp | Lumagate | www.lumagate.com | Sweden | My blog: www.scsm.se

    • Marked as answer by Kareem Behery Thursday, February 9, 2012 11:48 AM
    Thursday, February 9, 2012 8:12 AM
    Moderator
  • Thank you very much , it worked and i can now use Authoring tool

    Kareem Behery

    Thursday, February 9, 2012 11:49 AM
  • You sir are a genius :) thanks!
    Thursday, May 10, 2012 7:45 PM
  • Thank you.

    its works.

    Monday, June 25, 2012 10:42 AM
  • I encountered this with the 2012 SP1 authoring tool installation on Windows 8 Pro x64. The removal of the prereq check entry did work, but I'm hoping Microsoft can fix this for the next release of the installer.


    Noah Stahl Percepten.com

    Wednesday, September 25, 2013 6:51 PM
  • http://blogs.technet.com/b/thomase/archive/2014/02/11/problem-installing-the-scsm-authoring-console.aspx

    Please follow above one , it should fix it.

    Tuesday, October 28, 2014 11:26 AM
  • Hello 74KMS, 

    The link that you mentioned was showing the exact same issue i was facing and the solution mentioned in the article solved my problem and now i have the Authoring tool up and running. Cheers !

    Umair


    • Edited by Umair Hadi Monday, August 17, 2015 2:28 PM
    Monday, August 17, 2015 2:27 PM