Advertised Application will not be installed because it might be unsafe - msi


  • I receive the following error below when trying to install a advertised program through add/remove programs and through the run advertised programs applet in control panel. The program is a simple msi.

    "This advertised application will not be installed because it might be
    unsafe. Contact your administrator to change the installation user
    interface option of the package to basic"

    Any reason why?   

    When I go to the ccm cache directory the source file did download, I can install the program from just executing the msi.
    Friday, August 22, 2008 1:58 PM


All replies

  • This is a new one for me..  What is the application?  what command line  


    Friday, August 22, 2008 3:32 PM
  • Hey Matt,
    The command line points to the source directory and I chose Crystal Reports 11.msi from the browse button. The source directory only contains this msi. There are no other directories and files.    

    I have googled the error and here are a couple of links I found:

    And this also came from a completely different vendor, but they received the same error:

    Resolving Windows Installer Errors

    Advertised ... Unsafe

    Windows Installer displays a message saying: ‘This advertised application will not be installed because it might be unsafe. Contact your administrator to change the installation user interface option of the package to basic’.

    This error typically occurs when Araxis Merge has been already been partially installed on your machine by your Network Administrator. In this scenario, Merge is advertised on your computer as being available to use, and will be installed when you try to run it for the first time using the Araxis Merge icon in the Start Menu’s Programs list.

    • Locate the Araxis Merge entry in the Start menu’s Programs list, and click on it to install and run Araxis Merge.
    • Or, open Add/Remove Programs (or in Vista, Programs and Features) in Control panel, locate the Araxis Merge entry in the list of installed applications, and use the controls to Uninstall
      it. You can then install Merge from CDROM of from the setup package that you have downloaded.
    • Or, download the .msi version of the Araxis Merge setup package from the Product Downloads and Updates website. Open a Command Prompt and cd to the folder where you saved the downloaded .msi file. Run the msiexec program as follows: msiexec /qb /I merge2008_win32_????.msi.
    • Or, contact your Network Administrator to see if he/she has any information concerning partial Merge installations on your

    Friday, August 22, 2008 6:57 PM
  • Do you run the application as user or as administrator ? If user try administrator...


    Monday, August 25, 2008 1:11 PM
  • You Rock !!!   Thanks a lot  !! Run the Program as administrator.. I reconfigured the program to run as administrator instead of with user rights. I deleted and recreated the avertisement for the crystal reports program. I ran the newly created advertisement on the machine that I was having an issue with and it installed...    Thank you!! that drove me crazy for 3 days !!
    Monday, August 25, 2008 1:59 PM
  • Running the installation as Administrator was not the root of the problem when I encountered this.


    I experienced it when installing a Visual Studio 2005SE C# outlook 2007 addin. I was following a deployment walkthrough in Part of this incorporates granting "Full Trust" to the installed assembly, which uses an extra DLL to grant the trust (provided as part of the walkthrough - very useful). This additional DLL requires various parameters to be set, which include the construct <Manufacturer>.<AddinName>, which matches the tree structure under the "C:\Program Files" where the addin is installed. The <Manufacturer> element must match the Manufacturer property of the Setup project (right click the Setup project to get at the Properties).


    I had a mismatch between the two, having forgotten to set the Manufacturer property of the setup project. When I installed, the package was installed to the wrong tree under Program Files, which was then not given the Full Trust by the extra security DLL.


    I had to delete all references to my addin in the registry, correct my error and then reinstalled successfully.


    Hope this gives some additional clues.

    Thursday, November 27, 2008 10:46 AM
  • I found this article, which was the solution for me. In my case I was installing a Malwarebytes Enterprise Edition managed client. Hope this helps someone.

    From the command line: msiexec /i setup.msi /qb
    Tuesday, September 09, 2014 7:49 PM