Guest VM's in VMM2012 not joining domain


  • Hi,

    I've setup a Private Cloud using SCVMM 2012 and can successfully deploy a VM using a template I created.  However, for one reason or another, the VM that is generated is not being added to a domain successfully.  I've tried loading up an unattend.xml file containing a domain join but still no success.  The VM doesn't even show that it fails, everything seems to run fine but VM isn't part of the domain.  Anyone any suggestions?  I'm using the correct credentials to domain join in my template.



    Tuesday, April 02, 2013 1:40 PM

All replies

  • The VMM model for domain joining is that it ONLY happens as the VM exits sysprep.

    The assumption here is that the VM can properly resolve the DNS name of the AD Domain Controller as it completes mini-setup.  If DNS resolution is not working or the VM cannot reach the Domain Controller at this time, then the domain join will fail.

    There is a domain join log on the VM at: C:\Windows\debug\Netsetup.log

    Brian Ehlert
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Tuesday, April 02, 2013 4:24 PM