none
How do I edit a Service Request Area on Lists?

Answers

  • Gabriel, to be a SUPER clear ))) You can't delete existing items because they've stored in SEALED management pack. And this is by design. You can change display name but can't remove it.

    http://www.scsmsolutions.com/ freemanru (at) gmail (dot) com

    Monday, April 23, 2012 3:39 PM
    Moderator

All replies

  • Hi Gabriel

    Is it just the entry from Antons Management Pack that you can't change? Or any item?

    I've just checked on my systems and I have no problem just typing in a new entry or overtyping an existing entry in the Name text box which prompts me to save my changes to a new management pack (by default to the service manager service request configuration library).

    Is it just the custom MP that is causing the issue?

    Regards

    Graham


    Regards Graham New System Center 2012 Blog! - http://www.systemcentersolutions.co.uk
    View OpsMgr tips and tricks at http://systemcentersolutions.wordpress.com/

    Monday, April 23, 2012 7:18 AM
    Moderator
  • Are you using the RTM?

    Im using the RTM and can edit the Service Request area without importing the visibility MP.

    Monday, April 23, 2012 8:59 AM
  • To be clear. For this list you can:

    1. Create new items
    2. Create new child items for existing item
    3. Change display name for existing items

    But you can't:

    1. Delete existing items
    2. Move existing item

    The reason for that is what all items for that list stored in sealed management pack.


    http://www.scsmsolutions.com/ freemanru (at) gmail (dot) com

    Monday, April 23, 2012 1:37 PM
    Moderator
  • Anton, thats the problem.

    I want to edit, delete and create new itens from this list. If I remove the Anton's MP still cannot delete some itens I don't have in my company.

    I use RTM version, is not Beta version.

    Monday, April 23, 2012 3:33 PM
  • Gabriel, to be a SUPER clear ))) You can't delete existing items because they've stored in SEALED management pack. And this is by design. You can change display name but can't remove it.

    http://www.scsmsolutions.com/ freemanru (at) gmail (dot) com

    Monday, April 23, 2012 3:39 PM
    Moderator
  • This is a heinous design choice by Microsoft.  I get what you're saying that you can't delete it because it is sealed, but there's no indication of the rationale behind that choice.  I need to be able add, change, delete items from that field . . . PERIOD.  None of the other Work Items' Area lists are this way.  Why should the Service Request Area list be different?

    TsunamiSteve

    Thursday, February 14, 2013 5:39 PM
  • One fun thing to note about editing this list is with an Upgrade to SP1 all of your edited items will be changed back to defaults.  You will need to rename them again.  This happened to my upgrade.  We went from RTM to SP1 ( RTM - RU2 - SP1).  The lists were edited with the RTM and after the SP1 upgrade they were back to defaults.  I inquired about it here. http://social.technet.microsoft.com/Forums/en-US/setup/thread/a1ace71e-8f17-4b73-9d0c-0ff8d5f7bef1/#bf20b6bc-cd02-4c80-91b9-5b5a0c18a828
    Thursday, February 14, 2013 8:42 PM
  • I am in the same situation here. Why would this be a design choice, to not allow us to edit the list here by placing it in a Sealed Management Pack?

    I really need to be able to edit these lists in order to appropriately place jobs within the correct area which related to our organisation, not to relate to Microsoft's organisation.

    Friday, July 26, 2013 1:46 AM
  • You can edit the list in the sense that you can rename the default Microsoft ones and then add new list items.  You just can't delete the ones that were created in the sealed MP.  I am not convinced that this was as much as a design choice as it was an oopsie.  Service Request workitems were added in 2012 and early on (RTM) it was very half baked with lots of strange bugs.  They have been fixing them with every new patch.
    Friday, July 26, 2013 4:37 PM
  • Just in case anyone else comes across this forum entry and wants to remove the default entries:

    https://ramiemad.wordpress.com/2013/12/09/edit-lists-in-seald-mp/

    I'm probably going to following this article but I'm going to log a case with Microsoft first and I know they'll say it's unsupported bla bla bla, but I want to now the repercussions of making this DB edit.

    I think I'll also double-check all my SR Templates BEFORE doing the DB edit just to make sure none of them are referencing these "SR Areas" because I know the Console GUI throws an error if you try to delete an entry which is currently being referenced in a template.

    I agree with another poster (Anton) who basically said that storing these entries in a Sealed management pack was a poor design decision by Microsoft. Not only that, but the Out of the Box entries are horribly incomplete and irrelevant for our business.

    Finally, I've also heard of the renamed Defaults being renamed back (as per Misha's Post) so I'm reluctant to rename the existing options because they may revert. Also, the list items cannot be sorted and moved up and down into alphabetical order... so renaming the Out of the Box options becomes a real nightmare.

    • Proposed as answer by Jason Decou Monday, October 30, 2017 7:04 PM
    Tuesday, May 12, 2015 10:27 PM
  • Try that script on a test system first.  I would also see what happens when you delete those and then apply an update, either a UR, SP, or R2.  I think those MP's get re-added during  updates.  If that is the case you will just need to run the script after any upgrade.   You should be able to query what templates reference those enums with some powershell scripting or with SQL directly before deleting.

    Personally I would be more inclined to do this on a fresh system, not one that has previous production data.

    The way we have addressed this flaw, is I know the MP that stores all the SR list changes.  After any update, I just export and re-import it back.  This fixes the list names.

    Tuesday, May 12, 2015 10:39 PM
  • Worked as expected on a clean install of 2016, will post if I come across any errors but so far this fix has worked as expected.
    Monday, October 30, 2017 7:05 PM
  • Is your change still working fine? have you done any updates since making the change and did they cause any issues?

    Cheers

    Monday, August 20, 2018 8:44 AM