none
install SSP of SCVMM 2008 R2 RTM Eva

    Question

  • I am trying to install SCVMM 2008 R2 RTM Eva on a windows 2008 R2, everything goes fine untill installing the SSP.
    I just can't move any more in the Web Server Settings page(The page which you can change SSP port). Click "Next" doesn't have any effect, whatever the value you changes in any edit box.

    What's wrong?

    Tuesday, September 8, 2009 10:10 AM

Answers

  • I fix the problem by totally create a new vmm db instead of using the old one which has been upgraded by the r2rc upgrade to r2 utility.
    • Marked as answer by Ricky Ren Friday, September 25, 2009 5:33 AM
    Friday, September 25, 2009 5:33 AM

All replies

  • Hi Ricky,

    Just to clarify, when you attempt to click the "Next" button, is the button grayed out or is it "active" but nothing happens when you click it?

    If it is the latter issue, where the Next button is clickable but does not respond, I would check the following things:

    1) On the previous page, ensure that the folder location where you are installing the self service portal to does not contain any special characters. Is this the default path or one you specified?

    2) On the Web Service Settings page that you are having trouble getting past, ensure that the name of the Virtual Machine Manager server is DNS resolvable as it is typed. You should get a popup error message that it cannot resolve the name but sometimes it takes a long time before the resolution fails. You can try typing the fully qualified name of the server. Also to help troubleshooting this issuer, are there any special characters in this computer's name?

    Let me know some of that information and I can try to help you resolve this issue.

    -James

    Wednesday, September 9, 2009 12:10 AM
  • Installation Location Page:
        Program files location:
            C:\Program Files\Microsoft System Center Virtual Machine Manager 2008 R2
            (Same path to install the VMM Server or VMM admin console, can't recall, no error during installation)

    Web Server Settings Page:
        Virtual Machine Manager server:
            No matter write simple machine name, or localhost, or FQDN
        TCP port: 8100 (it's open and pass the firewall)
        Web Server TCP: 80 (if the port is incompatible, click next will pump an error, otherwise just have no effect.)
        No Host header

    The "Next" button is "active". I've install SCVMM 2008 rc, rtm, R2 RC several times, so I quite sure my configuration is fine.
    no any delay error, even 1 day after click, it just has no effect.

    Wednesday, September 9, 2009 3:30 AM
  • Hi Ricky,

    Can you go to the server where this installation failed and browse to this folder : "C:\ProgramData\VMMLogs\". ( ProgramData is often hidden so you will have to type in the path or enable visibility of hidden folders )

    In that folder there should be a SelfServiceSetup.log. Can you send that to me please? I should be able to figure it out from that.

    my email address is
    James [dot] crompton [at] microsoft [dot] com

    Thanks,
    -James
    Wednesday, September 9, 2009 7:29 PM
  • Already send you the log, But I didn't see anything new in the log file when trying to click the "next" button.

    Anyway, non-eva version is available on MSDN now. I am trying to download and install it, hope that version could work as the one before R2 release.
    Friday, September 11, 2009 7:44 AM
  • Hi Ren,

     

    The error appears to be that a default website using the port you selected already exists which is blocking the SSPortal site from being installed. The real mystery is why you are not seeing a popup error message.

     

    Can you confirm that IIS does not already have a website setup which is using this port, or change the port that the portal is being installed to?

    Error:

    Web site Default Web Site has the same address binding as the specified port.Enter a different port or a custom host header for the portal, or delete the conflicting Web site. Then try the operation again.Microsoft.VirtualManager.Setup.Exceptions.BackEndErrorException: Web site Default Web Site has the same address binding as the specified port.

    Enter a different port or a custom host header for the portal, or delete the conflicting Web site. Then try the operation again.


    -James

    Friday, September 11, 2009 5:53 PM
  • As what we've been discussed through email. This is nothing related with IIS web port. If I enter an occupied port, it do pump error box.

    the issue is like when I enter any validate value in this page(using port 81, 82,83, whatever, enter server name as localhost, machine name, FQDN whatever), it just has no action after click the next button, and the selfservicesetup.log has no more records as well.

    I didn some other tries and the result is quite weird.

    I tried to install it on another w2k8 enterprise x64 VM(not R2) and link it to VMM server that I got issue, it can be installed.
    I tried to install it on another physical w2k8 datacenter R2 x64 OS. it works.

    Once I tried it when the Server manager console is uninstall some feature, it will report an error relate with the server manager console.
    My issue server is physical, w2k8 enterprise R2 x64.

    It might be something with the VMM db, I upgrade it from RC by using the upgrade utility.
    Basically I think it was something incompatible with some application or services, just don't know which one.
    Friday, September 18, 2009 9:15 AM
  • I fix the problem by totally create a new vmm db instead of using the old one which has been upgraded by the r2rc upgrade to r2 utility.
    • Marked as answer by Ricky Ren Friday, September 25, 2009 5:33 AM
    Friday, September 25, 2009 5:33 AM
  • Hello James,
    I have the same problem as described by Ricky.
    I'm trying to install the VMM portal on port 81 because the setup gave me an error about Default Web Site been already in use.
    Everything seems OK, but the Next button has no effect.
    When I click Next, nothing happens.
    I've looked behind this window, but no other window is opened to display an error.
    All I can do is Previous or Cancel.
    I have sent to your email the files SelfServiceSetup.log and SelfServiceInspectReport.xml to help you with this issue.

    Thanks,
    Serge

    Thursday, October 1, 2009 2:57 PM
  • Same issue here. I tried many different ports, all have same effect. I deleted the default web site but am still seeing the same behavior where clicking the next button does nothing. This is a fresh install, not an upgrade. Is there a way I can configured the IIS site manually?

    I tried installing manually via the command line as well, but it just exits out:

    setup.exe /eup /i /f VMEup.ini

    VMEup.ini
    [OPTIONS]
    ProgramFiles=D:\Program Files\Microsoft System Center Virtual Machine Manager 2008 R2
    VmmServerName=localhost
    IndigoTcpPort=8100
    SelfServicePortalTcpPort=8080
    SelfServicePortalHeader=scvmm.orcsweb.com
    MUOptIn = 0

    [11/10/2009 11:03:01 PM] Information : End Inspect.
    [11/10/2009 11:03:01 PM] Information : **************************************************************************************
    [11/10/2009 11:03:01 PM] Information : **************************************************************************************
    [11/10/2009 11:03:01 PM] Information : Prerequisite check report start
    [11/10/2009 11:03:01 PM] Information : Prerequisite check report end
    [11/10/2009 11:03:01 PM] Information : **************************************************************************************
    [11/10/2009 11:03:01 PM] Information : Check the filesystem on which VM and prerequisites are installed
    [11/10/2009 11:03:01 PM] Information : D:\Program Files\Microsoft System Center Virtual Machine Manager 2008 R2
    [11/10/2009 11:03:01 PM] Information : C:\Windows\system32
    [11/10/2009 11:03:01 PM] Information : Query free disk space
    [11/10/2009 11:03:01 PM] Data : Folder Path = D:\Program Files\Microsoft System Center Virtual Machine Manager 2008 R2
    [11/10/2009 11:03:01 PM] Data : Free Space = 31203
    [11/10/2009 11:03:01 PM] Information : Query free disk space
    [11/10/2009 11:03:01 PM] Data : Folder Path = C:\Windows\system32
    [11/10/2009 11:03:01 PM] Data : Free Space = 943

    <?xml version="1.0" encoding="utf-8" standalone="yes"?>
    <Inspect Machine="SYSCENTER01">
      <Memory MemorySize="16384" MemoryMinRequired="0" MemoryRecommended="512" Result="0" />
      <DomainRole Result="0" />
      <WinFX>
        <WinFX SoftwareVersion="3.0.4506.4037" Result="0" />
      </WinFX>
      <PwrSh>
        <PowerShell SoftwareVersion="89383-100-0001260-04309" Result="0" />
      </PwrSh>
      <IIS_WWWPService ServiceName="W3SVC" ServiceStatus="Running" Result="0" />
      <IIS6Compatibility Result="0" />
      <IIS7RoleServicesRequired Result="0" />
    </Inspect>


    Jeff Graves, ORCS Web, Inc.
    Wednesday, November 11, 2009 3:52 AM
  • I think I may have finally figured this out. It seems to be that you cannot run the self-service portal on the same system as SCVMM server if you used the defaults during the server installation. I moved SCVMM to a new server and changed the default ports during the installation and the self service portal installed without issue.
    Jeff Graves, ORCS Web, Inc.
    Friday, February 12, 2010 9:36 PM