locked
IIS web.config issues and .vue RRS feed

  • Question

  • Currently I am doing a project for my college class and I am stuck.  I am in a small team that is implementing a simple webserver that will host a public database.  My team member was familiar with .vue and I was familiar with hosting an IIS server.  During implementation, I am having difficulty getting the .vue .html pages to work properly.  From what I have read, I need to modify the web.config file to allow for .vue to work.  However, whenever I modify the web.config file with sample code provided online it fails to work and I get a 500 Internal Error.  With the current web.config file I was able to get the vue page to work once, however it soon stopped working and I do not know where else to look.  Does anyone have any pointers I can look at?

    Website: Joseplh.com

    The server is running Windows 7 and I consider the server disposable...

    Tools: IIS

            Microsoft SQL

            SQL Server Management System (Trial Enterprise edition 180days)

            Node.js

    -----Current web.config-----

    <?xml version="1.0" encoding="UTF-8"?>

    <configuration>
        <system.webServer>
            <directoryBrowse enabled="true" />
        </system.webServer>

    </configuration>

    -----Online Sample-----

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
      <system.webServer>
        <rewrite>
          <rules>
            <rule name="Handle History Mode and custom 404/500" stopProcessing="true">
                <match url="(.*)" />
                <conditions logicalGrouping="MatchAll">
                  <add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
                  <add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" />
                </conditions>
              <action type="Rewrite" url="index.html" />
            </rule>
          </rules>
        </rewrite>
          <httpErrors>     
              <remove statusCode="404" subStatusCode="-1" />                
              <remove statusCode="500" subStatusCode="-1" />
              <error statusCode="404" path="/survey/notfound" responseMode="ExecuteURL" />                
              <error statusCode="500" path="/survey/error" responseMode="ExecuteURL" />
          </httpErrors>
          <modules runAllManagedModulesForAllRequests="true"/>
      </system.webServer>

    </configuration>

    Thursday, June 25, 2020 3:10 AM

All replies

  • Hi ,

    Your question is more related with IIS which our forum doesn't focus on. After discussed with IIS colleague, we suggest you have this asked in IIS forum for better answers. 

    Here is the link:

    https://forums.iis.net/

    The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us. Thank you for your understanding.

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Thursday, June 25, 2020 5:19 AM