none
P2V Error 2927 RRS feed

  • Question

  • I am getting the following error when doing an online P2V.



    Unable to create 'machinename'

    Error (2927)
    A hardware management error has occurred trying to contact server server.domain.internal

    Recommended Action
    Check the WinRM is installed and running on server server.domain.internal. For more information use the command "winrm helpmsg hresult"

    ("server.domain.internal" is the MSSCE2010 server running VMM)

    I have read countless posts on this but cannot find a solution.

    winrm is def working.

    The VM Server and the MSSCE Server are both win2k8 r2, both fully patched.

    I have tried multiple machines, and also fails when doing offline.

    I have watched the transfer, and it seems to successfully finish the BITS transfer process and once that is done it seems to fail? iI can see the new VM in the host server appear, but once it passes the BITS transfer, it then deletes. However the c_drivexxx.VHD file is still in "D:\ProgramData\Microsoft\Windows\Hyper-V\machinename" on the host server.

    I am a bit lost as what to do next, i feel like i have read every post on this error but cannot find any solution.

    Any ideas welcome.
    Wednesday, October 5, 2011 2:44 AM

Answers

  • Ok i finally found the solution.

    I had another web service running using port 443.

    I disabled that and now it works.

    • Marked as answer by Robert Kruk Tuesday, February 7, 2012 12:27 AM
    Tuesday, February 7, 2012 12:27 AM

All replies

  • Hello Fezman,

    Have you ever read this:

    SCVMM 2008 Error (2927) A Hardware Management error has occurred trying to contact server
    http://blogs.msdn.com/b/robertvi/archive/2009/10/23/scvmm-2008-error-2927-a-hardware-management-error-has-occurred-trying-to-contact-server.aspx

    And here is another thread for your reference:

    P2V fails Error (2927) (Unknown error (0x8033811e)
    http://social.technet.microsoft.com/Forums/en-AU/virtualmachinemgrclustering/thread/a70b57f1-1092-4433-bcd0-ff29e4fba72b

    Thanks,


    Yog Li -- Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, October 6, 2011 9:17 AM
    Moderator
  • Hi Yog,

    yes i have already seen those posts and have tried the reg.

    also firewall is off.

    Friday, October 7, 2011 1:10 AM
  • its just strange, it seems to complete copying the server over to a VHD onto the HOST, but then errors out.

    Not sure if there is a log that can maybe help point to a solution?

    Friday, October 7, 2011 3:31 AM
  • ok I just did another test, i did a v2v of an xp machine.

    still same issue, errors out once the vhd file is made.

    however I then created a "new VM" on the HOST, and pointed it to the VHD file that was created. it booted up and is working! (once getting through the windows activation and installing the integration services)

    hmm, will have to test this with a server...

     

    still I would like to figure out why MS SCE2010 is erroring out

     

    I also ran over this post and this

    however i am running win2k3 domain and dont seem to have that "delegation" tab.

    so not sure if its relevant?

    Friday, October 7, 2011 6:17 AM
  • I have also just found out that my domain is still at win2000 level. could this be causing issues?
    Tuesday, October 18, 2011 1:31 AM
  • RESEARCH:
    =======
    This error 2927 has many references.  Following are some KB articles:

    Unable to add a managed host in SCVMM 2008 and SCVMM 2008 R2, Error 2927 (0x8033809d)
    http://support.microsoft.com/kb/970923

    You receive a warning 2927 and an unknown error when you create a virtual machine from a VHD file after you upgrade to System Center Virtual Machine Manager 2008 R2
    http://support.microsoft.com/kb/974869

     
    Suggestions
    ===========
    Is there any further detail from the Error 2927?  Is that a full stack trace in the error output?  Any error codes aside from the 2927?

    We could also look towards the Event Logs or VMM Logs.  These can be found at the following:

    %PROGRAMDATA%\VMMLogs

    Event Logs at the following:

    Administrative Tools / Event Viewer / Applications and Services Logs / VM Manager.


    Ketan Thakkar | Microsoft Online Community Support
    Tuesday, October 18, 2011 12:11 PM
    Moderator
  • Thanks Ketan, I will go over those KB's and will check the logs to see what else I can find.
    Wednesday, October 19, 2011 12:29 AM
  • Ok i finally found the solution.

    I had another web service running using port 443.

    I disabled that and now it works.

    • Marked as answer by Robert Kruk Tuesday, February 7, 2012 12:27 AM
    Tuesday, February 7, 2012 12:27 AM