none
The Management server to which this component reports has not been upgraded - SCOM 2016 RRS feed

  • Question

  • Hello,

    I am upgrading the SCOM 2012 R2 test environment to SCOM 2016 RTM. Below are the two severs:

    1: Server 1 - Management Server

    2: Server 2 - DB&DW Server.

    I have upgraded Management server, Console, Web console, etc successfully however when I am trying to upgrade the Reporting, I am getting "The Management server to which this component reports has not been upgraded" message and the upgrade is not proceeding.

    I have already upgraded the Management Server:

    I don't want to uninstall - reinstall, reporting, please suggest the fix so can upgrade it.

    Thursday, November 10, 2016 7:53 AM

All replies

  • Hey,

    can you please check the log out and paste back here the related stuff. Thanks. Here a ref for the files:

    OpsMgr 2012: My installation failed. What log files do I read and where can I find them?

    Regards,


    Stoyan (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!)

    Thursday, November 10, 2016 10:26 AM
    Moderator
  • We also received this problem when trying to upgrade SCOM 2012 R2 --> 2016.

    The error that I was getting in my log file is:

        <LogInformation>System.TypeInitializationException: The type initializer for 'Microsoft.EnterpriseManagement.Common.Internal.SettingsCacheManager' threw an exception. ---&gt; System.TypeLoadException: Could not load type 'Microsoft.EnterpriseManagement.Mom.InternalSdkOnly.IdUtil' from assembly 'Microsoft.EnterpriseManagement.Core, Version=7.0.5000.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'.
       at Microsoft.EnterpriseManagement.Common.Internal.SettingsCacheManager..cctor()
       --- End of inner exception stack trace ---
       at Microsoft.EnterpriseManagement.Common.Internal.SettingsCacheManager.CreateDataSet()
       at Microsoft.EnterpriseManagement.Administration.Settings..ctor(ManagementGroup managementGroup)
       at Microsoft.EnterpriseManagement.Administration.AdministrationManagement.InitializeSettings()
       at Microsoft.EnterpriseManagement.Administration.AdministrationManagement.GetSettings()
       at Microsoft.EnterpriseManagement.Administration.ComputerHealthService.Reconnect(EnterpriseManagementGroup managementGroup)
       at Microsoft.EnterpriseManagement.Administration.ManagementServer.Reconnect(EnterpriseManagementGroup managementGroup)
       at Microsoft.EnterpriseManagement.Administration.ManagementServer..ctor(MonitoringObject hostComputer, MonitoringObject hostedHealthService)
       at Microsoft.EnterpriseManagement.Administration.AdministrationManagement.CreateManagementServers(IList`1 computerMonitoringObjects, IList`1 healthServiceMonitoringObjects, Pair`2 computerResultsPair)
       at Microsoft.EnterpriseManagement.Administration.AdministrationManagement.GetManagementServers(ManagementServerCriteria criteria)
       at Microsoft.EnterpriseManagement.OperationsManager.Setup.Common.SetupHelpers.GetVersionOfManagementServer(String managementServer)
       at Microsoft.SystemCenter.Essentials.SetupFramework.HelperClasses.OMPrequisiteChecks.ManagementServerAlreadyUpgradedCheck(String arguments, String formatValue)</LogInformation>
      </Result>

    The solution for me was I needed to install the SCOM 2012 R2 Operations Console on my reporting server from the iso file:

    X:\setup\AMD64\Console\OMConsole.msi

    ... which contained the necessary assemblies to connect to the MS and verify that it was running SCOM 2016 RTM already.

    Afterwards, all prerequisite checks passed :-)

    Thursday, December 1, 2016 5:55 PM
  • Hi EricUC,

    I would like to check the current state of this issue .

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, December 5, 2016 2:10 PM
    Moderator
  • Hello,

    I tried this, however its not working as expected. After running the OMConsole.msi from setup file, I am getting below and not the update page.

    Thursday, December 8, 2016 9:45 AM
  • Help!

    I have the same issue, whereby after installing the console, it now thinks the Reporting role doesn't need upgrading!

    The C:\Program Files\System Center Operations Manager 2016 folder structure doesn't have a Reporting node, and in Programs and Features, I can still see the SCOM 2012 R2 Reporting role as being installed!

    How do we upgrade this now?  I tried to run the OMReporting.msi directly off the SCOM 2016 source, but after a minute or so, it fails.

    I tried to run a repair from the SCOM 2016 setup, and it offers the Reporting role, and supposedly repairs it...but it is not SCOM 2016 Reporting I am left with, it's still SCOM 2012 R2!

    Thanks

    Wednesday, March 1, 2017 8:01 PM
  • Fixed mine now thanks!

    Sorry, I had done one minor thing wrong from the above...I installed the SCOM 2016 console instead of the SCOM 2012 R2 console.  Once I removed the 2016 console, installed the 2012 R2 console, closed the SCOM 2016 setup wizard and re-ran it again, the upgrade option came back and worked!

    FYI - without closing the initial 2016 setup first, the prerequisite checker defaulted back to the original message "The Management server to which this component reports has not been upgraded". Once I exited out of there and ran it again from setup, it worked perfectly!

    Awesome, happy times :)

    Thanks again team


    • Edited by Kiwifulla2 Monday, May 29, 2017 12:59 AM typo
    Thursday, March 2, 2017 3:06 AM
  • I can confirm that loading the 2012 R2 Console via the Setup.exe, and not the MSI allows the Reporting Server to be upgraded from 2012 R2 to 2016.
    Thursday, March 23, 2017 11:26 AM
  • Note, if you install the SCOM 2012 R2 Console, remember to patch it up to UR12 or higher, otherwise it still doesn't pass the pre-reqs! 
    • Proposed as answer by Black.C0ffee Wednesday, November 22, 2017 10:45 AM
    Tuesday, May 30, 2017 11:57 AM
  • I had the same issue, and installing the 2012 R2 console with UR11 first resolved the issue.  After 2012 R2 console was installed, I reran the 2016 setup, and it upgraded report server and console without issue.  Thanks !

    Monday, January 8, 2018 8:15 PM