none
There is no existing connection, Win32 error = 5

    Question

  • One of the primary server is unable to communicate to secondary sccm . When I check the sender.log I see following error message

    There is no existing connection, Win32 error = 5

    Error is considered fatal.

    Both servers are in same AD domain. But the DNS suffix on secondary was changed.

    Primary SCCM server tried to connect to secondary SCCM server with old dns suffix. Primary and secondary do not use WINS or host or lmhost files.

    I have checked the following -

    SCCM console, under site properties - Secondary SCCM server has correct "fqdn" name

    New DNS suffix is added to DNS suffix list on Primary server.

    I have flushed the DNS cache on Primary

    Primary sender log shows Pirmary trying to communicate with old DNS suffix

    I removed and readded the sender address

    I have triple checked SCCM primary server computer account is in local admin group of secondary and in sitetosite group of secondary server.

    Is there is any place else in SCCM where this needs to be modified for changes to effective ? or is it a DNS issue ?

    Friday, July 8, 2011 5:59 PM

Answers

All replies

  • 5 is access denied. No ambiguity there.

    Have you tried manually testing the connection between the systems using psexec to impersonate the local SYSTEM account?

    Have you rebooted both?


    Jason | http://myitforum.com/cs2/blogs/jsandys | Twitter @JasonSandys
    Friday, July 8, 2011 6:16 PM
    Moderator
  • Have you done an NSlookup from the box to make sure it sees the correct name.

    Until DNS and other servers update you can update the Host file and add server.foo.com xxx.xxx.xx.xxx

    and get it to force it to see the new name.  If it works then remove it after a while and see if can still communicate correctly via DNS.


    http://www.sccm-tools.com http://sms-hints-tricks.blogspot.com
    Friday, July 8, 2011 8:12 PM
    Moderator
  • Jason, Secondary was rebooted same day when dns suffix was changed. Rebooting primary still has no effect.  Primary Server still tries to make connection to secondary using old dns suffix
    Monday, July 11, 2011 2:10 PM
  • I don't get the connection between a suffix and "access denied". You will only get an "access denied" error if the primary reached the secondary at all - otherwise it would have been something like error 53 (network path not found). You can open a cmd in system context on the primary (using psexec) and check if you can connect to the secondary (dir \\secondary\share)
    Torsten Meringer | http://www.mssccmfaq.de
    Monday, July 11, 2011 3:03 PM
    Moderator
  • Deleted and readded the sender that seems to have resolved the issue
    Tuesday, July 12, 2011 10:14 PM
  • The Error 5 is access error, that is right, it cannot find the path for the parent site. Delete sender and re-enter it with full domain name. (ComputerName.ROOTDOMAIN.COM) and try to restart SMS_LAN_SENDER or reboot the SCCM box.
    • Edited by vnaumoff Monday, March 11, 2013 2:47 PM
    Monday, March 11, 2013 2:47 PM