none
Service Manager 2012 Exchange Connector 3.0 RTM errors

    Question

  • When replying to a Request with the ID# formatted like this [ID194] i am getting:

    Exchange Connector: Unable to process mail item. Subject="RE: An incident has been opened for you.  ID: [IR194]", Error Message=The key value of an object cannot be changed.

    With the old connector I could reply to an email with the ID formatted properly and it would append to the work item.  For some reason I cannot do this wiith the new connector.

    Also, something with the Health service and the 365 email box credentials:

    The Health Service could not log on the RunAs account mycompany.onmicrosoft.com\servicedesk for management group MG_SCSMPD.  The error is Logon failure: unknown user name or bad password.(1326L).  This will prevent the health service from monitoring or performing actions using this RunAs account

    Tuesday, April 30, 2013 1:25 PM

Answers

All replies

  • for office365 you must use basic account instead of windows account. the exception last one exception means what scsm try to check credentials of the mycompany.onmicrosoft.com\servicedesk  windows account nut failed.

    SCSMSolutions
    email: freemanru (at) gmail (dot) com

    Thursday, May 2, 2013 12:13 AM
    Moderator
  • Two things:

    Travis solved my first problem in another post on his blog re: the 3.0 connector release.  The template that I was using somehow had the IR ID embedded in the MP.  I changed my template for the connector and viola!

    For the second problem, mycompany.onmicrosoft.com\servicedesk is the Office365 basic account.  I simply needed to reboot.  I noticed this on the previous version of the connector but forgot.

    Thursday, May 2, 2013 12:43 PM
  • Hi Herb.

    I am seeing the same issue as your first.  However, I have changed the 'Update' incident template to a new one, and still receive the same error.  Also, I have checked the XML and removed everything except for the element to set the incident into an Active state see below:

    <ObjectTemplate ID="Template.dd4faf5d28f5482eb51894590875cbb8" TypeID="Incident!CustomForm_2c5a3b58_d565_47b9_9b76_2e70d3f08e58_TypeProjection">
          <Property Path="$Context/Property[Type='CustomSystem_WorkItem_Incident_Library!System.WorkItem.Incident']/Status$">$MPElement[Name='CustomSystem_WorkItem_Incident_Library!IncidentStatusEnum.Active']$</Property>
        </ObjectTemplate>

    Can you confirm the configuration of your solution please?

    Cheers

    Shaun


    Sunday, May 5, 2013 4:06 PM
  • Hey Guys,


    I have the same issue: "Exchange Connector: Unable to process mail item. Subject= "RE: Please provide additional information for Incident [IR196]", Error Messages= The key value of an object cannot be changed.

    I created a new Incident Template. same error. I opend the template in an XML editor, and renamed the ID.

    Same error.

    Please, if anyone have solved this, please provide an exact description of how to solve this.

    thanks

    Lasse wilén

    Update: I tried with other Incidents, and they seem to Work. So the number 196 is not accepted by SCSM. close to what berg experienced with his IR194. Strange but it Works.

    Update 2 of the day:

    it Works in some cases and in some cases not. When it isnt working the error is consistent with the above mentioned. So far I have not been able to find out why it sometimes fails and why it sometimes does not fail.



    • Edited by Lasse Wilén Tuesday, May 7, 2013 1:26 PM it is not working anyway. Errors seem random and not consistent
    Tuesday, May 7, 2013 9:34 AM
  • Shawn,

    I would create a brand new template.  If you are duplicating the template you are duplicating the problem.  I used a brand new template and it worked on the first try.

    Tuesday, May 7, 2013 4:07 PM
  • I'm experiencing exactly the same thing.  Some incidents, the [Ack], [Resolved], and [Closed] strings work as expected.  Others , this "The key value of an object cannot be changed."  error happens.  I, too, have created and configured brank new templates for both creation and update in the Exchange Connector.


    • Edited by UKCats Tuesday, May 7, 2013 8:04 PM
    Tuesday, May 7, 2013 8:01 PM
  • Hi Herb

    Tried this already.  I am seeing similar behaviour to Lasse Wilen.  It appears to work as expected for some incidents and not others.

    Cheers


    Shaun

    Tuesday, May 7, 2013 8:39 PM
  • I would post your issue here and have Travis take a look:

    http://blogs.technet.com/b/servicemanager/archive/2013/04/26/scsm-exchange-connector-3-0-rtm-released-amp-supported.aspx

    You have prompted me to test mine futher, I will post results soon.


    Wednesday, May 8, 2013 3:39 PM
  • Hi Herb.

    From looking at the mailbox where these are sent, and the email that have been processed, it looks like this affects specific individuals, rather than specific work items, or being random. For example replies from user1@domain.com are successfully processed, whilst replies from user2@domain.com are not processed.  I'm struggling to see what the relationship is at the moment, but I will continue to investigate.

    Cheers

    Shaun

    Thursday, May 9, 2013 3:07 PM
  • I'm having the same problem as everyone else with "the key value of an object cannot be changed"

    I've created new templates, new management packs for new templates, and hacked the XML to the point that the templates aren't updating anything at all. I've verified all my keywords are set to the defaults and the only two that should be parsing are the From: and the [IR###], both of which seem to be working fine and doing their job properly.

    This doesn't seem to be sporadic for me like it is for others. I have 5 emails waiting to be processed now and none of them will update, all different affected users and different IR #s.

    Anyone have new ideas besides changing the template?

    Friday, May 10, 2013 6:32 PM
  • Hi Tom.

    I have a case open with PSS at the moment, so I'll let you know how things go with that over the coming days.

    Cheers

    Shaun

    Sunday, May 12, 2013 11:24 AM
  • I too am having the same issue. 2012 SP1. Exchange 2007. New Templates, MPs, etc.. with no change. I continue to receive the key value error. Mine seems to happen every time for everyone. I turned logging up to 7. I see a flurry of events for each e-mail being processed, but the last few stand out. I changed my real e-mail addresses to generic ones for this example. 

    Exchange Connector: Updating work item: IR539 - Help Account Test

    Exchange Connector: User was found in the database by email address: scsm_user@mydomain.example

    Exchange Connector: Starting to remove mail subject tags.  Starting with: RE: An incident has been created for you [IR539]

    Exchange Connector: Done removing mail subject tags.  End result: An incident has been created for you [IR539]

    Exchange Connector: Adding action log entry.  Display name 'An incident has been created for you [IR539]'.  From: 'User, SCSM'.  Body: '5/3/2013 

    The rest of that event contains the original e-mail before the update. The problem that stands out to me is it appears to have processed fine at this point, however nothing was actually added to the action log. 

    Exchange Connector: Adding a To or CC recipient as a related CI to work item 'IR539 - Help Account Test'.  User email address is scsm_email@mydomain.example

    Exchange Connector: User was found in the database by email address: scsm_email@mydomain.example

    Exchange Connector: Trying to get the template with name 'Template.3e0e9307ff254881a0a16831ab40e30f'

    Exchange Connector: Found the template.  Template name: 'Exchange Connector Template'.  Template ID: '519c4124-ab21-b3e0-abdb-047ed5379c37'

    Exchange Connector: Unable to process mail item. Subject="RE: An incident has been created for you [IR539]", Error Message=The key value of an object cannot be changed.

    Exchange Connector: Done processing emails for email address 'scsm_email@mydomain.example'

    Exchange Connector: Connector 'ExchangeConnector.6c98256f53de4523a2c1adaabfd244f2' is finishing at 5/3/2013 5:39:59 PM UTC

    Exchange Connector: Setting status for Exchange connector 'ExchangeConnector.6c98256f53de4523a2c1adaabfd244f2' to 'Finished Success'

    Exchange Connector: Exchange Connector Execution Completed

    In between some of those events were ones detailing the EWS response, but because of their length I left them out. From this I am left to assume the connector is working and processing e-mails, but is unable to attach to the action log. Has anyone else been able to reproduce this? 

    Thanks

    - Jake

    Monday, May 13, 2013 5:46 PM
  • We too have experienced the errors with "key value of an object cannot be changed", and after extensive testing with exporting xml's, looking for ID fields, creating new templates and so on, we still could not get it to work. As we are working with different customers on this, and some did not have any problems, I noticed that there was a difference between where we had implemented the SendEmail solution and not. And when we removed the SendEmail 2.0 (SendEmail.mpb) Management Pack, updates to incidents with EC 3.0 RTM started working again. We also tried to re-import the SendEmail.mpb from the TechNet Gallery (which by the way is exactly the same version as earlier?), the problem was reintroduced. After removing again, updates are working.
    Would be great to have any input on this from Microsoft. Thanks.

    Jan Vidar Elven

    Tuesday, May 14, 2013 12:55 PM
  • Good work Jan, sending to Travis to take a look.
    Thursday, May 16, 2013 2:31 AM
  • Thankx Jan,

    We had the same problem and after removing the SendEmail mp everything started working again.

    I hope this will be fixed soon because we need the SendEmail function.

    Regard

    Friday, May 17, 2013 11:07 AM
  • I can't seem to find the SendEmail MP. Is this installed by default with SCSM 2012 or something everyone added? 
    Friday, May 17, 2013 12:06 PM
  • Hi tripleSquare,

    Send mail is not part of SCSM out of the box, so this is something you have to implement yourself.

    You Download the bits from here:

    http://gallery.technet.microsoft.com/Service-Manager-SendEmail-8171ba70

    Refered to in this blog: http://blogs.technet.com/b/servicemanager/archive/2013/04/26/scsm-exchange-connector-3-0-rtm-released-amp-supported.aspx

    Please let us know if the installation causes you any trouble. usually the XML cut and paste can be a litle tricky.

    isuue however as you can tell from this thread is that it may or may not Work.

    my current workaround is to implement the Release Code versioin, which Works just fine. (dont tell anyone ;-)  )

    cheers

    Lasse

    Friday, May 17, 2013 12:29 PM
  • Thanks Lasse!

    I definitely don't have that installed. I guess my "key value" error is being caused by something else. Has anyone found any other cause? 

    Friday, May 17, 2013 12:54 PM
  • With Send Mail causing these problems I'm wondering what the advantage is over using the Request User Input task and workflow??
    Friday, May 17, 2013 2:58 PM
  • Hi.

    MS PSS are currently trying to reproduce the issue at the moment.  I haven't heard anything else on this this week, but will update this thread when I have anything back from PSS.

    Cheers

    Shaun

    Friday, May 17, 2013 10:38 PM
  • A comment posted on the SCSM engineering blog seems to indicate a possible cause of an extended incident class with custom properties, but offers no fix at this point. I have an extended incident class, but have yet to enter a support case. 

    Thursday, May 23, 2013 5:20 PM
  • Hi.

    Just had a call with PSS.  This has been reproduced and handed off to the Product Group for a Hot Fix/re-release of the connector.  As yet, no ETA on this.  Recommended work around is to use the RC connector - although this has now been taken down.  As an aside, the more people that raise a case with MS regarding this, or any other issue which is deemed a bug, the higher priority the bug gets.  Therefore, it is likely to get fixed faster if more cases are linked to this issue.

    Cheers

    Shaun


    Thursday, May 30, 2013 4:48 PM
  • Thanks for sharing! Do you know the root reason of this error?


    SCSMSolutions
    email: freemanru (at) gmail (dot) com

    Thursday, May 30, 2013 4:56 PM
    Moderator
  • Thank You Shaun!
    Friday, May 31, 2013 12:10 PM
  • Removing a management pack that extended both Incident and SR class With custom Properties fixed this problem for me. But that's not a a good solution for most People. Let's hope MS fixes it soon.
    Saturday, June 8, 2013 6:41 PM
  • I have same problem.. I extend SR  class.. any news ?
    Tuesday, June 25, 2013 3:23 PM
  • Microsoft told me that this is a known issue and would be resolved in the next release.  No date but if you know how long it took for the last release then you know that this is not good.
    • Proposed as answer by nanou42 Tuesday, June 25, 2013 5:35 PM
    Tuesday, June 25, 2013 4:49 PM
  • really thanks for your reply :)

    I just want to know how, person like me, who use Service Request with extend class, made​​? I have to remove the MP who extend my service request ? and use the existing (default) classes to map elements of my form? So, it does not get too consistent on the portal .. (I mean for the presentation).. 

    Tuesday, June 25, 2013 5:35 PM
  • @nanou42. You can't extend the SR class with Exchange connector 3.0 RTM. A workaround could be to extend the manual activity class with alot of placeholder properties and then use that in your Service Request template. But this is not the most elegant solution. I would go back to the RC version, sadly, but RTM is pretty much broken at the moment. I really hope Microsoft jumps down from the cloud for just a day or two and fix this, as it's an issue for many people.

    Thursday, June 27, 2013 10:42 AM
  • Microsoft published last Monday a re release of the exchange connector 3.0.
    See http://www.microsoft.com/en-us/download/details.aspx?id=38791
    • Marked as answer by Herb Winhoven Thursday, October 10, 2013 2:54 PM
    Thursday, October 10, 2013 6:04 AM
  • Thanks Dennis.

    I like "re-release", but I'd like to see any relevant information about...

    Thursday, October 10, 2013 6:33 AM