none
Removed support for SQL Server 2000 RRS feed

  • Question

  • Hello!

    Regarding the updated SQL MP (6.1.314.35) and removed support for SQL Server 2000:

    What will happen to the existing SQL 2000 MP:s (6.0.6648.0) when importing the new SQL Server Core Library mp, will they still work or is it necessary to uninstall them first?

    If they will not work, is it possible to monitor both 2008 R2 and 2000 in some way, by running new and old MP:s in parallell?

    Sincerely
    Peter

    Thursday, August 12, 2010 12:43 PM

Answers

All replies

  • Hi Peter.

    I have a similar issue at a customer of mine. There are the SQL 2000 servers covered by the SQL 2000 components of the previous SQL Server MP. These two MP components do rely on the core libvrary of the new SQL MP but it runs fine. Also check this posting of mine: http://thoughtsonopsmgr.blogspot.com/2010/08/updated-sql-mp-has-been-released.html

     


    Best regards, Marnix Wolf

     

    (Thoughts on OpsMgr)
    Thursday, August 12, 2010 1:58 PM
    Moderator
  • UPDATE [8/17/2010] - The stand-alone SQL MP package is now posted at http://www.microsoft.com/downloads/details.aspx?FamilyID=8c0f970e-c653-4c15-9e51-6a6cadfca363&displaylang=en

    Stay tuned.  The SQL 2000 MPs are being split off into a seperate MSI and they will be reposted to the MP catalog soon.  The MPs haven't changed at all and will not be updated again, but this will at least make them available while the product is in its last few months of extended support.

    Note: These MP's will happily import with the upgrade SQL Server library MPs.


    This posting is provided "AS IS" with no warranties, and confers no rights. Use of attachments are subject to the terms specified at http://www.microsoft.com/info/cpyright.htm
    Thursday, August 12, 2010 6:10 PM
    Moderator
  • I´m not sure I get it?
     
    Can "Microsoft.SQLServer.Library.mp 6.0.6648.0" run alongside with "Microsoft.SQLServer.Library.mp 6.1.314.36"?
    If not, will monitoring SQL 2000 end the day the library no longer is backward compatible?

    Sincerely
    Peter

    Wednesday, August 18, 2010 3:33 PM
  • Yes, it can. Even better, the MP for monitoring SQL 2000 server has been just released: http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=8c0f970e-c653-4c15-9e51-6a6cadfca363 
    Best regards, Marnix Wolf

    (Thoughts on OpsMgr)
    Thursday, August 19, 2010 7:48 AM
    Moderator
  • Hmm, I don´t think so. If you try to install 6.1.314.36 of the library mp, it will upgrade 6.0.6648.0, not install side by side.

    I know that 6.1.314.36 library is compatible with the 2000 discovery and monitoring, but I thought the "split" was referring to making the 2000-parts completely independant, but that does not seem to be the case. So I think we will have to rely on future releases of the library is compatible also.

    Regards!
    Peter

    Thursday, August 19, 2010 8:21 AM
  • Hi, I understood you wrong. I thought you meant whether the SQL 2000 MP components could function beside the library used for the other version of SQL Server. My mistake. Thanks for keeping me sharp :).
    Best regards, Marnix Wolf

    (Thoughts on OpsMgr)
    Thursday, August 19, 2010 8:47 AM
    Moderator
  • If anyone is still monitoring this question... what is the current status of support for SQL Server 2000?  I find the MP's in the catalog, but they won't download.  And I cannot find them at the links listed in this thread.  Also, cannot find them in the list at this catalog: http://systemcenter.pinpoint.microsoft.com/en-US/applications/search/operations-manager-d11?q=

    Any update would be appreciated.

    Thursday, May 19, 2011 7:43 PM
  • None of the 2000 wave of products has any support any longer.  All of the packs for these unsupported products have been removed and can no longer be downloaded.
    Microsoft Corporation
    Thursday, May 19, 2011 8:03 PM
    Moderator
  • The SQL 2000 MP has been reposted.  It is out of support, but available for download at the following location:

    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=653d9fb9-b1c6-4702-a152-99852dcb2772

     


    Kevin Holman http://blogs.technet.com/b/kevinholman
    Thursday, May 26, 2011 9:00 PM
    Moderator
  • Kevin / Marnix,

    I noticed that there are 3 files in this management pack.

    1. Microsoft.SQLServer.2000.Discovery.mp

    2. Microsoft.SQLServer.2000.Monitoring.mp

    3. Microsoft.SQLServer.Library.mp

     

    Do i need to import #3 also considering that  I already have SQL Server Core Library ver 6.1.400.0 already imported ?

    Again SQL 2000 monitoring is an after thought since we have been monitoring SQL 2005 and SQL 2008 previously.

     

    Thanks

    A

    Friday, June 17, 2011 6:35 PM