System Center 2012 - Help with SSL Certificate


  • I am running System Center 2012 on a single server.  I have an SSL certificate issued through IIS 7 as a Domain CA certificate request.  This works but gives an invalid certificate warning when browsing to the catalog.  The error is because the certificate is issued to the FQDN and the portal link is the machine name (netbios).  

    I have tried creating a certificate using the MMC certificate snap - creating a web server certificate with both the FQDN and the netbios name in the alternative name section.  When I change the binding to use this certificate, my certificate warning goes away but the catalog portal then shows an error "cannot connect to the application server".   Also, if instead of browsing to https://netbios/cmapplicationcatalog  I browse to https://FQDN/cmapplicationcatalog I am prompted for my domain credentials.  I am not prompted if I use the netbios url which is the link in the System Center 2012 Software Center.

    Please direct me to information on what I need to do to get my SSL certificates setup correctly. 

    Thank you

    Fred Zilz

    Monday, April 09, 2012 5:18 PM


All replies

  • Hi,

    Please for the moment all CM2012 related queries should be posted on connect http://innovation.connect.microsoft.com/configmgrbeta/discussions until there is a 2012 forum created.

    Bechir Gharbi | http://myitforum.com/myitforumwp/community/members/bgharbi/ | Time zone : GMT+1

    Monday, April 09, 2012 5:38 PM
  • Ok, I thought since it was released it would be in the regular forum.  PS. I tried the Innovation.connect.microsoft.com and there is a server error - hope this is fixed.

    Fred Zilz

    Monday, April 09, 2012 6:28 PM
  • Have you already had a look at the existing CM12 documentation: http://technet.microsoft.com/en-us/library/gg699362.aspx. The certificate requirements are listed there. Even a step-by-step guide is available: http://technet.microsoft.com/en-us/library/gg682023.aspx

    Torsten Meringer | http://www.mssccmfaq.de

    • Marked as answer by FredZilz Tuesday, April 10, 2012 4:57 PM
    Tuesday, April 10, 2012 8:38 AM
  • Not sure what I did differently this time, but the certificate error is gone.  It is funny that I still can't use the FQDN, but I can the netbios name.  If I use the FQDN I get a request for authentication and then a message that "can not connect to application server"  seems like from the catalog website point and web service point settings that I should be able to use either one.  It seems to be working otherwise.

    Fred Zilz

    Tuesday, April 10, 2012 5:00 PM