locked
It's painful to use Dynamic Optimization in SCVMM 2012 R2 RRS feed

  • Question

  • I asked a similar question in this forum a while ago. Here is the link.

    I read the suggested blogs. However, the pain is persist.

    Here is my environment:
    1. Two computer with Windows Server 2012 R2 and Hyper-V enabled.
    2. One computer with 10GB memory(HV001), another with 4GB(HV002).
    3. With different memory on the computers, so I configured the reserves on the host individually. One HV001, the reserve is 5500MB, another is 1000MB. CPU reserve is the same, 10%. As you can see the following screenshot.

    I created 3 VMs(2 with 1GB memory each other, the 3rd with 512MB) and put them running on the host HV001.
    When I tried to create the 4th VM and put it on HV001, I got the following information.

    However, when I tried to run "OPtimize Hosts" and got the same result like the one in my last post.

    Is there a easy way to use dynamic optimization in SCVMM?

    Monday, July 28, 2014 3:03 PM

Answers

  • Hi Zephyrhu

    I'm sorry that you're having a difficult time with SCVMM. The short answer is, your cluster is overcommitted. That means that, given the high reserves you have configured, SCVMM cannot guarantee that if one node fails, the other node will be able to keep all of your HA VMs running.

    You can turn off cluster overcommit easily. Just check the cluster properties (through SCVMM) and change "cluster reserve" to 0. Then you will be able to continue placing VMs, and hopefully you will also get good results when you attempt to optimize your hosts.

    Hope this helps

    Cheers, Hilton

    Monday, July 28, 2014 10:42 PM

All replies

  • Here is the result when I tried to run "OPtimize Hosts"

    By the way, the thresholds of memory for Dynamic Optimization is 2048MB.
    • Edited by Zephyrhu Monday, July 28, 2014 3:41 PM update
    Monday, July 28, 2014 3:04 PM
  • Hi Zephyrhu

    I'm sorry that you're having a difficult time with SCVMM. The short answer is, your cluster is overcommitted. That means that, given the high reserves you have configured, SCVMM cannot guarantee that if one node fails, the other node will be able to keep all of your HA VMs running.

    You can turn off cluster overcommit easily. Just check the cluster properties (through SCVMM) and change "cluster reserve" to 0. Then you will be able to continue placing VMs, and hopefully you will also get good results when you attempt to optimize your hosts.

    Hope this helps

    Cheers, Hilton

    Monday, July 28, 2014 10:42 PM