none
SCOM 1801 PowerShell Support on Windows server 2008 R2 RRS feed

  • Question

  • Hi Experts,

    SCOM Verson : 1801

    MS1 : OS : windows server 2012 R2

    MS2: OS : Windows server 2016

    MS3: OS : Windows server 2016

    ServiceNow MID Server : OS : Windows Server 2008 R2

    Powershell version on Windows server 2012 R2 and Windows server 208R2 is Same : PS version 5.1

    All our SCOM TAKSs are automated from Service Now. In process of SCOM Environment OS upgrade We we are planning to remove Windows server 2012 R2 Server so that all our SCOM Environment will be on 2016 OS platform.

    ISSUE: When we tried to execute new-scommanagementgroupconnection -Computer MS1 our scripts are working fine

    When we tried executing new-scommanagementgroupconnection -Computer MS2/MS3 we are getting  below exception

      

    New-SCOMManagementGroupConnection : The client has been disconnected from the server. Please call ManagementGroup.Reconnect() to reestablish the connection.
    At line:1 char:1
    + New-SCOMManagementGroupConnection -computername $notificationServer
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (Microsoft.Syste...nnectionCommand:NewSCManagementGroupConnectionCommand) [New-SCManagementGroupConnection], ServerDi 
       sconnectedException
        + FullyQualifiedErrorId : ExecutionError,Microsoft.SystemCenter.Core.Commands.NewSCManagementGroupConnectionCommand

    Is there any workround to fix the PS Connection problem.

    Kind Regards,

    Naveen Kumar B


    ~Bommi

    Thursday, September 27, 2018 1:52 AM

All replies

  • Hi Naveen,

    When you tried running the New-SCOMManagementGroupConnection cmdlet, with what account did you try it and what permissions does the account have?

    Make sure also that these servers don't have any time difference.

    Have you also tried restarting the System Center Data Access Service?

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Thursday, September 27, 2018 3:01 AM
  • Hi Naveen,

    Agree with Leon, I saw many similar issue all caused by time out of sync.

    http://www.opsman.co.za/scom-2016-error-while-connecting-to-management-server-the-client-has-been-disconnected-from-the-server/
    https://itmonitoring.wordpress.com/2014/03/31/the-client-has-been-disconnected-from-the-server-please-call-managementgroup-reconnect-to-reestablish-the-connection-message-in-create-incident-runbooks/
    http://thoughtsonopsmgr.blogspot.com/2009/11/error-client-has-been-disconnected-from.html

    So please confirm it again.

    Best regards,
    Yuxiang



    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, September 27, 2018 3:24 AM