none
The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID RRS feed

  • Question

  • Hi

    I am getting these errors on about 5 of my web servers that have IIS with shared config enabled.

    The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID 
    {05D1D5D8-18D1-4B83-85ED-A0F99D53C885}
     and APPID 
    {AD65A69D-3831-40D7-9629-9B0B50A93843}
     to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.

    This error repeats over and over. But the agent seems to work fine. Does this error create problems for the SCCM agent? I found this post outlining what I think is the solution. Is ther any other way to solve this or is this the only solution? Or is there something else wrong? The error messages are not the same..

    Wednesday, February 15, 2012 1:41 PM

Answers



  • You might need to provide permission using the below instruction.


    1. Click Start -> Run -> Type -> dcomcnfg, expand Component Services -> Computers -> My Computer -> DCOM Config.
    2. Click View -> Detail -> Now you will get Application Name and Application ID in right side.
    3. Scroll down and find the application ID {AD65A69D-3831-40D7-9629-9B0B50A93843} -> Right Click -> Properties and select the Security tab.
    3. Click Customize under "Launch & Activation Permission" -> click Edit -> Add in the account NT AUTHORITY\SYSTEM and set local launch and local activation.
    4. Restart the application Service linked to this Application ID or restart the server and monitor

    _________________________
    .
    Ur's -> SithaYuvaraj

    Tuesday, March 6, 2012 5:30 PM
  • Hi

    I am getting these errors on about 5 of my web servers that have IIS with shared config enabled.

    The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID 
    {05D1D5D8-18D1-4B83-85ED-A0F99D53C885}
     and APPID 
    {AD65A69D-3831-40D7-9629-9B0B50A93843}
     to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.

    This error repeats over and over. But the agent seems to work fine. Does this error create problems for the SCCM agent? I found this post outlining what I think is the solution. Is ther any other way to solve this or is this the only solution? Or is there something else wrong? The error messages are not the same..

    Most times it isn't an issue, try this on for size, some DCOM troubleshooting info

    http://technet.microsoft.com/en-us/library/cc751272.aspx

    HTH

    Monday, February 20, 2012 5:16 PM
    Moderator

All replies

  • Hi

    I am getting these errors on about 5 of my web servers that have IIS with shared config enabled.

    The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID 
    {05D1D5D8-18D1-4B83-85ED-A0F99D53C885}
     and APPID 
    {AD65A69D-3831-40D7-9629-9B0B50A93843}
     to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.

    This error repeats over and over. But the agent seems to work fine. Does this error create problems for the SCCM agent? I found this post outlining what I think is the solution. Is ther any other way to solve this or is this the only solution? Or is there something else wrong? The error messages are not the same..

    Most times it isn't an issue, try this on for size, some DCOM troubleshooting info

    http://technet.microsoft.com/en-us/library/cc751272.aspx

    HTH

    Monday, February 20, 2012 5:16 PM
    Moderator


  • You might need to provide permission using the below instruction.


    1. Click Start -> Run -> Type -> dcomcnfg, expand Component Services -> Computers -> My Computer -> DCOM Config.
    2. Click View -> Detail -> Now you will get Application Name and Application ID in right side.
    3. Scroll down and find the application ID {AD65A69D-3831-40D7-9629-9B0B50A93843} -> Right Click -> Properties and select the Security tab.
    3. Click Customize under "Launch & Activation Permission" -> click Edit -> Add in the account NT AUTHORITY\SYSTEM and set local launch and local activation.
    4. Restart the application Service linked to this Application ID or restart the server and monitor

    _________________________
    .
    Ur's -> SithaYuvaraj

    Tuesday, March 6, 2012 5:30 PM
  • You might need to provide permission using the below instruction.


    1. Click Start -> Run -> Type -> dcomcnfg, expand Component Services -> Computers -> My Computer -> DCOM Config.
    2. Click View -> Detail -> Now you will get Application Name and Application ID in right side.
    3. Scroll down and find the application ID {AD65A69D-3831-40D7-9629-9B0B50A93843} -> Right Click -> Properties and select the Security tab.
    3. Click Customize under "Launch & Activation Permission" -> click Edit -> Add in the account NT AUTHORITY\SYSTEM and set local launch and local activation.
    4. Restart the application Service linked to this Application ID or restart the server and monitor

    The above one work for me. Thank you.

    • Proposed as answer by Sreeraj v v Wednesday, January 16, 2013 1:23 PM
    • Unproposed as answer by Sreeraj v v Wednesday, January 16, 2013 1:23 PM
    Thursday, July 26, 2012 9:49 AM
  • I'm getting these on my database server from SQL Server 2012, with user localhost.

    Trouble is, the classID of the distributed com object listed in the windows event log doesn't appear in the list.

    <rant>It is ridiculous to have to find the class ID manually when there are potentially hundreds of entries there.  Given the age of DCOM, one would think the developers could have implemented a FIND feature</rant>

    • Proposed as answer by lbvangeel Wednesday, December 3, 2014 11:55 PM
    Thursday, January 31, 2013 6:28 PM
  • @ MooseMiester, Ravi

    Same problem with BLBEngine Class (it nor it's AppID are listed in DCOM component services).  This is the error that causes WBAdmin to fail every time.  Did you find any resolution?

    Thanks

    Sean

    Friday, May 24, 2013 11:30 PM
  • I have the exact same issue going on with my servers as well.  Its listed in the error logs but no where to be found in the DCOM components.  So what do you do at this point? 

    Jennifer Knight (MCITP, MCPD)

    • Proposed as answer by kurashviliz Wednesday, August 26, 2015 12:52 PM
    Friday, June 7, 2013 6:58 PM
  • We have a similar error on a print server and can't find the CLSID in DCOM components but I am able to find it in the registry.

    {C97FCC79-E628-407D-AE68-A06AD6D8B4D1} is associated with IPBusEnum, However, when go back to DCOM components, I realize IPBusEnum has an AppID {344ED43D-D086-4961-86A6-1106F4ACAD9B}. So, don't be confused by CLSID and AppID.

    By default, NT AUTHORITY\SYSTEM only has Local Activation permission. I add Local Launch on as instructed and hope it fixes the issue.

    Thanks,

    D

    Friday, June 14, 2013 2:19 PM
  • I have a similar error on a db server  and can't find the CLSID in DCOM components but I am able to find it in the registry.

    application-specific Local Activation {FDC3723D-1588-4BA3-92D4-42C430735D7D} {83B33982-693D-4824-B42E-7196AE61BB05} NT SERVICE SQLSERVERAGENT S-1-5-80-344959196-2060754871-2302487193-2804545603-1466107430 LocalHost (Using LRPC)


    Thanks,

    D


    Wednesday, June 26, 2013 9:36 AM
  • I have the same error on 3 different applications. The problem is I already changed permission and gave full control to the specified user.

    I don't know what to do anymore!

    By the way...should one change the registry key back to the default owner, or can I just leave it like it is after I changed ownership for the problem DCOM entry?

    Thursday, August 1, 2013 9:39 PM
  • Hi,

    If you find the CLSID in the registry then the AppID is listed in the registry entry. You can then match up the relevant DCOM Application ID and set the permissions as you need.

    I found this out after spending an age searching for the CLSID in the DCOM Config :(

    Hope this helps.

    James


    MCTS: Windows Server 2008 Active Directory, Configuring MCTS: Windows 7, Configuring


    Monday, August 5, 2013 9:40 AM
  • Hey There can any one help me with my problem

    Log Name:      System
    Source:        Microsoft-Windows-DistributedCOM
    Date:          30/09/2013 15:00:14
    Event ID:      10016
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          NETWORK SERVICE
    Computer:     myServer
    Description:  The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
    {61738644-F196-11D0-9953-00C04FD919C1}
     and APPID
    {61738644-F196-11D0-9953-00C04FD919C1}
     to the user NT AUTHORITY\NETWORK SERVICE SID (S-1-5-20) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.

    The problem I am having is that if I right click on the CLSID (IIS WARMREG admin Service) and selected the security tab all the entries in the window are not active???

    Can somebody assist please!!

    Monday, September 30, 2013 7:03 PM
  • I assume you mean the security options are greyed out?

    If you are using Windows Server 2008 or below you should be able to edit the component services permissions as long as you are logged in as a member of the local administrators group.

    This was changed in Windows Server 2008 R2 however so you will need to grant permissions for the local administrators group to the registry key.

    The below article explains this process.

    http://blogs.msdn.com/b/emeadaxsupport/archive/2010/01/26/unable-to-edit-the-dcom-settings-for-iis-wamreg-admin-service-on-a-windows-server-2008-r2-when-trying-to-configure-kerberos-authentication-for-role-centers.aspx

    After granting this permission you should be good to go.

    James


    MCTS: Windows Server 2008 Active Directory, Configuring MCTS: Windows 7, Configuring


    • Edited by Jamesatighe Tuesday, October 1, 2013 8:14 AM edit
    Tuesday, October 1, 2013 8:14 AM
  • hello.

    When I go to security tab all of the options are disabled. can't click on them or do something.

    Thursday, March 26, 2015 7:33 AM
  • Buttons are greyed-out...cannot proceed. (logged in as administrator).
    Sunday, October 18, 2015 2:04 PM
  • The properties window is greyed out accross the board, meaning you cannot select or change anything.

    Like you cannot click "Customize" for example

    Now what?

    Thursday, December 17, 2015 9:53 PM
  • Hi,

    At step 03: Should I give the permission to NT AUTHORITY\SYSTEM or the service account which is running the SSIS?

    Thanks,

    zahid

    Thursday, February 11, 2016 1:05 AM
  • Hi everyone. I have similar problem with the dcom error, i ve followed Your suggestions and i managed to find the APPID and CLSID and point it out to RuntimbeBroker. I edited registry settings so the options are not greyed out however the "Add" button is greyed out in "Launch and activation permissions". I ve searched quite alot about this and cant seem to find anything. Please help.
    Sunday, February 14, 2016 8:46 AM
  • Maybe this can help.

    http://xlery.com/blog/2014/04/16/windows-8-1-event-10016/

    Friday, February 19, 2016 9:19 PM
  • To find the application name, run this script in PowerShell.  How to fix is already answered below.

    Of course replace the $CLSID below with the one you are looking for.

    cls
    $CLSID = "{3f2db10f-6368-4702-a4b1-e5149d931371}"
    New-PSDrive -Name HKCR -PSProvider Registry -Root HKEY_CLASSES_ROOT  | Out-Null
    $key = Get-Item "HKCR:\AppID\$CLSID\"
    $values = Get-ItemProperty $key.PSPath
    $values.'(default)'
    Remove-PSDrive -Name  HKCR

    helfrichbc@outlook.com



    • Edited by helfrichbc Saturday, March 12, 2016 6:24 PM Cleanup
    Saturday, March 12, 2016 6:22 PM
  • AD65A69D-3831-40D7-9629-9B0B50A93843} was not found in the list.
    Tuesday, December 27, 2016 1:00 AM
  • Nice writeup about this error is here:

    https://windoh.wordpress.com/2012/05/23/dcom-error-related-to-sccm/

    Monday, January 23, 2017 11:15 AM
  • @scerazy ... thanks.  You are right that is an excellent write up.  And as suggested I'm going to leave alone :) 

    Saturday, March 25, 2017 12:41 PM
  • I have a similar problem:

    The application-specific permission settings do not grant Local Activation permission
    
    for the COM Server application with CLSID 
    {D63B10C5-BB46-4990-A94F-E40B9D520160}
    and APPID 
    {9CA88EE3-ACB7-47C8-AFC4-AB702511C276}
    to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC)
    
    running in the application container Unavailable SID (Unavailable). 
    This security permission can be modified using the Component Services administrative tool.

    Looking for 

    {9CA88EE3-ACB7-47C8-AFC4-AB702511C276}

    in regedit, I find service RuntimeBroker.

    If I go to DCOM Config, Security options are greyed out. I am on a Windows 10 Pro platform upgraded from Windows 7 Pro version.

    I suspect that such a service is a residual of version 7. How can I verify that? In case, should I remove it, and how?


    Dario de Judicibus

    Tuesday, May 2, 2017 8:11 AM


  • You might need to provide permission using the below instruction.


    1. Click Start -> Run -> Type -> dcomcnfg, expand Component Services -> Computers -> My Computer -> DCOM Config.
    2. Click View -> Detail -> Now you will get Application Name and Application ID in right side.
    3. Scroll down and find the application ID {AD65A69D-3831-40D7-9629-9B0B50A93843} -> Right Click -> Properties and select the Security tab.
    3. Click Customize under "Launch & Activation Permission" -> click Edit -> Add in the account NT AUTHORITY\SYSTEM and set local launch and local activation.
    4. Restart the application Service linked to this Application ID or restart the server and monitor

    _________________________
    .
    Ur's -> SithaYuvaraj

    I cannot find the AppID that is showing up in event viewer.  I went one by one and did not find it. Please help as this is the error that shows up after my game crashes, specifically The Division by Ubisoft. Thank you.

    Sunday, May 7, 2017 7:25 PM
  • cant edit in security tab, the options are greyed out
    Saturday, July 8, 2017 3:24 PM
  • The DCOM Config settings are sometimes greyed out for security reasons. To the following to provide permission to Administrator account:

    1. Click Start -> Run -> Type -> regedit, Right Click -> Run as Administrator
    2. Click Edit -> Find -> Type -> the application ID that you want to modify in Component Services
    3. Right Click -> Permissions -> Advanced -> Owner tab -> change owner to local Administrators group and click on Apply, then OK.
    4. Under Permissions window, select the local Administrators group and under Permissions for Administrators select Full Control and click on Apply, then OK.
    5. Re-run the Component Services management console (dcomcnfg.exe) and you should now be able to modify the settings.

    • Proposed as answer by coreynolds Sunday, June 10, 2018 3:00 AM
    Wednesday, July 19, 2017 6:24 PM
  • Here is how to fix grayed out radio buttons.
    Tuesday, October 17, 2017 8:41 AM
  • To SithaYuvara:

    I have

    The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID 
    {D63B10C5-BB46-4990-A94F-E40B9D520160}
     and APPID 
    {9CA88EE3-ACB7-47C8-AFC4-AB702511C276}
     to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

    I can follow your instructions in the first 3 steps.  But on the fourth step (which is your second step "3") i find that "customize " is already selected, but both Use-Default and Customize are grayed and cannot be changed.  And when I select "Edit" as you suggest, i get the following error:

    "One or more of the permission entries attached to Registry Value has an unrecognized type and can not be displayed."  

    When i got this error I selected "OK" (the only choice).  However I am still not able to add any permissions because both the "Add" and "Remove" buttons are grayed.

    Do you have any suggestions??



    Sunday, October 22, 2017 3:44 AM


  • You might need to provide permission using the below instruction.


    1. Click Start -> Run -> Type -> dcomcnfg, expand Component Services -> Computers -> My Computer -> DCOM Config.
    2. Click View -> Detail -> Now you will get Application Name and Application ID in right side.
    3. Scroll down and find the application ID {AD65A69D-3831-40D7-9629-9B0B50A93843} -> Right Click -> Properties and select the Security tab.
    3. Click Customize under "Launch & Activation Permission" -> click Edit -> Add in the account NT AUTHORITY\SYSTEM and set local launch and local activation.
    4. Restart the application Service linked to this Application ID or restart the server and monitor

    _________________________
    .
    Ur's -> SithaYuvaraj

    My Error: The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {D63B10C5-BB46-4990-A94F-E40B9D520160} and APPID {9CA88EE3-ACB7-47C8-AFC4-AB702511C276} to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

    I follow steps 1 and 2, but when I get to three? My APPID isn't listed in the DCOM Config.... Help?

    Sunday, January 21, 2018 2:16 PM
  • What if you can't find the APP ID?
    Saturday, February 17, 2018 2:44 PM
  • It says: "Unable to save permission changes on {6B3B8D23-FA8D-40B9-8DBD-B950333E2C52}, Access is denied."

    I am running the regedit as an administrator, and for the past couple months straight, I have been trying to narrow down the cause of sudden BSoD-less crashes which have since been occurring with increasing frequency, without any success. I am having trouble finding the cause of it with all these DistributedCOM errors clogging up the event viewer log dated at the same time as when the crashes occur. If I fix this error on my end, it should get a clearer picture of what happens with my computer the next time the crash happens, provided that it isn't the cause of them.

    Thursday, February 22, 2018 11:31 PM
  • First how in the world is there no way MS can patch this problem? I have lots of choice words I'd like to use but they'd probably get me banned from the forum. This whole thing is utterly ridiculous. Multi-billion dollar company, 80-90% of business world wide using their OS (on the clients anyway) and they just go "oh yeah here's some work arounds.....k bye....going to swim in money now...")...

    Anyway I've highly appreciative of those trying to help but the steps provided for the dcomcnfg.exe thing ain't working on my end (Windows 10 btw) ....I mean DCOM config opens and I can follow along but I don't see my app id listed... of course there's 9.8 billion entries in no sane order...(another beautiful design to facilitate troubleshooting....thanks MS).... but besides that.... there's multiple DIFFERENT CLSIDs in my log (I just noticed as I was scrolling through) all at different dates and times that it happened playing a game. 

    You mean the only fix is doing this tedious and time sucking process EVERY TIME?

    Saturday, May 5, 2018 12:13 AM
  • Hi,

    Logged As Administrator but i can't edit nothings :/ security tab is not editable !!!

    any suggestions please.

    THX

    Friday, June 8, 2018 8:52 AM
  • Nope, not working.
    Saturday, August 18, 2018 6:26 PM
  • I agree wholeheartedly. The sooner Microsoft ceases to exist the better off the world will be.
    These kinds of issues come up all the time - in my case after a Windows Update that I can not refuse and can not rollback. There are thousands of IT professionals spending hundreds of hours each solving problems that were forced onto them by Microsoft.

    There must be a better way that this :-(


    Software architect and development veteran.

    Tuesday, December 25, 2018 6:31 PM
  • This error is crashing my brand new Win10 laptop with AMD Ryzen5 at least once a week. 

    The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID

    {2593F8B9-4EAF-457C-B68A-50F6B8EA6B54}
     and APPID
    {15C20B67-12E7-4BB6-92BB-7AFF07997402}
     to the user NORLBU\Norlbu SID (S-1-5-21-2097794364-1621188666-1132795717-1001) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

    I have not attempted to try to fix this yet but its annoying. Reading through all this stream of posts and not sure any of it works.

     
    Sunday, January 27, 2019 2:27 AM
  • Microsoft needs to provide a "Click here to fix this" button in the event viewer when the repair is recommended.

    After all we do have a computer here to help us.

    Saturday, February 16, 2019 9:25 PM
  • I'm having the same issue, I followed the steps outlined above, but when I find the component service and go to properties I cannot modify any permissions. I am an administrator on my computer and when I opened the Component Services I chose to run as administrator. There is a non-existant ID (Displays the SID with a question mark) showing up in names that I cannot remove as well. 
    Wednesday, June 19, 2019 3:27 PM
  • Use nsudo & run as either system or trustedinstaller
    Wednesday, June 19, 2019 6:37 PM