locked
Reports not populating in SCCM Console or in reports web page RRS feed

  • Question

  • I'm having an issue with a newly installed Reporting Services role where the reports aren't populating in the SCCM console or in the SSRS web page. I can browse to both Report Manager at  http://%servername%/reports and Report Server at http://%servername%/ReportServer and I can see the ConfigMgr_XXX folder with a GUID object in Configmgr_XXX folder. In the srsrp.log file I see:

    Could not retrieve the reporting service name for instance 'MSSQLSERVER'

    Invalid class

    Could not stop the reporting service "

    I found several articles describing registering a sqlmgmproviderxpsp2up.mof but I can't find that file anywhere.  I did find a reportingservices.mof in an SSRS folder but it didn't seem to help the issue.  I have also completely uninstalled and reinstalled the Reporting role in SCCM.  Another thing I notice is the key HKLM\Software\Microsoft\SMS\SRSRP > SRSInitializeState is still set to 0 which tells me its never been able to import the reports.

    What am I missing?

    Connor

    Wednesday, July 6, 2016 5:32 PM

Answers

All replies

  • The error does suggest that WMI is an issue.

    I found sqlmgmproviderxpsp2up.mof within the C:\Program Files (x86)\Microsoft SQL Server\120\Shared

    

    Garth Jones

    Blog: http://www.enhansoft.com/blog Old Blog: http://smsug.ca/blogs/garth_jones/default.aspx

    Twitter: @GarthMJ Book: System Center Configuration Manager Reporting Unleased

    Wednesday, July 6, 2016 7:29 PM
  • Success!  Our SQL admins install SQL on a separate drive so I was looking on that drive for the .mof file but I found it on the C: drive right where everyone said it would be. It looks like SQL still installs some things to C: even when the application is installed somewhere else.

    I imported the mof file and almost immediately the reports started to load.  I still see some errors in the srsrp.log file but so far everything seems to be working much better.  I think we can call this one resolved.  If I still have problems I'll post a new thread.

    Thanks Garth!

    Connor of Clan McCloud

    Wednesday, July 6, 2016 7:51 PM
  • Hi Garth, I have the same error, I believe I have reporting services working as I can browse the reports url and manually import the rdl files, if I look in wmi I can see the class for the reporting server.

    __GENUS                          : 2
    __CLASS                          : MSReportServer_ConfigurationSetting
    __SUPERCLASS                     :
    __DYNASTY                        : MSReportServer_ConfigurationSetting
    __RELPATH                        : MSReportServer_ConfigurationSetting.InstanceName="MSSQLSERVER"
    __PROPERTY_COUNT                 : 34
    __DERIVATION                     : {}
    __SERVER                         : LAB-CM1
    __NAMESPACE                      : root\Microsoft\SqlServer\ReportServer\RS_MSSQLSERVER\v13\Admin
    __PATH                           : \\LAB-CM1\root\Microsoft\SqlServer\ReportServer\RS_MSSQLSERVER\v13\Admin:M
                                       ver_ConfigurationSetting.InstanceName="MSSQLSERVER"
    ConnectionPoolSize               : 768
    DatabaseLogonAccount             :
    DatabaseLogonTimeout             : -1
    DatabaseLogonType                : 2
    DatabaseName                     : ReportServer
    DatabaseQueryTimeout             : 120
    DatabaseServerName               : LAB-CM1
    ExtendedProtectionLevel          : Off
    ExtendedProtectionScenario       : Proxy
    FileShareAccount                 :
    InstallationID                   : {8c2760a7-ab5b-443a-b697-76063b8285c8}
    InstanceName                     : MSSQLSERVER
    IsInitialized                    : True
    IsPowerBIFeatureEnabled          :
    IsReportManagerEnabled           : True
    IsSharePointIntegrated           : False
    IsWebServiceEnabled              : True
    IsWindowsServiceEnabled          : True
    MachineAccountIdentity           : LABDC1\LAB-CM1$
    PathName                         : C:\Program Files\Microsoft SQL Server\MSRS13.MSSQLSERVER\Reporting
                                       Services\ReportServer\RSReportServer.config
    SecureConnectionLevel            : 0
    SenderEmailAddress               :
    SendUserName                     :
    SendUsingSMTPServer              : True
    ServiceName                      : ReportServer
    SMTPAuthenticate                 : 0
    SMTPServer                       :
    SMTPUseSSL                       : False
    UnattendedExecutionAccount       :
    Version                          : 13.0.5026.0
    VirtualDirectoryReportManager    : Reports
    VirtualDirectoryReportServer     : ReportServer
    WindowsServiceIdentityActual     : LocalSystem
    WindowsServiceIdentityConfigured : LocalSystem
    PSComputerName                   : LAB-CM1

    SCCM Roles and SQL are on one Virtual machine.

    Reporting services keeps creating new data sources so I have over 200 of them.

    I have done the mofcomp sqlmgmproviderxpsp2up.mof , rebooted and no change.

    Any ideas will be much appreciated.

    cheers Dene

    Tuesday, March 26, 2019 6:06 AM
  • Hi Zach, did you ever fix this? I'm getting the exact same issue and i can't work it out!

    Thanks

    Nik


    http://nikifoster.blogspot.com/

    Wednesday, August 5, 2020 6:06 PM
  • Hi Zach, did you ever fix this? I'm getting the exact same issue and i can't work it out!

    Thanks

    Nik


    http://nikifoster.blogspot.com/

    Did you review the srsrp.log? What error does it display? 

    Garth Jones

    Blog: https://www.enhansoft.com/blog Old Blog: https://sccmug.ca/

    Twitter: @GarthMJ Book: System Center Configuration Manager Reporting Unleashed

    Wednesday, August 5, 2020 6:14 PM
  • Hi Garth, yes I did! Its not too helpful, I just get this every minute:

    Timed Out... SMS_SRS_REPORTING_POINT 8/5/2020 1:40:44 PM 996 (0x03E4)
    Set configuration SMS_SRS_REPORTING_POINT 8/5/2020 1:40:44 PM 996 (0x03E4)
    Check state SMS_SRS_REPORTING_POINT 8/5/2020 1:40:44 PM 996 (0x03E4)
    Check server health. SMS_SRS_REPORTING_POINT 8/5/2020 1:40:44 PM 996 (0x03E4)
    Successfully created srsserver SMS_SRS_REPORTING_POINT 8/5/2020 1:40:44 PM 996 (0x03E4)
    Created service with byPass proxy setting: http://hcidalas37. SMS_SRS_REPORTING_POINT 8/5/2020 1:40:44 PM 996 (0x03E4)
    Reporting Services URL from Registry [http://hcidalas37/ReportServer/ReportService2005.asmx] SMS_SRS_REPORTING_POINT 8/5/2020 1:40:44 PM 996 (0x03E4)
    Reporting Services is running SMS_SRS_REPORTING_POINT 8/5/2020 1:40:44 PM 996 (0x03E4)
    Retrieved datasource definition from the server. SMS_SRS_REPORTING_POINT 8/5/2020 1:40:44 PM 996 (0x03E4)
    Retrieved datasource definition from the server. SMS_SRS_REPORTING_POINT 8/5/2020 1:40:44 PM 996 (0x03E4)
    [HCIDALAS37.HCI.pvt] [CM_HHQ] [ConfigMgr_HHQ] [HCIDALAS37.HCI.PVT] SMS_SRS_REPORTING_POINT 8/5/2020 1:40:44 PM 996 (0x03E4)
    [MSSQLSERVER] [1] [] [HUNTOIL\SCCM-SQLReporting] SMS_SRS_REPORTING_POINT 8/5/2020 1:40:44 PM 996 (0x03E4)
    [1] [0] SMS_SRS_REPORTING_POINT 8/5/2020 1:40:44 PM 996 (0x03E4)
    Confirmed version [12.0.5223.6] for the Sql Srs Instance. SMS_SRS_REPORTING_POINT 8/5/2020 1:40:44 PM 996 (0x03E4)
    Extract resource language packs if exists SMS_SRS_REPORTING_POINT 8/5/2020 1:40:44 PM 996 (0x03E4)
    Loading localization resources from directory [E:\Program Files\SMS_SRSRP\SrsResources.dll] SMS_SRS_REPORTING_POINT 8/5/2020 1:40:44 PM 996 (0x03E4)
    Looking for 'English (United States)' resources SMS_SRS_REPORTING_POINT 8/5/2020 1:40:44 PM 996 (0x03E4)
    Looking for 'English' resources SMS_SRS_REPORTING_POINT 8/5/2020 1:40:44 PM 996 (0x03E4)
    Found resources for 'English' SMS_SRS_REPORTING_POINT 8/5/2020 1:40:44 PM 996 (0x03E4)
    Successfully get report server from Registry SMS_SRS_REPORTING_POINT 8/5/2020 1:40:44 PM 996 (0x03E4)
    Next security configuration at [8/5/2020 1:45:38 PM] SMS_SRS_REPORTING_POINT 8/5/2020 1:40:45 PM 996 (0x03E4)
    Retrieved datasource definition from the server. SMS_SRS_REPORTING_POINT 8/5/2020 1:40:45 PM 996 (0x03E4)
    Updating data source {5C6358F2-4BB6-4a1b-A16E-8D96795D8602} at ConfigMgr_HHQ SMS_SRS_REPORTING_POINT 8/5/2020 1:40:45 PM 996 (0x03E4)
    Retrieved datasource definition from the server. SMS_SRS_REPORTING_POINT 8/5/2020 1:40:45 PM 996 (0x03E4)
    Updating data source {39B693BB-524B-47DF-9FDB-9000C3118E82} at ConfigMgr_HHQ SMS_SRS_REPORTING_POINT 8/5/2020 1:40:45 PM 996 (0x03E4)
    Successfully get report server from Registry SMS_SRS_REPORTING_POINT 8/5/2020 1:40:45 PM 996 (0x03E4)
    Moved folder from /ConfigMgr_HHQ to /ConfigMgr_HHQ.OLD.22. SMS_SRS_REPORTING_POINT 8/5/2020 1:40:45 PM 996 (0x03E4)
    Created folder [ConfigMgr_HHQ]. SMS_SRS_REPORTING_POINT 8/5/2020 1:40:45 PM 996 (0x03E4)
    Creating data source {5C6358F2-4BB6-4a1b-A16E-8D96795D8602} at ConfigMgr_HHQ SMS_SRS_REPORTING_POINT 8/5/2020 1:40:45 PM 996 (0x03E4)
    Creating data source {39B693BB-524B-47DF-9FDB-9000C3118E82} at ConfigMgr_HHQ SMS_SRS_REPORTING_POINT 8/5/2020 1:40:45 PM 996 (0x03E4)
    Could not retrieve the reporting service name for instance 'MSSQLSERVER' SMS_SRS_REPORTING_POINT 8/5/2020 1:40:45 PM 996 (0x03E4)
    Could not stop the reporting service '' SMS_SRS_REPORTING_POINT 8/5/2020 1:40:45 PM 996 (0x03E4)
    Successfully get report server from Registry SMS_SRS_REPORTING_POINT 8/5/2020 1:40:45 PM 996 (0x03E4)
    Next security configuration at [8/5/2020 1:45:38 PM] SMS_SRS_REPORTING_POINT 8/5/2020 1:40:46 PM 996 (0x03E4)
    Root Folder exists SMS_SRS_REPORTING_POINT 8/5/2020 1:40:46 PM 996 (0x03E4)
    Next SRS usage data collection at [8/6/2020 12:33:20 PM] SMS_SRS_REPORTING_POINT 8/5/2020 1:40:46 PM 996 (0x03E4)
    Current ReportServerVersion: 12.0.5223.6 SMS_SRS_REPORTING_POINT 8/5/2020 1:40:46 PM 996 (0x03E4)
    Power BI supported Server version: 15.0.1102.620 SMS_SRS_REPORTING_POINT 8/5/2020 1:40:46 PM 996 (0x03E4)
    Current ReportServerVersion doesn't support Power BI reports SMS_SRS_REPORTING_POINT 8/5/2020 1:40:46 PM 996 (0x03E4)
    No report file information found. SMS_SRS_REPORTING_POINT 8/5/2020 1:40:46 PM 996 (0x03E4)
    No PowerBI report file information found. SMS_SRS_REPORTING_POINT 8/5/2020 1:40:46 PM 996 (0x03E4)
    Successfully checked that the SRS web service is healthy on server HCIDALAS37.HCI.PVT SMS_SRS_REPORTING_POINT 8/5/2020 1:40:46 PM 996 (0x03E4)
    Registry change SMS_SRS_REPORTING_POINT 8/5/2020 1:40:46 PM 996 (0x03E4)
    Waiting for changes for 1 minutes SMS_SRS_REPORTING_POINT 8/5/2020 1:40:46 PM 996 (0x03E4)
    SRSRP registry key change notification triggered. SMS_SRS_REPORTING_POINT 8/5/2020 1:40:46 PM 996 (0x03E4)
    Registry change SMS_SRS_REPORTING_POINT 8/5/2020 1:40:46 PM 996 (0x03E4)
    Waiting for changes for 1 minutes SMS_SRS_REPORTING_POINT 8/5/2020 1:40:46 PM 996 (0x03E4)

    When I look in the SSRS site, it seems to be recreating my folder every minute:

    I've tried reinstalling the RSP multiple times but keep getting this same issue.


    http://nikifoster.blogspot.com/

    Wednesday, August 5, 2020 6:42 PM
  • So I got it working...

    I had PowerBI Report Server installed and I guess this was screwing something up. After I removed it and restarted the box, all the reports started populating!


    http://nikifoster.blogspot.com/

    Wednesday, August 5, 2020 7:08 PM
  • So I got it working...

    I had PowerBI Report Server installed and I guess this was screwing something up. After I removed it and restarted the box, all the reports started populating!


    http://nikifoster.blogspot.com/

    Power BI report Server does work, have have several blogs on the topic. There are some issues with it, but I didn't see any of the errors within your log snipit. So... 

    Garth Jones

    Blog: https://www.enhansoft.com/blog Old Blog: https://sccmug.ca/

    Twitter: @GarthMJ Book: System Center Configuration Manager Reporting Unleashed

    Wednesday, August 5, 2020 7:39 PM
  • I should say Power BI Report Server does works with CMCB 2002 or later.  

    Garth Jones

    Blog: https://www.enhansoft.com/blog Old Blog: https://sccmug.ca/

    Twitter: @GarthMJ Book: System Center Configuration Manager Reporting Unleashed

    Wednesday, August 5, 2020 7:41 PM
  • Yep, it does and ive got it working now. I think I had both PowerBI Server and SQL Reporting Services installed - this caused the issue.

    Thanks for your help Garth.


    http://nikifoster.blogspot.com/

    Thursday, August 6, 2020 3:06 PM