none
Host management credentials greyed out VMM

    Question

  • Hello,

    I am trying to add a file share storage to our cluster in VMM. But when doing that it gives an error saying "No Run As account is associated with the host. You have not specified a Run As account for your host."

    Some googling on that issue points me to add "Host Access" on each specific host, so far so good.

    But in order to do that I go to properties on a host and select "Host Access" but the "Run As account"-field is greyed out. Why is that? I cant find a single similar case when googling which leaves me out of ideas.

    So anyone with an idea why this field is greyed out?

    We are running a 4 node Hyper-V cluster and have just set up VMM, the VMM is running on the cluster - I hope this won't cause any issues.

    Thursday, March 07, 2013 10:05 AM

Answers

  • Kristian: I admire your knowledge. But I think you are wrong this time.
    You can update the credentials in a running cluster without removing it from VMM.
     Why it´s grayed out I leave to someone at MSFT to answer.

    A little bit of this: http://technet.microsoft.com/en-us/library/hh801619.aspx
    and a little bit of this: http://technet.microsoft.com/en-us/library/hh801522.aspx

    Can result in something like this:

    $YourCluster = Get-SCVMHostCluster -Name YOUR-CLUSTER-NAME

    $YourRunAs = Get-SCRunAsAccount -Name "YOURRUNASACCOUNT"

    Set-SCVmHostCluster -VMHostCluster $YourCluster -VMHostManagementCredential $YourRunAs

    This one works like a charm for VMM 2012 SP1 for Windows 2008 R2 and 2012 clusters.

    Do you want to update the old threads related to the same subject or do you want me to do it? ;)

    Monday, May 20, 2013 8:52 AM
  • Once you have a cluster in VMM, you can't change this setting.

    The only solution is to remove the cluster (and this will eventually break the visability of NIC teaming - if you are using this, in VMM) and add the cluster again, specifying a correct run as account.

    -kn


    Kristian (Virtualization and some coffee: http://kristiannese.blogspot.com )

    Monday, March 11, 2013 4:47 PM
    Moderator

All replies

  • Once you have a cluster in VMM, you can't change this setting.

    The only solution is to remove the cluster (and this will eventually break the visability of NIC teaming - if you are using this, in VMM) and add the cluster again, specifying a correct run as account.

    -kn


    Kristian (Virtualization and some coffee: http://kristiannese.blogspot.com )

    Monday, March 11, 2013 4:47 PM
    Moderator
  • Hi,

    Did you try the solution proposed by Kristian ?

    Thanks for the answer ... 


    David LACHARI
    MVP Virtual Machine - VCP et VTSP vSphere 4.1
    Blog DansTonCloud
    Auteur du livre Hyper-v v2 sous Windows Server 2008 R2

    Tuesday, March 12, 2013 11:16 AM
  • I had the same problem, I had to delete the cluster, assign the account, reboot hosts, then rebuild the cluster.

    Resolved the issue for me.

    Wednesday, March 13, 2013 6:20 PM
  • Hi Kristian,

    Yeah~Resolved the issue, this solution is worked for me.

    Thank you very much!


    Technology changes life……

    Wednesday, March 20, 2013 6:47 AM
  • Hey,

    can this be done during production?

    Are the running VMs affected?

    Regards

    Friday, May 17, 2013 1:00 PM
  • Kristian: I admire your knowledge. But I think you are wrong this time.
    You can update the credentials in a running cluster without removing it from VMM.
     Why it´s grayed out I leave to someone at MSFT to answer.

    A little bit of this: http://technet.microsoft.com/en-us/library/hh801619.aspx
    and a little bit of this: http://technet.microsoft.com/en-us/library/hh801522.aspx

    Can result in something like this:

    $YourCluster = Get-SCVMHostCluster -Name YOUR-CLUSTER-NAME

    $YourRunAs = Get-SCRunAsAccount -Name "YOURRUNASACCOUNT"

    Set-SCVmHostCluster -VMHostCluster $YourCluster -VMHostManagementCredential $YourRunAs

    This one works like a charm for VMM 2012 SP1 for Windows 2008 R2 and 2012 clusters.

    Do you want to update the old threads related to the same subject or do you want me to do it? ;)

    Monday, May 20, 2013 8:52 AM
  • Thanks so much for your post. You are correct. This works 100% like a charm. We had a need to change Host Access and your process rocks !

    Mike E.

    Wednesday, July 10, 2013 9:20 PM
  • I have two 2012 Hyper-V servers (non cluster) managed by VMM 2012 SP1 RU 3, I'm trying to set the Host Access RunAs Account, but every time I set it and check its been applied the box is blank again!

    The following command is being executed; 

    $vmHost = Get-SCVMHost -ID "GUID"
    $hostManagementAccount = Get-SCRunAsAccount -Name "Virtual Machine Service Account" -ID "GUID"

    Set-SCVMHost -VMHost $vmHost -JobGroup "GUID" -RunAsynchronously -VMHostManagementCredential $hostManagementAccount -AvailableForPlacement $true -RemoteConnectPort 2179

    I've tried rebooting the host, I've added the local account to the local admin group but still to no effect, I need to set the runas account so I have can do live vm migration from host to host. This works perfectly in the hyper-v console on both hosts.

    Thanks for any advice,

    Rob

    PS, I was trying to resolve this issue http://www.server-log.com/blog/2013/5/20/system-center-2012-sp1-virtual-machine-manager-live-migratio.html


    • Edited by RobFuller Monday, August 05, 2013 8:06 AM
    Monday, August 05, 2013 8:06 AM
  • Hi Rob,

    I assume you are running this via the VMM UI. What's the result of the job?

    Thursday, August 08, 2013 6:21 AM
  • Yes that right, the result looks successful but nothing is apply. (box just disappears as normal, don't see a task result logged)
    • Edited by RobFuller Thursday, August 08, 2013 12:01 PM
    Thursday, August 08, 2013 11:57 AM
  • Have you tried it using powershell?
    Friday, August 09, 2013 12:10 AM
  • That works like a charm, even in SCVMM 2012 R2 / W2K12 R2 Cluster
    Many thx

    JG
    Thursday, December 19, 2013 12:35 PM
  • Thank you so much for this fix. Have been pulling my hair out for days and days but then stumbled on this post. You've saved my Bacon. Up voted!!

    Regards,
    Mark Broadbent
    Contact me through twitter | blog | sqlcloud


    Please click "Propose as answer" if a post solves your problem
    or/and vote the post up if it's been helpful.

    Want professional SQL Server High Availability Training? Click here

    Thursday, June 05, 2014 9:36 PM
  • Hi gyus. I have exactly the same issue. On the Host Access tab I cannot choose Run As account because this field is greyed out. We Use SCVMM 2012 R2 and Windows 2012 Cluster.

    I tried to use script above but I receive  the error: 

    Set-SCVMHostCluster : Cannot process argument transformation on parameter
    'VMHostManagementCredential'. Only a RunAsAccount Type is allowed for this
    parameter. If PSCredential was earlier supported it's no longer supported.
    At C:\1\3.ps1:3 char:81
    + ... mentCredential $YourRunAsAccount
    +                    ~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidData: (:) [Set-SCVMHostCluster], Paramete
       rBindingArgumentTransformationException
        + FullyQualifiedErrorId : ParameterArgumentTransformationError,Microsoft.S
       ystemCenter.VirtualMachineManager.Cmdlets.SetHostClusterCmdlet

    Please help!

    Friday, June 06, 2014 9:41 AM
  • Hi Guys, i have the same issue as kot_nn

    Set-SCVMHostCluster : Cannot process argument transformation on parameter
    'VMHostManagementCredential'. Only a RunAsAccount Type is allowed for this
    parameter. If PSCredential was earlier supported it's no longer supported.
    At C:\1\3.ps1:3 char:81
    + ... mentCredential $YourRunAsAccount
    +                    ~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidData: (:) [Set-SCVMHostCluster], Paramete
       rBindingArgumentTransformationException
        + FullyQualifiedErrorId : ParameterArgumentTransformationError,Microsoft.S
       ystemCenter.VirtualMachineManager.Cmdlets.SetHostClusterCmdlet

    Tuesday, December 30, 2014 9:56 AM
  • For anyone running into the following error:

    Set-SCVMHostCluster : Cannot process argument transformation on parameter
    'VMHostManagementCredential'. Only a RunAsAccount Type is allowed for this
    parameter. If PSCredential was earlier supported it's no longer supported.

    Try augmenting the script a little bit as following (it worked for me):

    NOTE: -Name "<ClusterName>" should work as well for the first vaiable

    $vmHostCluster = Get-VMHostCluster -ID "<IDofCluster>"

    $hostManagementAccount = Get-SCRunAsAccount -Name "<NameOfRunAsAccount>" Set-VMhostCluster $vmHostCluster -VMHostManagementCredential $hostManagementAccount


    Cheers,

    Max



    • Edited by Maxim M Tuesday, July 21, 2015 5:05 PM
    Tuesday, July 21, 2015 4:43 PM
  • Kristian: I admire your knowledge. But I think you are wrong this time.
    You can update the credentials in a running cluster without removing it from VMM.
     Why it´s grayed out I leave to someone at MSFT to answer.

    Can result in something like this:

    $YourCluster = Get-SCVMHostCluster -Name YOUR-CLUSTER-NAME

    $YourRunAs = Get-SCRunAsAccount -Name "YOURRUNASACCOUNT"

    Set-SCVmHostCluster -VMHostCluster $YourCluster -VMHostManagementCredential $YourRunAs

    This one works like a charm for VMM 2012 SP1 for Windows 2008 R2 and 2012 clusters.

    Do you want to update the old threads related to the same subject or do you want me to do it? ;)

    Just wanted to confirm that this solution does in fact work on VMM 2012 R2 as well. Thanks very much.
    Monday, February 22, 2016 4:59 PM
  •  "Why it´s grayed out I leave to someone at MSFT to answer."

    Perhaps because of this?

    -VMHostManagementCredential<PSCredential>

    This parameter is obsolete.

    Above came from the second link you have listed below:

    A little bit of this: http://technet.microsoft.com/en-us/library/hh801619.aspx
    and a little bit of this: http://technet.microsoft.com/en-us/library/hh801522.aspx

    Wednesday, June 22, 2016 8:05 PM
  • Thank you!!! Work perfectly :)
    Friday, July 22, 2016 10:16 AM
  • Hi Guys, i have the same issue as kot_nn

    Set-SCVMHostCluster : Cannot process argument transformation on parameter
    'VMHostManagementCredential'. Only a RunAsAccount Type is allowed for this
    parameter. If PSCredential was earlier supported it's no longer supported.
    At C:\1\3.ps1:3 char:81
    + ... mentCredential $YourRunAsAccount
    +                    ~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidData: (:) [Set-SCVMHostCluster], Paramete
       rBindingArgumentTransformationException
        + FullyQualifiedErrorId : ParameterArgumentTransformationError,Microsoft.S
       ystemCenter.VirtualMachineManager.Cmdlets.SetHostClusterCmdlet

    Add the run as account to vmm first. you can find the place to do that under settings
    Friday, October 21, 2016 11:53 AM
  • Thanx Fivener for the update, i can confirm that it really does work on VMM 2012 R2 just fine!
    Wednesday, May 17, 2017 4:49 PM