none
Install Operation manager Agent on Linux machine- GUI errors

    Question

  • Hello everyone,

    I get the following error when I try to install the agent on a Linux machine:

    Failed to install kit. Exit code: 1
    Standard Output: Extracting...
    Installing cross-platform agent ...
    ----- Queuing package: omi (omi-1.0.8-7.universal.x64) for installation -----
    ----- Queuing package: scx (scx-1.6.2-338.universal.x64) for installation -----
    ----- Installing packages:  100/omi-1.0.8-7.universal.x64.deb 100/scx-1.6.2-338.universal.x64.deb -----
    Checking if Apache is installed ...
      Apache not found, will not install
    Checking if MySQL is installed ...
      MySQL not found, will not install

    Standard Error: dpkg: error: requested operation requires superuser privilege

    Exception Message: 


    I am already using a superuser.

    Any idea?

    Thanks

    Wednesday, March 22, 2017 5:20 PM

Answers

  • Hi,

    Please look into : https://social.technet.microsoft.com/Forums/en-US/18047ddf-bcef-4021-a6eb-6cf644e060ad/scom-2012-sp1-not-able-to-discover-linux-workgroup-servers?forum=operationsmanagerunixandlinux

    https://social.technet.microsoft.com/wiki/contents/articles/4966.scom-2012-troubleshooting-unixlinux-agent-discovery.aspx

    According to me the issuer name should be the same as OM Server.

    • Marked as answer by Anntb Friday, March 24, 2017 2:52 PM
    Thursday, March 23, 2017 8:06 PM

All replies

  • When I try to add another Linux server, I get:

    The target address is unreachable.

    WinRM cannot complete the operation. Verify that the specified computer name is valid, that the computer is accessible over the network, and that a firewall exception for the WinRM service is enabled and allows access from this computer. By default, the WinRM firewall exception for public profiles limits access to remote computers within the same local subnet. 
       It is possible that:
       1. The destination computer is unreachable (because it is down, or due to a firewall issue).
       2. The destination certificate is signed by another certificate authority not trusted by the management server.
       3. The destination has an invalid certificate, e.g., its common name (CN) does not match the fully qualified domain name (FQDN) used for the connection.
       4. The servers in the resource pool have not been configured to trust certificates signed by other servers in the pool.
        

    PLease help

    Thanks

    Wednesday, March 22, 2017 5:35 PM
  • try manual installation
    Wednesday, March 22, 2017 6:00 PM
  • Add entry of Linux Server to Hosts file :

    https://technet.microsoft.com/en-us/library/hh212851.aspx

    Thursday, March 23, 2017 9:57 AM
  • I have already installed it on the second machine. But I must use the wizard to add the machine to the Operation manager console anyway, right?
    Thursday, March 23, 2017 10:18 AM
  • Did you tried adding to hosts file ?
    Thursday, March 23, 2017 11:00 AM
  • I have added the details of the servers to the hosts file, like the example of the post:

    192.168.1.1     newhostname.newdomain.name

    However, it did not help, I am getting the same errors

    Thursday, March 23, 2017 11:59 AM
  • When I run the suggested command:

     sudo openssl x509 -noout -in /etc/opt/microsoft/scx/ssl/scx.pem -subject -issuer -dates

    I get:

    subject= /CN=servername.domain/CN=servername.domain
    issuer= /CN=SCX-Certificate/title=SCX633376D2-E3E2-4f31-8461-D09259ACEF3D/DC=OperationManagerName
    notBefore=Apr 21 21:54:02 2016 GMT
    notAfter=Mar 22 16:14:02 2027 GMT

    It seems the issuer line is wrong, but it shouldn't matter after adding the hostnames in the hosts files, right?

    Thursday, March 23, 2017 12:03 PM
  • Hi,

    Please look into : https://social.technet.microsoft.com/Forums/en-US/18047ddf-bcef-4021-a6eb-6cf644e060ad/scom-2012-sp1-not-able-to-discover-linux-workgroup-servers?forum=operationsmanagerunixandlinux

    https://social.technet.microsoft.com/wiki/contents/articles/4966.scom-2012-troubleshooting-unixlinux-agent-discovery.aspx

    According to me the issuer name should be the same as OM Server.

    • Marked as answer by Anntb Friday, March 24, 2017 2:52 PM
    Thursday, March 23, 2017 8:06 PM
  • Thank you very much again!

    Apparently, Telnet was not installed on the machine. I also added the Firewall entry to allow this connection on this machine.

    I had other permissions errors, but I could fix them following this suggestions: http://blog.scomskills.com/install-scom-agent-on-red-hat-enterprise-linux-6-using/ 

    I used to add the user's credentials selecting the wrong 'privileged access' option. 'The right option is: Do not use elevation with this account'.

    Friday, March 24, 2017 2:52 PM