OpsMgr snapin for Powershell wont work after R2 upgrade


  • Hi!

    After we've upgraded OpsMgr from SP1 to R2, I cant get the snapin to work. We currently have a GPO that forces Powershell to only run signed certificates (Executionpolicy is AllSigned).

    The problem is that PS claims that the PS console files (When you install Command shell in the OpsMgr install wizard, it puts 3-4 files in the installation dir) does not match the hash of the file, does not match the hash stored in the digital signature.

    I have tried to reinstall the commandshell without any luck. The scripts are signed by MS, it shouldnt make that error!? I had absolutely no problems running this (inclusive the GPO) prior to upgrading to R2.
    Sunday, October 11, 2009 7:28 PM


  • I just tried this out and I got the same error.  This is a bug - we made a small change to Microsoft.EnterpriseManagement.ClientShell.Functions.ps1 right before shipping R2 and failed to re-sign the script.  Since the content of the file is different the old signature is no longer valid.

    Thankfully there is easy workaround:
    - Open the script in notepad and go to line 249 (in the function Write-OperationsManagerClientShellBanner).
    - Modify the line by removing the 3 characters " R2" (<space>, R, 2) after "2007".
    - Line 249 of the script should now read:
        Out-StringNoWrap -string: "Welcome to the Operations Manager 2007 Command Shell.  This command shell is"
    - Save

    The shell should now open fine without errors.  We'll make sure to fix this in the next release.


    Monday, October 12, 2009 6:40 PM