none
enabled fewer messages after enable RRS feed

  • Question

  • Hi, may i know if there is a way to Activate "Generated after the subscription is enabled (fewer messages) option" when executing the powershell command "Enable-SCOMNotificationSubscription"?

    Thanks.

    Wednesday, February 28, 2018 5:49 AM

Answers

  • Hi,

    Please refer to:

    https://docs.microsoft.com/en-us/powershell/module/operationsmanager/enable-scomnotificationsubscription?view=systemcenter-ps-2016

    As I see it, this is not possible


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Proposed as answer by Sameer Mhaisekar Wednesday, February 28, 2018 8:15 AM
    • Marked as answer by localtechie Thursday, March 1, 2018 8:57 AM
    Wednesday, February 28, 2018 5:59 AM
  • Yan,

    As I understand, the question is this:

    On the console when you enable a disabled subscription, it prompts you for two options for forwarding alerts,

    1. "Generated after the subscription is enabled (fewer messages)" and

    2. "Generated since the subscription was disabled (more messages)"

    (not necessarily in the right order here)

    The PS command "Enable-SCOMNotificationSubscription" by default works with option 2, which creates more (potentially unwanted) alerts. the asker wants to know if we can change it to 1st way.

    The answer to which is "no", as far as I know.

    Cheers


    Sam (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" wherever applicable. Thanks!)

    • Marked as answer by localtechie Thursday, March 1, 2018 8:57 AM
    Wednesday, February 28, 2018 8:58 AM
  • Thank you, Sam!

    I agree it seems like that there is no such option with powershell command. 

    Regards,

    Yan Li


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by localtechie Thursday, March 1, 2018 8:57 AM
    Wednesday, February 28, 2018 9:07 AM
    Moderator

All replies

  • Hi,

    Please refer to:

    https://docs.microsoft.com/en-us/powershell/module/operationsmanager/enable-scomnotificationsubscription?view=systemcenter-ps-2016

    As I see it, this is not possible


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Proposed as answer by Sameer Mhaisekar Wednesday, February 28, 2018 8:15 AM
    • Marked as answer by localtechie Thursday, March 1, 2018 8:57 AM
    Wednesday, February 28, 2018 5:59 AM
  • Hello,

    As long as you run enable-scomnotificationsubscription command to enable a notification subscription, the subscription get enabled. What Option do you mean? If possible would you please post more details about your requirements. 

    Regards,

    Yan


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, February 28, 2018 8:50 AM
    Moderator
  • Yan,

    As I understand, the question is this:

    On the console when you enable a disabled subscription, it prompts you for two options for forwarding alerts,

    1. "Generated after the subscription is enabled (fewer messages)" and

    2. "Generated since the subscription was disabled (more messages)"

    (not necessarily in the right order here)

    The PS command "Enable-SCOMNotificationSubscription" by default works with option 2, which creates more (potentially unwanted) alerts. the asker wants to know if we can change it to 1st way.

    The answer to which is "no", as far as I know.

    Cheers


    Sam (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" wherever applicable. Thanks!)

    • Marked as answer by localtechie Thursday, March 1, 2018 8:57 AM
    Wednesday, February 28, 2018 8:58 AM
  • Thank you, Sam!

    I agree it seems like that there is no such option with powershell command. 

    Regards,

    Yan Li


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by localtechie Thursday, March 1, 2018 8:57 AM
    Wednesday, February 28, 2018 9:07 AM
    Moderator
  • This is not true.

    You can use the Update method with a value of true on the subscription object to reset the timer.

    https://docs.microsoft.com/en-us/previous-versions/system-center/developer/cc136311%28v%3dmsdn.10%29

    Here is an example:

    $allSubscriptions = Get-SCOMNotificationSubscription
    $allSubscriptions[0] | Disable-SCOMNotificationSubscription
    $allSubscriptions[0].Enabled = $true
    $allSubscriptions[0].Update($true)
    
    



    http://mariusene.wordpress.com/

    Friday, October 18, 2019 1:02 PM