SMS Distribution Manager failed to initialize the network abstraction layer (NAL)


  • Hello,
    I have a similar problem to the one described at in that since Nov. 19th, software is not making it to our DP but is generating the error message: SMS Distribution Manager failed to initialize the network abstraction layer (NAL). I am not aware of any patches, updates or configuration changes that were applied to the SCCM server at that time. We did lose power for a couple of hours, but the servers never went down as they are on UPS and generators.
    While troubleshooting, I have applied the hotfix that prevents it from not following the retry schedule and number of attempts, so that is acting appropriately, but the packages are still not making it to the DP (not that I expected that to fix the error).  I have also re-applied SCCM 2007 SP2, rebooted multiple times and verified permissions on both servers.  I adjusted WebDAV and COM launch permissions on the DP to what is required but still we cannot get packages to go to the DP.
    When I tried to follow Sabrina's directions from the link above, I ran in to a few issues that were fixed after I completely deleted the registry key (though mine is not using the wow6432node key, but the HKLM\Software\Microsoft\NAL key) and recreated it.
    I do not know why, but I cannot launch the the "ConfigMgr Service Manager".  It claims that it cannot connect to my site server.  I receive an error: "Error communicating with the specified ConfigMgr Site Server" even though I am running it from on the site server itself.  So I manually stop services via the services.msc
    After completing Sabrina's instructions and rebooting I received a pop-up error:
    The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID {1A9FFCE9-10C1-40BC-9815-B20C1DC2D156} to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19). This security permission can be modified using the Component Services administrative tool.
    I granted local launch rights to the "Local Service" on the "SMS Agent Host" COM app and rebooted.  The pop-up did not reappear but I still saw the error in the system event log.
    I am still unable to launch the "ConfigMgr Service Manager" and I am still receiving the failed to initialize NAL error for all packages that are trying to be distributed to our DP.
    On the DP server I see a lot of the following error:
    The description for Event ID 63 from source Microsoft-Windows-WMI cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
    If the event originated on another computer, the display information had to be saved with the event.
    The following information was included with the event:
    Any idea what that error might be?
    Also, I noticed that there is no NAL key in the registry of any of our Distribution Points.  Should there be?
    We really need to get our software distribution working again.
    Any suggestions?
    Thanks for the help,

    • Edited by JeremyHawks Friday, December 02, 2011 9:02 PM
    Friday, December 02, 2011 8:39 PM


All replies

  •    Have you tried to uninstall / install the DP?  Though that's not always a good test since all the content will be redistributed to the DP. But since your content isn't there anyway, its OK.

     Check the DistMgr.log to see what other information is in there besides unable to initialize the NAL.

    Friday, December 09, 2011 5:28 AM
  • Thanks for the response Michael.  I have uninstalled/reinstalled the DP.  Same status.  I called Microsoft support and walked that tech through the same process as was recommended by Sabrina, only this time it worked.  No idea why.  He had me open up a separate case for the ConfigMgr Service Manager not launching as that is still an issue.

    So Sabrina's response at should still get the "Marked as Answer" credit.

    • Edited by JeremyHawks Tuesday, December 13, 2011 9:22 PM
    • Marked as answer by JeremyHawks Tuesday, December 13, 2011 9:22 PM
    Tuesday, December 13, 2011 9:21 PM