none
IIS 10 monitoring from SCOM 2012 R2 UR 14 RRS feed

  • Question

  • Hello,

    We have SCOM 2012 R2 UR 14 and would like to monitor IIS 10 or Windows 2016 IIS.

    Tired both the IIS Management Pack version 10.1.0.0 and IIS Management Pack version 1.0.6.0 but they are not getting imported.

    Does these Management Pack supports SCOM 2012 R2 , the IIS Management Pack version 1.0.6.0 MP guides specifically says that this MP supports 2012 SCOM R2.


    Amanpreet Singh Bansal

    Monday, October 14, 2019 9:42 PM

Answers

All replies

  • Hi,

    IIS MP 10.1.0.0 requires SCOM 2016 / 2019. For the 1.0.6.0 MP, is it MS officially released? I am unable to find it in catalog

       Microsoft Management Packs

    Hope the above information helps.

    Regards,

    Alex Zhu
    -----------------------------------------------
    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.
    Tuesday, October 15, 2019 1:24 AM
  • at first, I think that there is typo error of your IIS MP version.
    Tired both the IIS Management Pack version 10.1.0.0 and IIS Management Pack version 10.0.6.0 but they are not getting imported. rather than IIS MP  1.0.6.0.

    with refer to MS document, IIS 10.1.0.0 does not support SCOM 2012 R2. Your only available option is using IIS MP 10.0.6.0 or IIS MP 10.0.9.0.  You mention that IIS MP 10.0.6.0 has imported unsuccessfully into SCOM 2012 R2 environment. Please specify what error message when you import IIS MP 10.0.6.0 such that we can easy to figure out the cause.

    Roger
    Tuesday, October 15, 2019 3:38 AM
  • Hi,

    The latest IIS 10 management pack for Windows Server 2016 that is supported by SCOM 2012 R2 is the version 10.0.6.0, see: Updated MP: Microsoft System Center Management Pack for Internet Information Service 2016 – Version: 10.0.6.0

    It can be downloaded from here:
    https://systemcenter.wiki/?Get-ManagementPack=Microsoft.Windows.InternetInformationServices.2016&Version=10.0.6.0

    What errors are you receiving when trying to import?

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Tuesday, October 15, 2019 7:02 AM
  • It looks like MP is trying locate itself and we have Windows 2016 MP already imported


    Amanpreet Singh Bansal

    Wednesday, October 16, 2019 1:28 AM
  • It looks like MP is trying locate itself and we have Windows 2016 MP already imported


    Amanpreet Singh Bansal

    Wednesday, October 16, 2019 1:29 AM
  • Make sure you don't have the "Microsoft Windows Server 2016 Internet Information Services 10" management pack already imported.

    If it's not, try clearing the cache of the Operations Console by adding the /clearcache switch 
    (See: https://docs.microsoft.com/en-us/system-center/scom/manage-clear-healthservice-cache?view=sc-om-2019)

    Once the Operations console's cache has been cleared, download the management pack file from here: Microsoft.Windows.InternetInformationServices.2016.mp (1 file, version 10.0.6.0).

    Try importing the management pack once again.


    Blog: https://thesystemcenterblog.com LinkedIn:

    • Marked as answer by Aman Bansal Thursday, October 17, 2019 11:55 PM
    Wednesday, October 16, 2019 5:38 AM
  • This MP you provided installed easily no errors. As a part of MP another Library MP - Microsoft.Windows.InternetInformationServices.CommonLibrary.ENU.mp is also there, i have imported that as well.

    I am waiting for the discovery of IIS 10 instances.


    Amanpreet Singh Bansal

    Thursday, October 17, 2019 10:45 PM
  • I am able to discover the IIS 10 instances now. It looks like with the issue with IIS Mp version 10.0.6.0 I have downloaded, may be a wrong source.

    Amanpreet Singh Bansal

    Thursday, October 17, 2019 11:55 PM
  • Hi,

    Thank Leon very much for the solution provided. We're glad the problem is solved now. Here's a short summary for the problem.

    Problem/Symptom:
    ===================
    Platform: SCOM 2012 R2 UR14
    Problem details: 
    Tired both the IIS Management Pack version 10.1.0.0 and IIS Management Pack version 10.0.6.0 but they are not getting imported. The IIS Management Pack version 10.0.6.0 MP guides specifically says that this MP supports 2012 SCOM R2.

    Possible Cause:
    ===================
    N/A

    Solution:
    ===================
    1, clear the cache of the Operations Console by adding the /clearcache switch
    2, download 10.0.6.0 MP from systemwiki
    https://systemcenter.wiki/ManagementPacks/Microsoft.Windows.InternetInformationServices.2016/10.0.6.0/Microsoft.Windows.InternetInformationServices.2016.mp
    3, import the management pack once again

    If you have any questions in future, we warmly welcome you to post in this forum again.

    Have a nice day!

    Regards,

    Alex Zhu
    -----------------------------------------------
    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.
    Monday, October 21, 2019 4:14 AM