none
WSUS and SCCM not will not sync

    Domanda

  • Hi all,

     

    I currently have a SCCM 2007 server with WSUS 3 SP1 installed on it and when I'm trying to manually sync i'm getting the following log with the updates not syncing.

     

    I have highlighted what i think maybe the problem but I'm not sure.

     

    Can anyone help me solve why this is not working?

     

     

    Performing sync on local request 

    SMS_WSUS_SYNC_MANAGER 02/09/2008 15:19:23 5240 (0x1478)
    STATMSG: ID=6701 SEV=I LEV=M SOURCE="SMS Server" COMP="SMS_WSUS_SYNC_MANAGER" SYS=VSSMS01 SITE=101 PID=2472 TID=5240 GMTDATE=Tue Sep 02 14:19:23.614 2008 ISTR0="" ISTR1="" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0 SMS_WSUS_SYNC_MANAGER 02/09/2008 15:19:23 5240 (0x1478)
    STATMSG: ID=6704 SEV=I LEV=M SOURCE="SMS Server" COMP="SMS_WSUS_SYNC_MANAGER" SYS=VSSMS01 SITE=101 PID=2472 TID=5240 GMTDATE=Tue Sep 02 14:20:14.295 2008 ISTR0="" ISTR1="" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0 SMS_WSUS_SYNC_MANAGER 02/09/2008 15:20:14 5240 (0x1478)
    Synchronizing WSUS server VSSMS01 SMS_WSUS_SYNC_MANAGER 02/09/2008 15:20:14 5240 (0x1478)
    Using account vs\admin_vs to connect to WSUS Server SMS_WSUS_SYNC_MANAGER 02/09/2008 15:20:14 5240 (0x1478)
    Synchronizing WSUS server vssms01.vs.net ... SMS_WSUS_SYNC_MANAGER 02/09/2008 15:20:14 732 (0x02DC)
    sync: Starting WSUS synchronization SMS_WSUS_SYNC_MANAGER 02/09/2008 15:20:14 732 (0x02DC)
    sync: WSUS synchronizing categories SMS_WSUS_SYNC_MANAGER 02/09/2008 15:20:20 732 (0x02DC)
    STATMSG: ID=6705 SEV=I LEV=M SOURCE="SMS Server" COMP="SMS_WSUS_SYNC_MANAGER" SYS=VSSMS01 SITE=101 PID=2472 TID=5240 GMTDATE=Tue Sep 02 14:20:22.123 2008 ISTR0="" ISTR1="" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0 SMS_WSUS_SYNC_MANAGER 02/09/2008 15:20:22 5240 (0x1478)
    Synchronizing SMS database with WSUS server VSSMS01 SMS_WSUS_SYNC_MANAGER 02/09/2008 15:20:22 5240 (0x1478)
    Using account vs\admin_vs to connect to WSUS Server SMS_WSUS_SYNC_MANAGER 02/09/2008 15:20:22 5240 (0x1478)
    Synchronizing SMS database with WSUS server vssms01.vs.net ... SMS_WSUS_SYNC_MANAGER 02/09/2008 15:20:22 980 (0x03D4)
    sync: Starting SMS database synchronization SMS_WSUS_SYNC_MANAGER 02/09/2008 15:20:22 980 (0x03D4)
    requested localization languages: en SMS_WSUS_SYNC_MANAGER 02/09/2008 15:20:22 980 (0x03D4)
    Syncing all updates SMS_WSUS_SYNC_MANAGER 02/09/2008 15:20:22 980 (0x03D4)
    requested update classifications: Critical Updates, Definition Updates, Drivers, Feature Packs, Security Updates, Service Packs, Tools, Update Rollups, Updates SMS_WSUS_SYNC_MANAGER 02/09/2008 15:20:22 980 (0x03D4)
    sync: SMS synchronizing categories SMS_WSUS_SYNC_MANAGER 02/09/2008 15:20:22 980 (0x03D4)
    sync: SMS synchronizing categories, processed 0 out of 87 items (0%) SMS_WSUS_SYNC_MANAGER 02/09/2008 15:20:22 980 (0x03D4)
    Sync failed: Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)). Reason: Class not registered. Source: Microsoft.SystemsManagementServer.SoftwareUpdatesManagement.UpdatesManager.UpdatesManagerClass.DefineCategory SMS_WSUS_SYNC_MANAGER 02/09/2008 15:20:22 5240 (0x1478)
    STATMSG: ID=6703 SEV=E LEV=M SOURCE="SMS Server" COMP="SMS_WSUS_SYNC_MANAGER" SYS=VSSMS01 SITE=101 PID=2472 TID=5240 GMTDATE=Tue Sep 02 14:20:22.927 2008 ISTR0="Microsoft.SystemsManagementServer.SoftwareUpdatesManagement.UpdatesManager.UpdatesManagerClass.DefineCategory" ISTR1="Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG))" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0 SMS_WSUS_SYNC_MANAGER 02/09/2008 15:20:22 5240 (0x1478)
    Sync failed. Will retry in 60 minutes SMS_WSUS_SYNC_MANAGER 02/09/2008 15:20:22 5240 (0x1478)

    martedì 2 settembre 2008 14:31

Risposte

  • Error 0x80040154 is "class not registered" as is listed there. Something didn't get installed properly.

     

    What I'd do is to:

    * Remove the SUP role

    * Verify that the WSUS 3.0 SP1 admin console is installed on the site server

    * Verify that vssms01.vs.net is the proper FQDN for this WSUS box

    * Add the SUP role

    * Make it a default SUP, configured to sync from Microsoft Update

     

    Then verify in Site System Status that the install was successful (refresh to get the WSUS role appearing - ConfigMgr software update point).

     

    You can also look at wsusctrl.log and wcm.log to validate successful installation/configuration.

     

    Then force a sync of the catalog.

     

    martedì 2 settembre 2008 20:15