Unable to uninstall SCE2010 - Invalid Class error


  • Hi,

    I have been trying to uninstall SCE2010 from our domain for the past few days without any success. When I go to Programs & Features and click uninstall I receive the following error.  I have also tried doing a command line uninstall using the original Install media but that results in the same error.

    Uninstall SCE2010 error Invalid class

    Any suggestions would be helpful.

    2012년 12월 5일 수요일 오후 5:20

모든 응답

  • Hello Ronan,

    It seems like a OS-related issue. Could you uninstall the other program without any issue? Did you log in as a local administrator who installed the SCE server?

    Besides, please check the Event Log to see if any error was logged with detailed information, which could be very helpful to locate the root cause.


    Yog Li
    TechNet Community Support

    2012년 12월 6일 목요일 오전 9:28
  • This server is a domain controller and we are logged in as the Domain Admin but still receive the error above. All other programs install / uninstall correctly.

    There is one event in the error log which I have included below.

    Fault bucket , type 0
    Event Name: CLR20r3
    Response: Not available
    Cab Id: 0

    Problem signature:
    P1: setup.exe
    P2: 7.0.2432.0
    P3: 4bb7bbb2
    P4: System.Management
    P6: 4ca2baf0
    P7: e0
    P8: 3f
    P9: System.Management.Management

    Attached files:

    These files may be available here:

    Analysis symbol: 
    Rechecking for solution: 0
    Report Id: 5bd0ee59-3fbf-11e2-94c4-005056a13274
    Report Status: 4

    2012년 12월 6일 목요일 오후 4:12