Query Result criteria constraints not working


  • I'm going round in circles with this one, any help most welcome...

    I've created two configuration item classes: Printers, and Toner. They both share a common list for Make and Model as a property. So a Printer item can be a HP 2025, and Toner item can be for a HP 2025.

    I created a Request offering with two questions. The first asks to select a printer... The second asks to select the toner needed for that printer selected. They're both Query Results. The second one has a criteria constraint which states the Printer Make/Model from the previous question must equal the Printer Make/Model in the Toner item.

    But when i select the printer in the form I get no results from the second question. Even though there can be no difference as the two classes use the same list.

    I just don't get it :-(

    15 มิถุนายน 2555 16:18



  • Hi Andrew,

    I bet you configured everything exactly as you should. The thing is, you need to put the refresh button on the second Query Prompt after you've changed something in the first Query Prompt.

    I hope that this is something that will be improved in the near future!


    Anders Asp | Lumagate | | Sweden | My blog:

    16 มิถุนายน 2555 9:14
  • Hey Anders,

    good shout, but still no luck. I've tried to make the form simpler... The first question is now just an MP enumeration list (printer location), and the second is a query result with the criteria set against the first question. The class used in the query result has the exactly the same list so should work fine... sadly it doesn't.

    I've noticed on the page prior to going into the form i have the following message at the bottom:

    As this is before the form is started i'm not sure if this is related or not, but i don't get this on any other request offering so it needs checking out.

    16 มิถุนายน 2555 17:15
  • I ran a test request offering... MP Enumeration List = Incident Source, and Query result = Incident

    Works fine, i select the source from the drop down, refresh the results and it populates the correct results. So i know i'm doing it right!

    Either my custom classes or the request offering itself

    16 มิถุนายน 2555 18:11
  • Still having trouble with this one, having tried all sorts of combinations i'm not much further ahead. Even with a query based on a string i get nothing.

    If i remove the criteria i get results, plus i don't get that error i posted above. However at the moment i can't find any information on what that error means, i guess i'll keep digging...

    One thought at the moment is that my configuration classes are unsealed, and whether this may cause a problem.

    I've also downloaded the Silverlight developer runtime and have (hopefully) a more useful error message:

    "Exception has been thrown by the target of an invocation"

    • แก้ไขโดย Andrew France 18 มิถุนายน 2555 10:53
    18 มิถุนายน 2555 10:45
  • For anyone who may be following this thread, it seems that any custom configuration class you want to run Query Results against need to be in a SEALED management pack.

    Looks like I'm all sorted now :-)

    • ทำเครื่องหมายเป็นคำตอบโดย Andrew France 18 มิถุนายน 2555 13:29
    18 มิถุนายน 2555 13:29
  • Hi Andrew,

    Just to confirm for other people... I had the same issue, and after sealing the Management Pack, it does work !

    It would be very nice to have an error or warning stating that the MP has to be sealed to use custom items, but that is too simple I guess ;-)



    19 เมษายน 2556 7:34