Deploying Dynamics GP 2010, SCE package issues with Application Error Reporting 11.0


  • I am making a package in SCE 2010 to deploy Microsoft Dynamics GP 2010 to our clients on Windows 7 machines. I have created a package using the main EXE that came with the installation media and not I am on to deploying it into a package. The issue is that the installation of the setup.exe, which should be silent, finds that prerequisites are missing and then proceeds to ask the user if it is okay to install them. I don't want that in the package so I have created a batch file to install all of the prerequisites and then go to the setup.exe.

    The issue arises when I have it install Microsoft Application Error Reporting using the dw20shared.msi. The installation fails and the batch file continues. I have logged this install and get this error:

    MSI (s) (CC:0C) [14:00:14:774]: Doing action: CADwDoSharedRefCountAdd
    MSI (s) (CC:0C) [14:00:14:774]: Note: 1: 2205 2:  3: ActionText 
    Action start 14:00:14: CADwDoSharedRefCountAdd.
    MSI (s) (CC:0C) [14:00:14:776]: Note: 1: 2235 2:  3: ExtendedType 4: SELECT `Action`,`Type`,`Source`,`Target`, NULL, `ExtendedType` FROM `CustomAction` WHERE `Action` = 'CADwDoSharedRefCountAdd' 
    MSI (s) (CC:B0) [14:00:14:779]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI72DE.tmp, Entrypoint: DwDoSharedRefCountAdd
    CustomAction CADwDoSharedRefCountAdd returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
    Action ended 14:00:14: CADwDoSharedRefCountAdd. Return value 3.

    It appears that a custom action from within dw20shared.msi is being called and something doesn't like it. It doesn't appear to be anything permissions related because I have full control admin rights over everything.

    I have tried installing dw20shared.msi with the 'msiexec /i dw20sharedamd.msi AppGUID={F5459EB2-A662-4EB3-AD94-E771DC2F542A} /Qb' parameters with still no avail.

    It really confuses me when I successfully install Dynamics GP 2010 on a system regularly without silent parameters, Application Error Reporting does not show up in Add/Remove Programs. It seems to have a GUID in the registry that I should be able to use to uninstall it, but I am unable to do this. Basically once I manually install Dynamics GP 2010 on a machine it's useless for testing packages because I can't get Application Error Reporting off of it. This is an issue because once its on the system(unremovably) the silent install goes through with no problems.

    Long story short: I need to be able to manually install Microsoft Application Error Reporting 11.0 so that it works with Microsoft Dynamics GP 2010... in 2.5 days.

    Thanks for any help in advance.

    21 กันยายน 2554 20:38