Storage integration with SCVMM 2012 RC


  • Hi, I've installed SCVMM2012 RC and succesfully added our existing Hyper-V cluster (previously managed by SCVMM 2008R2) to the new environment. 
    There is however an issue trying to assign disk resources to the existing cluster using the new SMI-S based storage management.

    The initial integration of our Nseries7800 array (Netapp FAS6070) using SMI-S function worked ok, provider has been added and existing aggregates and LUNs are picked up.

    Following the documentation I have created and allocated a storage pool (from new resources on the array) to the host group that contains the cluster. Now I am trying to assign storage resources to the cluster/hosts using SCVMM. Again following the docs I am trying to add either "available" or "shared" storage to the cluster (through properties). The expected disk pool resources are listed as but when I try to add them the job fails with below error 26184. I have tried adding already created LUNs as well as creating LUNs as part of the process, same problem

    Who can shed some insight what the error exactly refers to ...? VMM should attempt to create the relevant storage group on the array (one per cluster node, in my case Hyperv1 and hyperv2) to map to the LUN.
    What is the "Storage Group existing for hyperV2_FC" in the error? And what setting at the array does it "need to match"? Is the fact that the existing cluster LUNs are already mapped to the HBA initiators on these hosts conflicting with what VMM is trying to do? 

    Any insight would be appreciated.






    08 Ocak 2012 Pazar 21:19

Tüm Yanıtlar

  • Hi there ;

    I thinnk you should first run the command ;

    Get-SCStorageArray  |Set-SCStorageArray -CreateStorageGroupsPerCluster $true

    Best Regards,

    Murat Demirkiran

    Senior Virtualization Architect

    27 Mart 2012 Salı 17:25
  • I get the same error as the original pster on VMM 2012 RTM + CU2 with Dell Compellent as the storage provider. Running the command Murat suggested retruns the following error:

    Set-SCStorageArray : The StorageGroupPerCluster setting is not valid for storage array <MyArrayName> as there exists clusters with storage groups created per node. (Error ID: 26182)

    Here i should mention that we had a cluster created first and then added it to VMM 2012. How do I change the 'storage groups'? I've tried searching for this but without any luck so far.



    16 Ağustos 2012 Perşembe 13:56
  • ever find the fix for this ??

    26 Ekim 2012 Cuma 03:38