none
VMM 2012 V2V Conversion fails

    问题

  • I'm trying to convert a VM in ESXi to a VM in Hyper-V. I've tried a Hyper-V 2008 R2 and 2012 host and I get the same error. When I try the migration I get this error:

    Error (2940)
    VMM is unable to complete the requested file transfer. The connection to the HTTP server esxi01.hyrule.local could not be established.
    Unknown error (0x80072ee2)

    Recommended Action
    Ensure that the HTTP service and/or the agent on the machine esxi01.hyrule.local are installed and running and that a firewall is not blocking HTTP/HTTPS traffic on the configured port.

    I monitored the progress and the "Convert VMDK to Virtual Hard Disk" task runs for about 35 minutes and gets to about 25% before it fails. Does anyone have any suggestions as to what's causing this to fail?

    Vincent Sprague

    2012年10月1日 11:58

全部回复

  • if you get an error about the conflicting SSL cert on 443, these are the steps that we recommed (we'll improve this story in the upcoming SP1 release)

    1.       Go to Regedit->HKLM\Software\Microsoft\Microsoft System Center Virtual Machine Manager Server\Settings

    2.       Create a new DWORD reg entry named “P2VBITSTcpPort” and give it a decimal value of say 3043 or any other port that is not being used on the host machine.

    3.       Go to system services (services.msc) and restart Virtual Machine Manager service.

    Alternatively, you can run > httpcfg.exe query ssl

    to find if the cert is still bound to port :443 run >

    httpcfg.exe delete ssl -i <ip-address>

    to delete the binding

    Also check if you have any error with the Disk, try to create and deploy some new VMs to that disk or changed the storage location to local


    Mohamed Fawzi | http://fawzi.wordpress.com

    2012年10月6日 23:31
    版主
  • I would like to confirm what is the current situation? Have you resolved the problem?

    If there is anything that we can do for you, please do not hesitate to let us know, and we will be happy to help.

    Mohamed Fawzi | http://fawzi.wordpress.com


    2012年10月13日 12:30
    版主
  • It still won't migrate, same error has before, runs for about 30 minutes and then fails.


    Vincent Sprague

    2012年10月14日 14:07
  • can you please try Disk2VHD ?

    Mohamed Fawzi | http://fawzi.wordpress.com

    2012年11月26日 23:50
    版主
  • I tried Disk2VHD and it created a VHD file. But when I created a VM in hyper-v and assigned the VHD file to it the new VM doesn't boot. The VHD file was also created very quickly, almost too quickly.

    Vincent Sprague

    2012年12月12日 14:22
  • Hi Baron,

    I was moving VM guest from 2008 R2 cluster to our new 2012 cluster using the new SCVMM 2012 with SP1, and stumbled with that same error.

    The issue was: during the migration phase, the final host needs to connect to SCVMM on port 443. Just open the port on your firewalls so the connection is authorized from HyperV Host -> SCVMM host : TCP/443.

    Rui

    2013年1月13日 15:32
  • Firewall was shutoff at the time because I thought it might have been part of the issue but it did not resolve my issue.

    Vincent Sprague

    2013年1月21日 14:27
  • I'm having the same problem. The job runs for 35-40 minutes (it varies) and then fails out with the same error. Help!
    2013年1月22日 17:06
  • mostly it is a port problem, Check your firewall to make sure that you are able to connect between VMM, Hyper-v and VMware

    Please check screenshot in http://technet.microsoft.com/en-us/library/bb963740.aspx


    Mohamed Fawzi | http://fawzi.wordpress.com

    2013年2月9日 22:14
    版主
  • It wasn't a firewall issue for me, the firewalls had all been disabled. I have since removed the server and won't be trying it again anytime son.

    Vincent Sprague

    2013年4月1日 20:27
  • I faced the same issue, finally i resolved the issue !!!

    I have raised 4 hardware firewall requests.

    Request 1: From VMware ESX Server– hyper node (port  80, 443 and 445).

    Request 2: From hyper node to VMware ESX Server ( port 22, 80 and 443).

    Request3-> From VMware Vcenter Server– hyper node (port 80 and 443)

    Request 4: From Hyper-V node to VMware Vcenter Server ( port 80 and 443)

    then i am able to telnet required ESX ports from Target hyper-v server. It works nicely !!

    ESX and Vcenter version is 5.1

    Hyper-V -2012

    SCVMM 2012 Sp1 RTM


    Kirpal Singh


    2013年5月24日 12:30
  • Mohamed,

    thanks for the details...this appears to have resolved my issue as I was having the same error.  I also disabled the firewall on HyperV Server 2012/r2  ...and it appears to be working (albeit terribly slowly)

    thanks.


    Microsoftie

    2014年1月23日 22:06