Delete folder as owner results with "Access denied"


  • Hello everyone,

    I've read maybe 50 articles about this topic and about UAC etc. - nothing helped so far...
    My problem is as followed:

    I have a folder called "C:\Program" on my Server 2012 R2 (Domain-Member).
    This was created with a User called "XXX_salt".
    Neither the owner nor a member of the Administrator-Group can delete it. I tried it via GUI, cmd, ps and from remote - nothing worked.
    Via the GUI the user is getting prompted "You require permissions from XXX_salt to make changes to the folder" - but XXX_salt is the owner... You can't even change the ownership or enable/disable the inheritance.
    From CMD any operation is ending with "Access denied".
    Funny thing is, that there is a setting for Principal "Everyone" with "Read&Execute" but the inheritance is disabled - so this should not change anything.
    Admins and owner are marked with "Full control", Auditing is empty.
    Checking the "Effective access" is also returning, that I should be allowed to delete it.
    Right clicking the folder and selecting properties is showing a "Read Only (Only applies to files in folder)".

    I also applied the UAC-settings to disable the Admin-Approval-Mode.

    Anyone an idea about this problem?!
    Me and my colleagues don't care about the existance of the folder - but maybe somewhen in the future something like this might become an urgent issue.
    Thank you all in advance!


    13 กรกฎาคม 2561 8:15