none
Hyper-V Server 2016 (free core) working system disk spontaneously converts from GPT to MBR and entire disk becomes unallcoated

    คำถาม

  • I have been attempting to install the free Hyper-V Server 2016 onto a 128GB ADATA SP600 SSD in a system with a Gigabyte workstation MOBO (model ga-z270x-ud3) and BIOS set to UEFI with no CSM (compatibility support module). All disks, including the install media are formatted to GPT and UEFI boot. The install completes perfectly, Hyper-V boots up, works great for several reboots/power cycles, and both Diskpart and PowerShell confirm the disk to be GPT. However, eventually, within the range of 1 to 4 reboots/power-cycles, Hyper-V will no longer boot. The BIOS gives the error that no bootable media was found. Upon inspection of the disk with 3 different rescue disks/live OSes, diskpart, and PowerShell, all agree that the disk is now MBR and report the entire drive to be unallocated space. I am able to recover the partitions using TestDisk to the point that the BIOS can find the Windows Boot Manager, but can not get past the Boot Manager. Regardless, the root problem remains. I have duplicated this at least 10 times. The BIOS is updated to the latest firmware. There is nothing wrong with the SSD, I have run many tests on it and the exact same system setup works perfectly without this issue occurring when Windows 10 instead is installed on the SSD. So I don't see any factor remaining other than Hyper-V. Has anyone else seen a similar issue? Could this be a driver problem? Being that the MOBO is intended for workstations, obtaining and applying drivers is difficult. I just can't wrap my head around how Hyper-V could be corrupting the partition table simply from rebooting. Any help would be greatly appreciated as I am out of any actionable ideas. Thanks.
    12 กรกฎาคม 2561 1:21

ตอบทั้งหมด