none
New VHDX in HyperV VM not recognized

    คำถาม

  • We created a new VHDX in HyperV Manager and mounted it in one of our virtual machines via a SCSI controller. HyperV Manager says it's connected without any errors.

    After connecting the VHDX to the VM, we checked whether the disk was recognized by the VM in diskpart but it didn't show up there. We then tried creating two test VHDX disks with just 1 GB size each (1 fixed and 1 dynamic). Both got recognized once, but not the other times we tried mounting them. The chance of being actually seen by the VM seems to be pretty random.

    The HyperV host and guest machines are both on Windows Server 2012 R2 with no GUI installed. We couldn't check a more detailed hardware information of the hard drive (VHDX) via device manager because it is not installed in the VM's Windows version. The HyperV Integration Services (mounted vmguest.iso via HyperV) are also on the latest version, the installer says.

    Has anyone experienced this issue before or has some tips or ideas on how to fix this? Any help is appreciated very much.

    Thank you!

    8 พฤษภาคม 2561 12:34

ตอบทั้งหมด