none
Exchange issue with one external domain

    คำถาม

  • I have a strange issue with our 2013 Exchange. All internal users are getting these return errors if they send to one ( and only one) external domain. These emails work from personal email ( yahoo, gmail... etc.. )

    The trouble domain email is hosted on googlemail and we are running an exchange server locally for our domain. 

    The email address you entered couldn't be found. Please check the recipient's email address and try to resend the message. If the problem continues, please contact your helpdesk

    However, if I create a email contact in exchange, it works flawlessly. Far as I can tell, this error is on our exchange server. I can email these users from my personal email so I know they are valid addresses. 

    done all exchange server diags I could find after some internet searches telnet email, ( failed ) test-emailconnectivity cmdlet etc.... with no success.

    nslookup results:

    C:\Windows\System32>nslookup -type=mx xxxxxx.org
    Server:  Our Internal DC
    Address:  172.x.x.x

    Non-authoritative answer:
    blacksburgrescue.org    MX preference = 1, mail exchanger = aspmx.l.google.com
    blacksburgrescue.org    MX preference = 5, mail exchanger = alt2.aspmx.l.google.com
    blacksburgrescue.org    MX preference = 10, mail exchanger = aspmx3.googlemail.com
    blacksburgrescue.org    MX preference = 10, mail exchanger = aspmx2.googlemail.com
    blacksburgrescue.org    MX preference = 5, mail exchanger = alt1.aspmx.l.google.com

    aspmx.l.google.com      internet address = 173.194.X.X
    aspmx.l.google.com      AAAA IPv6 address = xxxxx
    alt2.aspmx.l.google.com internet address = 209.85.X.X
    alt2.aspmx.l.google.com AAAA IPv6 address = xxxxxx
    alt1.aspmx.l.google.com internet address = 64.233.X.X
    alt1.aspmx.l.google.com AAAA IPv6 address =xxxxxx

    not sure where to go from here. I am not creating 200 plus exchange email contacts to make it work.

    Can anyone point me where to look to correct this issue?

    Thanks,

    JD


    13 กรกฎาคม 2561 15:15

ตอบทั้งหมด

  • Can you recreate this behaviour sending a new message via OWA?
    13 กรกฎาคม 2561 15:31
  • Same thing if you manually type the e-mail address in the To field?

    i.e. not using cache or a contact.

    13 กรกฎาคม 2561 15:57
  • Hi,

    Is the NDR message generated by Google or the internal mail server?
    If you are not sure about this, we recommend you to post the entire NDR here without the sensitive message.

    Besides, please run the following command to get the a single email's message tracking log, we could get more details here:

    Get-MessageTrackingLog -MessageSubject "<subject>" -Recipients "<username>"


    Regards,

    Manu Meng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    16 กรกฎาคม 2561 9:56
    ผู้ดูแล
  • This is the result from internal test outgoing email……

    Delivery has failed to these recipients or groups:

    (External user email address)

    The email address you entered couldn't be found. Please check the recipient's email address and try to resend the message. If the problem continues, please contact your helpdesk.

    Diagnostic information for administrators:

    Generating server: my internal internal email server

    Valid Remote Email address Remote Server returned '550 5.1.1 RESOLVER.ADR.RecipNotFound; not found'

    Original message headers:

    Received: from internal exchange server (internal ip) by
     internal exchange server (internal ip address)) with Microsoft SMTP Server (TLS) id
     15.0.1076.9; Mon, 16 Jul 2018 06:29:20 -0400
    Received: from internal exchange server([::1]) by internal exchange server (internal ip)
     ([::1]) with mapi id 15.00.1076.000; Mon, 16 Jul 2018 06:29:20 -0400
    Content-Type: application/ms-tnef; name="winmail.dat"
    Content-Transfer-Encoding: binary
    From: "my exchange account name" <my email address
    To: "external user" <external email address>
    Subject: Testing outgoing email From My Domain
    Thread-Topic: Testing outgoing email My Domain
    Thread-Index: AdQc79qc2CStonR0T+2+hI2N2r903A==
    Date: Mon, 16 Jul 2018 06:29:20 -0400
    Message-ID: <59552a403ce44e78a3d918aa7ecbb4ee at my exchange server>
    Accept-Language: en-US
    Content-Language: en-US
    X-MS-Has-Attach:
    X-MS-TNEF-Correlator: <59552a403ce44e78a3d918aa7ecbb4ee at my mail server>
    MIME-Version: 1.0
    X-MS-Exchange-Transport-FromEntityHeader: Hosted
    X-Originating-IP: [my workstation ip]
    Return-Path: internal exchange email

    This is from sending a reply from the external email address

    Delivery has failed to these recipients or groups:

    (External Email Address)

    The email address you entered couldn't be found. Please check the recipient's email address and try to resend the message. If the problem continues, please contact your helpdesk.

    Diagnostic information for administrators:

    Generating server: my exchange server

    (Email address)

    Remote Server returned '550 5.1.1 RESOLVER.ADR.RecipNotFound; not found'

    Original message headers:

    Received: from internalmailserver.blaxxxxxxx.xx.xx (ip address) by
     internalmailserver (ip address) with Microsoft SMTP Server (TLS) id
     15.0.1076.9; Mon, 16 Jul 2018 06:40:31 -0400
    Received: from internalmailserver ([::1]) by internalmailserver
    id 15.00.1076.000; Mon, 16 Jul 2018 06:40:31 -0400
    Content-Type: application/ms-tnef; name="winmail.dat"
    Content-Transfer-Encoding: binary
    From: "my exchange account" <email address>
    To: external user at domain dot org
    Subject: RE: Testing
    Thread-Topic: Testing
    Thread-Index: AQHUHPCCHWAu7/tVCE+iPLE2UpttpKSRqOJQ
    Date: Mon, 16 Jul 2018 06:40:30 -0400
    Message-ID: <0ab3dad86de749a8b145335ace430959 at internalmailserver.blaxxxxxxx.xx.xx >
    References:  CACzmh7kcCJ7iv14ByWMF3LyiTS=dcmnCHGWT76+DtX=32VOfx  mail dot gmail dot com 
    In-Reply-To: <CACzmh7kcCJ7iv14ByWMF3LyiTS=dcmnCHGWT76+DtX=32VO xx at mail dot gmail dot com  
    Accept-Language: en-US
    Content-Language: en-US
    X-MS-Has-Attach:
    X-MS-TNEF-Correlator: 0ab3dad86de749a8b145335ace430959 email server 
    MIME-Version: 1.0
    X-MS-Exchange-Transport-FromEntityHeader: Hosted
    X-Originating-IP: [my workstation ip]
    Return-Path: my email


    16 กรกฎาคม 2561 11:10
  • Found the issue. Had to do with phone system email.

    Someone had added the external domain on our exchange server so the server was not seeing any email addresses on that domain.

    16 กรกฎาคม 2561 13:29
  • Found the issue. Had to do with phone system email.

    Someone had added the external domain on our exchange server so the server was not seeing any email addresses on that domain.

    Is it caused by a wrong-added accept domain and corresponding email address policy?

    Regards,

    Manu Meng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    17 กรกฎาคม 2561 2:25
    ผู้ดูแล