none
Exchange2010Sp3-OwaSorunu RRS feed

  • Soru

  • Merhaba,

    AD 2003 olan ortama tüm ön gereksinimleri uygulayarak 2008R2 üzerinde Exchange2010 kurulumu yaptım. Sonrasında Sp3 ü de uyguladım.

    Şuan bazı kullanıcılarda Owa dan mailbox ı açmak istediğimizde aşağıdaki hata ile karşılaşıyouz. Çözümü konusnda yardımlarınızı rica ederim.

    Teşekkürler.

    Request
    Url: https://192.168.1.15:443/owa/
    User: name.lastname
    EX Address: /o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=name lastname721
    SMTP Address: name.lastname@domain.com
    OWA version: 14.3.123.3

    Exception
    Exception type: Microsoft.Exchange.Data.Storage.StoragePermanentException
    Exception message: Cannot find row based on condition.

    Call stack

    Microsoft.Exchange.Data.Storage.QueryResult.SeekToCondition(UInt32 bookMark, Boolean useForwardDirection, QueryFilter seekFilter, SeekToConditionFlags flags)
    Microsoft.Exchange.Data.Storage.QueryResult.SeekToCondition(SeekReference reference, QueryFilter seekFilter, SeekToConditionFlags flags)
    Microsoft.Exchange.Data.Storage.UserConfiguration.FetchAllConfigurations(Folder folder, SortBy[] sorts, Int32 maxRow, PropertyDefinition[] columns)
    Microsoft.Exchange.Data.Storage.UserConfiguration.QueryConfigurations(Folder folder, SortBy[] sorts, UserConfigurationName configurationName, UserConfigurationSearchFlags searchFlags, Int32 maxRow, PropertyDefinition[] columns)
    Microsoft.Exchange.Data.Storage.UserConfiguration.Create(Folder folder, UserConfigurationName configurationName, UserConfigurationTypes type)
    Microsoft.Exchange.Data.Storage.UserConfigurationManager.CreateMailboxConfiguration(String configurationName, UserConfigurationTypes dataTypes)
    Microsoft.Exchange.Clients.Owa.Core.UserOptions.RecreateUserConfiguration(Boolean deleteFirst)
    Microsoft.Exchange.Clients.Owa.Core.UserOptions.GetUserConfiguration()
    Microsoft.Exchange.Clients.Owa.Core.UserOptions.Load(IList`1 properties)
    Microsoft.Exchange.Clients.Owa.Core.UserOptions.LoadAll()
    Microsoft.Exchange.Clients.Owa.Core.UserContext.Load(OwaContext owaContext)
    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.CreateUserContext(OwaContext owaContext, UserContextKey userContextKey, UserContext& userContext)
    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.PrepareRequestWithoutSession(OwaContext owaContext, UserContextCookie userContextCookie)
    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.AcquireAndPreprocessUserContext(OwaContext owaContext, HttpRequest request)
    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.InternalDispatchRequest(OwaContext owaContext)
    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.DispatchRequest(OwaContext owaContext)
    Microsoft.Exchange.Clients.Owa.Core.OwaRequestEventInspector.OnPostAuthorizeRequest(Object sender, EventArgs e)
    System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
    System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

    Inner Exception
    Exception type: Microsoft.Mapi.MapiExceptionJetErrorKeyDuplicate
    Exception message: MapiExceptionJetErrorKeyDuplicate: Unable to find table row. (hr=0x80004005, ec=-1605) Diagnostic context: Lid: 55847 EMSMDBPOOL.EcPoolSessionDoRpc called [length=170] Lid: 43559 EMSMDBPOOL.EcPoolSessionDoRpc returned [ec=0x0][length=434][latency=0] Lid: 23226 --- ROP Parse Start --- Lid: 27962 ROP: ropGetContentsTable [5] Lid: 27962 ROP: ropSetColumns [18] Lid: 27962 ROP: ropSortTable [19] Lid: 17082 ROP Error: 0xFFFFF9BB Lid: 27489 Lid: 21921 StoreEc: 0xFFFFF9BB Lid: 27962 ROP: ropExtendedError [250] Lid: 1494 ---- Remote Context Beg ---- Lid: 26426 ROP: ropSortTable [19] Lid: 21970 StoreEc: 0x8004010F PropTag: 0x668F0040 Lid: 3245 StoreEc: 0xFFFFF9BF Lid: 3245 StoreEc: 0xFFFFF9BF Lid: 52413 dwParam: 0x30040 Lid: 8916 StoreEc: 0xFFFFFAE7 Lid: 54507 dwParam: 0x8 Lid: 15243 StoreEc: 0xFFFFFAE7 Lid: 62699 dwParam: 0x8 Lid: 39415 dwParam: 0x17679A Lid: 12427 StoreEc: 0xFFFFFAE7 Lid: 46315 dwParam: 0x8 Lid: 13780 StoreEc: 0xFFFFF9BB Lid: 36029 Lid: 56361 StoreEc: 0xFFFFF9BB Lid: 38697 StoreEc: 0xFFFFF9BB Lid: 50093 StoreEc: 0xFFFFF9BB Lid: 47457 Lid: 10213 StoreEc: 0xFFFFF9BB Lid: 28256 Lid: 9189 StoreEc: 0xFFFFF9BB Lid: 1750 ---- Remote Context End ---- Lid: 27962 ROP: ropSeekRow [24] Lid: 27962 ROP: ropFindRow [79] Lid: 17082 ROP Error: 0xFFFFF9BB Lid: 23649 Lid: 21921 StoreEc: 0xFFFFF9BB Lid: 27962 ROP: ropExtendedError [250] Lid: 1494 ---- Remote Context Beg ---- Lid: 26426 ROP: ropFindRow [79] Lid: 57069 StoreEc: 0xFFFFF9BB Lid: 28720 Lid: 11621 StoreEc: 0xFFFFF9BB Lid: 56781 StoreEc: 0xFFFFF9BB Lid: 21484 Lid: 23788 StoreEc: 0xFFFFF9BB Lid: 1750 ---- Remote Context End ---- Lid: 26849 Lid: 21817 ROP Failure: 0xFFFFF9BB Lid: 29726 Lid: 18462 StoreEc: 0xFFFFF9BB

    Call stack

    Microsoft.Mapi.MapiExceptionHelper.ThrowIfError(String message, Int32 hresult, SafeExInterfaceHandle iUnknown, Exception innerException)
    Microsoft.Mapi.MapiTable.FindRow(Restriction restriction, BookMark bookmark, FindRowFlag flag)
    Microsoft.Exchange.Data.Storage.QueryResult.SeekToCondition(UInt32 bookMark, Boolean useForwardDirection, QueryFilter seekFilter, SeekToConditionFlags flags)

    15 Mayıs 2013 Çarşamba 10:24

Tüm Yanıtlar

  • Merhaba,

    OWA'ya erişemeyen kullanıcılar karantinada olabilir. Aşağıdaki kayıt anahtarında yer alan kullanıcıları siliniz ve ardından tekrar deneme yapınız.

    HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeI S\<Server Name>\Private-{db guid}\QuarantinedMailboxes\{mailbox guid}

    Mailbox GUID'i tespit etmek için aşağıdaki komutu kullanabilirsiniz:

    get-mailboxstatistics -identity <user> | fl

    Buna ek olarak şu konularda bizimle bilgi paylaşabilirseniz sevinirim:

    • Exchange Management Shell üzerinde aşağıdaki komutu uygulayınız ve sonucunu bizimle paylaşınız:

           Get-Owavirtualdirectory | fl

    • OWA Virtual Directory Default IIS ayarları için aşağıdaki makaleyi kontrol ediniz:

           http://blogs.technet.com/b/exchange/archive/2010/09/23/3411146.aspx

    • Sorun yaşayan kullanıcıların mailboxuserlarını farklı bir database'e taşıdığınızda durum nedir?
    • Sorun yaşayan kullanıcıları, sorunun yaşanmadığı kullanıcıların bulunduğu OU'lara taşıdığınızda durum nedir?
    • Bu sorun SP3 öncesi de mevcut muydu?
    • IIS üzerinde Default Website'da bir yönlendirme (Redirection) işlemi mevcut mudur?
    • IIS üzerinde OWA VD'de bir yönlendirme işlemi mevcut mudur?
    • OWA'ya erişim sağlayabilen kullanıcılar lokal kullanıcılar mıdır?

    17 Mayıs 2013 Cuma 14:18
    • Yanıt Olarak Öneren Ugur Demir 19 Mayıs 2013 Pazar 14:07
    19 Mayıs 2013 Pazar 14:02