none
Exchange 2003 to 2010 migration move mailbox hatası... RRS feed

  • Soru

  • Merhaba

    Exchange 2003 den 2010 'a  mailbox move ederken aşağıdaki hatayı aldım sorunum nedir acaba ? Teşekkürler...


    http://technet.microsoft.com/en-US/library/ms.exch.err.default(EXCHG.141).aspx?v=14.1.218.11&t=exchgf1&e=ms.exch.err.Ex23B42B

    Summary: 1 item(s). 0 succeeded, 1 failed.
    Elapsed time: 00:00:00


    Administrator
    Failed

    Error:
    Mailbox database "exc03\First Storage Group\Mailbox Store (DURAK04)" doesn't exist.
    Click here for help... http://technet.microsoft.com/en-US/library/ms.exch.err.default(EXCHG.141).aspx?v=14.1.218.11&t=exchgf1&e=ms.exch.err.Ex23B42B

    Warning:
    When an item can't be read from the source database or it can't be written to the destination database, it will be considered corrupted. By specifying a non-zero BadItemLimit, you are requesting Exchange not copy such items to the destination mailbox. At move completion, these corrupted items will not be available at the destination mailbox.


    Exchange Management Shell command attempted:
    'exchange.local/Users/Administrator' | New-MoveRequest -TargetDatabase 'Mailbox Database 1769900348' -BadItemLimit '5'

    Elapsed Time: 00:00:00


    • Düzenleyen ferdikilic 18 Nisan 2012 Çarşamba 17:56 düzeltme
    18 Nisan 2012 Çarşamba 14:58

Yanıtlar

    • Move işlemi için kullandığınız admin hesabının Organization Admin olduğundan emin olun
    • Yine bu hesabı ADUC üzerinde kontrol edin ve Security sekmesinde "include inheritable permissions from this object`s parent" seçeneğinin seçili olduğuna emin olun. (Seçili ise, kaldırın apply dedikten sonra tekrar seçip OK'e basın)

    Teşekkürler



    Get-Mailbox.org

    • Yanıt Olarak İşaretleyen ferdikilic 18 Nisan 2012 Çarşamba 18:40
    18 Nisan 2012 Çarşamba 18:30

Tüm Yanıtlar

  • Merhaba Ferdikilic ,

    move request (recipient yonetimi kismi altinda) log kisminda neden bad-item oldugunu yazar. Mailbox`i move ederken bad item durumunda skip etmeyi secip deneyebilirsin (test yapiyorsan). Yada move-request ozelliklerinde log kismindan neden bad item var bakabilirsin. Muhtemelen personeliniz buyuk boyutlu email gondermeye denemistir ve exchange non delivery report dondurmustur. bad item`lar buyuk ihtimalle bu sekildedir. goz ardi edebilirsin.

    18 Nisan 2012 Çarşamba 17:48
  • Merhaba bu arada yapım şu şekilde.

    Yapıda 1 adet Server 2003 DC mevcut

    1 Adet Server 2003 DC ye ADC olarak yüklü Exchange server var

    Ben Yeni bir server 2008 r2 kurup normal bir şekilde domaine aldım.Daha sonra domain admin ile logon olup kurulum işlemine başladım.

    Yani Server 2008 ADC değil Server 2003 diğer DC ye ADC sorun bundan kaynaklanıyor olabilir mi?

    Teşekkürler...

    18 Nisan 2012 Çarşamba 17:49
  • Merhaba Barış Hocam

    Dediğiniz gibi yaptım hatalı olanları atla dedim fakat taşımadı, hatta yeni kullanıcı oluşturup tr karakter sorunu olup olmadığını kontrol ettim ama sonuç yine değişmedi.

    18 Nisan 2012 Çarşamba 18:08
  • Mumkunse move-request`lerden hatali olan bir kacinin log kisminin ekran goruntusunu paylasabilirmisin ferdi ?
    18 Nisan 2012 Çarşamba 18:12
  • Merhaba Barış Hocam

    Ekran görüntüsü yukarıdaki ilk başlıkta yazdığım log daki gibi.Şu an sisteme erişimim yok.Bütün move ettiğim kullanıcılarda aynı hatayı alıyorum.Birşey dikkatimi. çekti bir posta hesabının üzerine sağ tıklayıp açılan pencerede  send permission properties'ine tıkladığımda boş geliyor.

    18 Nisan 2012 Çarşamba 18:19
    • Move işlemi için kullandığınız admin hesabının Organization Admin olduğundan emin olun
    • Yine bu hesabı ADUC üzerinde kontrol edin ve Security sekmesinde "include inheritable permissions from this object`s parent" seçeneğinin seçili olduğuna emin olun. (Seçili ise, kaldırın apply dedikten sonra tekrar seçip OK'e basın)

    Teşekkürler



    Get-Mailbox.org

    • Yanıt Olarak İşaretleyen ferdikilic 18 Nisan 2012 Çarşamba 18:40
    18 Nisan 2012 Çarşamba 18:30
  • Merhaba Serkan Hocam

    domain\administrator olarak login oluyorum.ADUC da bu kullanıcı Domain admin Security sekmesinde include inheritable permissions from this object`s parent"  seçeneğini kontrol edeceğim.Eğer sorunum düzelmez ise Exchange 2010 un olduğu Server 2008 r2 ent. serverı kaldırıp yeniden kurulum yapsam.Yeniden Setup / komutları çalıştırsam.Kurulumu yeniden yapsam olur mu yoksa artık çok mu geç ? Exchange 2003 tarafında Exchange 2003 2010' algıladı yapacak bir şey yok mu?

    Teşekkürler

    18 Nisan 2012 Çarşamba 18:46
  • Merhaba,

    Aldığın hatanın Exchange 2010 kurulumun ile ilgili bir hata olduğunu düşünmüyorum. Ayarları düzgün yapman durumunda sorun olacağını sanmıyorum. 

    Permissionları kontrol et sorun düzelecektir diye düşünüyorum.

    Teşekkürler



    Get-Mailbox.org


    18 Nisan 2012 Çarşamba 18:51
  • Serkan Hocam günaydın,

    Permission ları ADUC danmı kontrol edeyim.Kullanıcıların hepsi domain user. Domain admin hesabı ile taşıma işlemi yapıyorum.Yanlız  Exchange 2003 server tarihi geçmiş ssl ile haberleşiyordu.Bu da public klasöre girerken problem çıkarttı.SSL'i kaldırdım Public klasörüne erişebildim.Onunla alakalı da olabilir mi?

    Yine technet de aşağıdaki bir çözüm önerisini buldum.Denememde bir sakıncası olabilirmi.

    I may have a solution for you:  I ran into the exact issue you did, at roughly the same time you were posting the previous reply.  If you go onto the exchange 2003 server, and open the ESM, then expand Administrative Groups, and right-click on the "first administrative group"(or whatever you named the admin group for the original 2k3 server), and then select properties, click on the Security tab, and click Add, then add the Server that Exchange 2010 is hosted on, with full permissions, it should resolve your problem.  If you go down any further than "first administrative group", it'll say that it can now see the mailbox store, but won't connect due to mapi errors.  Hope this helps!

    • Düzenleyen ferdikilic 19 Nisan 2012 Perşembe 05:54
    19 Nisan 2012 Perşembe 05:51
  • Serkan Hocam Merhaba söylediğiniz şekilde kontrol ettim.Include inheritable permissions from this object`s parent"  seçili yetkileri yeniden mi oluştursam ?
    19 Nisan 2012 Perşembe 07:10
  • AD de yenibir OU oluşturdum vwe Everyone dahil bütün kullanıcılara full yetki verdim.Ayrıca Exchange server tarafında administrator grup, first administrator grup'a giderek ilgili Exchange 2003 server için permission ları düzenleyerek Full yetki verdiğim.Fakat sorunum devam ediyor.
    19 Nisan 2012 Perşembe 07:56
  • Merhabalar birşey fark ettim yaklaşık 100 kullanıdan 8 tanesi normal görünüyor bu hatayı almıyorum.Acaba database mi problemli? Fakat taşıma yaprken aynı hatayı alıyorum.
    • Düzenleyen ferdikilic 19 Nisan 2012 Perşembe 08:46
    19 Nisan 2012 Perşembe 08:15
  • Ferdi,

    Mailbox move yaparken, bad item limit'e 10, 50, vs.. gibi bir raqkam yazarak deneyebilirmisin


    www.serhadmakbuloglu.com

    19 Nisan 2012 Perşembe 09:04
  • Merhaba Serhad Hocam yazdım 90 yazdım 100 yazdım 300 bile yazdım :) test ortamı kuruyorum.Sorunu çözdüğümde burada anlatıcam bende çok merak ediyorum.Problem ne acaba?

    Bunu da denedim.Ama olmadı.

    http://support.risualblogs.com/blog/2010/01/18/insufficient-access-rights-to-perform-the-operation-error-when-moving-a-mailbox-onto-exchange-2010/


    • Düzenleyen ferdikilic 19 Nisan 2012 Perşembe 09:42
    19 Nisan 2012 Perşembe 09:20
    • Move işlemi için kullandığınız admin hesabının Organization Admin olduğundan emin olun
    • Yine bu hesabı ADUC üzerinde kontrol edin ve Security sekmesinde "include inheritable permissions from this object`s parent" seçeneğinin seçili olduğuna emin olun. (Seçili ise, kaldırın apply dedikten sonra tekrar seçip OK'e basın)

    Teşekkürler



    Get-Mailbox.org

    Ikinci adim da admin hesabin icin inheritance Seçili ise, kaldırın apply dedikten sonra tekrar seçip OK'e basın  seklinde belirttim bunu yaptin mi?

    Get-Mailbox.org

    19 Nisan 2012 Perşembe 12:43
  • Merhaba Serkan Hocam evet yaptım.Hatta Bütün yetkileri kaldırdım yeniden oluşturdum.Everyone da dahil olmak üzere tük kullanıcılara full yetki verdim.Fakat aynı sorun devam etti.OU içinde aynı yetkilendirme yaptım user içinde fakat olmadı.Chek box' ı kaldırıp ekledim yinede olmadı.
    19 Nisan 2012 Perşembe 12:47
  • Serkan Hocam günaydın,

    Permission ları ADUC danmı kontrol edeyim.Kullanıcıların hepsi domain user. Domain admin hesabı ile taşıma işlemi yapıyorum.Yanlız  Exchange 2003 server tarihi geçmiş ssl ile haberleşiyordu.Bu da public klasöre girerken problem çıkarttı.SSL'i kaldırdım Public klasörüne erişebildim.Onunla alakalı da olabilir mi?

    Yine technet de aşağıdaki bir çözüm önerisini buldum.Denememde bir sakıncası olabilirmi.

    I may have a solution for you:  I ran into the exact issue you did, at roughly the same time you were posting the previous reply.  If you go onto the exchange 2003 server, and open the ESM, then expand Administrative Groups, and right-click on the "first administrative group"(or whatever you named the admin group for the original 2k3 server), and then select properties, click on the Security tab, and click Add, then add the Server that Exchange 2010 is hosted on, with full permissions, it should resolve your problem.  If you go down any further than "first administrative group", it'll say that it can now see the mailbox store, but won't connect due to mapi errors.  Hope this helps!

    Bunu deneyebilirsin.

    Ayrica ADSIEdit ile Exchange Trusted Subsystem group'un yetkilerini 2003 yapisinda kontrol eder misin?

    http://blogs.technet.com/b/richardroddy/archive/2010/07/12/exchange-2010-and-the-exchange-trusted-subsystem.aspx


    Get-Mailbox.org

    19 Nisan 2012 Perşembe 13:06
  • Serkan Hocam enson o makaleyi yaptım olmadı.Şimdi mail leri export edip sonra içeri alıcam işlemi manuel yapmaya karar verdim.Yeni bir EXC 2010 kurup tek tek kullanıcılara bağlanıp önce mailleri dışarı vericem sonra posta profilini silip yeni profil olarak exc2010 gösterip mailleri tekrar içeri alıcam.İşleme başladık.
    • Düzenleyen ferdikilic 19 Nisan 2012 Perşembe 13:12
    19 Nisan 2012 Perşembe 13:12
  • Serkan Hocam tekrar merhabalar :) kurulum bir türlü olmadı makaladeki gibi adsiedit ile Exchange Trusted Subsystem yetkiler boş gelmişti tekrar full yetki verdim ve "include inheritable permissions kontrol ettim. fakat olmadı ve Exchange 2003 var olduğu için yeni bir exchange 2010 kurmamıza izin vermiyor.Taşımayıda geçtim yeni bir exchange kurup mailleri manuel import etme yoluna girdim.Fakat olmuyor onuda yaptırmıyor yardımlarınızı rica ederim.Çok teşekkürler.
    20 Nisan 2012 Cuma 19:09