locked
Server 2008 üstünde IIS 7.5 da isteklere cevap vermeme, eski sayfayı tekrar getirme sorunu RRS feed

  • Soru

  • Merhaba

    Biraz karmaşık bir sorunumun var sorunu net olarak çözebilmiş değilim aslında. Bir çok şüpheli var ancak en büyük şüpheli IIS 7.5. 

    Sunucuda 100den az domain var  ve çok yüklü de değiller. Sunucudaki domainler genelde asp.net kullanıyor. Db olarak da aynı sunucuda SQL 2008 var. 3GB ram mevcut. 2.50 ghz işlemci var. 

    Sorunum bazı zamanlarda ortyaya çıkıyor belli bir düzeni yok. Veya var o düzeni ve tetikleyen nedeni bulamadım.

    Sorun ilk olarak websitepanel de çıkmıştı ben de yazılımla ilgili olduğunu düşündüm ancak sonradan başka sitelerde de aynı sorunlar gözükmeye başladı

    Sorunla ilgili bir kaç örnek yazacağım. Websitepaneli örnek verecek olursam login olduktan sonra hesapları listeliyorsunuz sonra hesap detayına girmek isytiyorsunuz hesap detayına girince bulunduğunuz sayfa tekrar geliyor. sonra o sitede ne kadar link varsa bulunduğunuz sayfa yeiden geliyor. URl kısmında adres değişiyor (wspanelde default.aspx?komut=xx gibi linklerin hepsi)  mesela adres default.aspx?page=accounts yazıyor ama gelen sayfa o değil. bir süre dokunmadığın tekrar tıkladığın zaman gelebiliyor bekleme süresi değişebiliyor.  30 saniye de olabiliyor bir kaç dakika da ..

    Aynı şekilde endi hazırladığımız sitelerde de aynı durum sözkonusu özellikle postback işlemlerinde bu durum oluyor. mesela sayfa.aspx?sayfa=3 linkindesiniz menüden ?sayfa=4 tıklıyorsunuz yine karşınızda ?sayfa=3 hatta ?sayfa=fdkljgk yapıyorum normal olarak çakılması lazım ancak yine karşına ?sayfa=3 içeriği geliyor.

    SQL Profiler ile baktığında SQL e o donma olunca hiç komut gelmiyor. Yani IIS sanki cacheden gönderiyor ancak cache kapalı. Hatta çeşitli şekillerde Web Siteyi, Apllication poolu, IIS i recycle, restart vs yapıyorum ancak gidip gelince bazen yine bana eski sayfayı getirdiği oluyor halbuki session düştüğü için logine atması gerekirken.....

    Task manageri izliyorum RAM 2GB biraz üstü seviyesinde çalışıyor. 

    BU neden olabilir? Değerli görüşlerinizi bekliyorum.

     

    20 Ocak 2014 Pazartesi 11:35

Tüm Yanıtlar

  • Probleminiz internet explorer in websitenize uyumsuzluğundan kaynaklanıyor gibi geldi bana. explorer in versiyonunu düşürebilirsiniz ya da başka bir browserla deneyebilirmisiniz
    27 Ocak 2014 Pazartesi 21:17
  • Merhaba

    Her tür browser ile karşılaşıyorum bu sorunla. Lokalde sorun yok server bize ait sunucuya attığımda oluyor.

    20 Şubat 2014 Perşembe 16:35