none
Exchange 2013 te database mount edilmedi hatası alıyoruz. Bu sorunu nasıl çözebiliriz? RRS feed

  • Soru

  • Merhaba,

    Exchange 2013 Enterprise kullanıyoruz. Yanlışlıkla makina kapanması yaşadık. Ardından Event Wiever da şu hataları aldık.

    At '7/15/2013 1:43:16 PM' the copy of database 'Mailbox Database 0524114147' on this server was unexpectedly dismounted. The error returned by failover was "There is only one copy of this mailbox database (Mailbox Database 0524114147). Automatic recovery is not available.".  For more specific information about the failures, consult the event log on the server for other "ExchangeStoreDb" events.

    and this error

    Active Manager failed to mount database Mailbox Database 0524114147 on server mail.ugrl.gov.tr. Error: An Active Manager operation failed. Error: The database action failed. Error: Operation failed with message: MapiExceptionDatabaseError: Unable to mount database. (hr=0x80004005, ec=1108)
    Diagnostic context:
        Lid: 65256  
        Lid: 10722   StoreEc: 0x454     
        Lid: 1494    ---- Remote Context Beg ----
        Lid: 45120   dwParam: 0x207246
        Lid: 57728   dwParam: 0x207311
        Lid: 46144   dwParam: 0x2073CC
        Lid: 34880   dwParam: 0x2073CC
        Lid: 34760   StoreEc: 0xFFFFFE0B
        Lid: 46144   dwParam: 0x2075B1
        Lid: 34880   dwParam: 0x2075B1
        Lid: 54472   StoreEc: 0x1388    
        Lid: 42184   StoreEc: 0x454     
        Lid: 1750    ---- Remote Context End ----
        Lid: 1047    StoreEc: 0x454    

    Bu hataları nasıl aşabiliriz?

    Teşekkürler

    15 Temmuz 2013 Pazartesi 10:52

Tüm Yanıtlar

  • Merhaba;

    BURADA bu şekildeki bir hata yaşadıklarında çözüm bulmuşlar. Yedeklerinizi alarak bir denemenizi tavsiye ederim.

    Kolay gelsin.


    Bu cevabın size yardımcı olduğunu düşünüyorsanız lütfen resmin altındaki Yardımcı Olarak Oyla butonuna tıklayınız.

    15 Temmuz 2013 Pazartesi 14:34
  • Selam,

    Öncelikle eseutil /mh komutu ile database'in state/durumunun kontrol edilmesi gerekiyor.Dirty / Clean Shutdown mu?

    Geri dönüşüne göre farklı parametrelere yönlendirerek sorun giderilebilir.


    www.serhadmakbuloglu.com

    16 Temmuz 2013 Salı 06:01
  • Merhaba,

    Cevaplarınız için teşekkürler.

    eseutil /mh komutunu kullandım. Dirty shutdown olduğunu söylüyor. Bundan sonra nasıl devam edebilirim?

    Teşekkürler

    16 Temmuz 2013 Salı 06:45
  • Database ve Log dosyalarını farklı bir yere taşıyın.

    move-DatabasePath -Identity ‘database name’ -LogFolderPath ‘new log path’ -ConfigurationOnly

    Sonrasında ESEUTIL /p ile database'i recover edip, /mh'ı çalıştırıp database state'inin Clean Shutdown olup olmadığını kontrol edin.

    Buraya kadar her şey tamam ise, Mount edilmesi gerekiyor.


    www.serhadmakbuloglu.com

    16 Temmuz 2013 Salı 11:09
  • [PS] C:\Program Files\Microsoft\Exchange Server\V15\Mailbox\Mailbox Database 0524114147>Move-DatabasePath -Idendtity '.\
    Mailbox Database 0524114147.edb' -LogFolderPath "C:\repair" -ConfigurationOnly
    A parameter cannot be found that matches parameter name 'Idendtity'.
        + CategoryInfo          : InvalidArgument: (:) [Move-DatabasePath], ParameterBindingException
        + FullyQualifiedErrorId : NamedParameterNotFound,Move-DatabasePath
        + PSComputerName        :

    Verdiğiniz komandı denerken yukarıdaki hatayı alıyoruz. Nerede yanlış yapıyoruz acaba?

    Teşekkürler

    16 Temmuz 2013 Salı 11:54
  • A parameter cannot be found that matches parameter name 'Idendtity'.

    -Identity parametresinde de yazim hatasi yapmissiniz

     

    C:\Program Files\Microsoft\Exchange Server\V15\Mailbox\Mailbox Database 0524114147>Move-DatabasePath -Identity '.\

    olmaliydi

    16 Temmuz 2013 Salı 12:21
  • Merhaba,

    Yanlış yazmışım pardon, ama doğrusunu yazınca da hata alıyorum. Hata aşağıdaki gibi

    [PS] C:\Program Files\Microsoft\Exchange Server\V15\Mailbox\Mailbox Database 0524114147>Move-DatabasePath -Identity '.\M
    ailbox Database 0524114147.edb' -LogFolderPath "C:\repair" -ConfigurationOnly

    Cannot process argument transformation on parameter 'Identity'. Cannot convert value ".\Mailbox Database
    0524114147.edb" to type "Microsoft.Exchange.Configuration.Tasks.DatabaseIdParameter". Error: "'.\Mailbox Database
    0524114147.edb' is not a valid value for the identity.
    Parameter name: Identity"
        + CategoryInfo          : InvalidData: (:) [Move-DatabasePath], ParameterBindin...mationException
        + FullyQualifiedErrorId : ParameterArgumentTransformationError,Move-DatabasePath

    16 Temmuz 2013 Salı 13:13
  • Aşağıdaki şekilde yazalım, database'in yolunu gösterin.

    move-DatabasePath -Identity "M:\db.edb" -LogFolderPath "M:\logs’ -ConfigurationOnly


    www.serhadmakbuloglu.com

    16 Temmuz 2013 Salı 14:16
  • Değişik kombinasyonları denedim ama hep hata alıyorum

    [PS] C:\Program Files\Microsoft\Exchange Server\V15\Mailbox\Mailbox Database 0524114147>Move-DatabasePath -Identity ".\M
    ailbox Database 0524114147.edb" -LogFolderPath "C:\repair" -ConfigurationOnly
    Cannot process argument transformation on parameter 'Identity'. Cannot convert value ".\Mailbox Database
    0524114147.edb" to type "Microsoft.Exchange.Configuration.Tasks.DatabaseIdParameter". Error: "'.\Mailbox Database
    0524114147.edb' is not a valid value for the identity.
    Parameter name: Identity"
        + CategoryInfo          : InvalidData: (:) [Move-DatabasePath], ParameterBindin...mationException
        + FullyQualifiedErrorId : ParameterArgumentTransformationError,Move-DatabasePath
        + PSComputerName        :

    [PS] C:\Program Files\Microsoft\Exchange Server\V15\Mailbox\Mailbox Database 0524114147>Move-DatabasePath -Identity .\Ma
    ilbox Database 0524114147.edb -LogFolderPath "C:\repair" -ConfigurationOnly
    Cannot process argument transformation on parameter 'Identity'. Cannot convert value ".\Mailbox" to type
    "Microsoft.Exchange.Configuration.Tasks.DatabaseIdParameter". Error: "'.\Mailbox' is not a valid value for the
    identity.
    Parameter name: Identity"
        + CategoryInfo          : InvalidData: (:) [Move-DatabasePath], ParameterBindin...mationException
        + FullyQualifiedErrorId : ParameterArgumentTransformationError,Move-DatabasePath
        + PSComputerName        :

    [PS] C:\Program Files\Microsoft\Exchange Server\V15\Mailbox\Mailbox Database 0524114147>Move-DatabasePath -Identity Mail
    box Database 0524114147.edb -LogFolderPath "C:\repair" -ConfigurationOnly
    A positional parameter cannot be found that accepts argument 'Database'.
        + CategoryInfo          : InvalidArgument: (:) [Move-DatabasePath], ParameterBindingException
        + FullyQualifiedErrorId : PositionalParameterNotFound,Move-DatabasePath
        + PSComputerName        :

    [PS] C:\Program Files\Microsoft\Exchange Server\V15\Mailbox\Mailbox Database 0524114147>Move-DatabasePath -Identity 'Mai
    lbox Database 0524114147.edb' -LogFolderPath "C:\repair" -ConfigurationOnly
    The operation couldn't be performed because object 'Mailbox Database 0524114147.edb' couldn't be found on
    'mail.ugrl.gov.tr'.
        + CategoryInfo          : NotSpecified: (:) [Move-DatabasePath], ManagementObjectNotFoundException
        + FullyQualifiedErrorId : 8FA77789,Microsoft.Exchange.Management.SystemConfigurationTasks.MoveDatabasePath
        + PSComputerName        :

    [PS] C:\Program Files\Microsoft\Exchange Server\V15\Mailbox\Mailbox Database 0524114147>Move-DatabasePath -Identity '.\M
    ailbox Database 0524114147.edb' -LogFolderPath "C:\repair" -ConfigurationOnly
    Cannot process argument transformation on parameter 'Identity'. Cannot convert value ".\Mailbox Database
    0524114147.edb" to type "Microsoft.Exchange.Configuration.Tasks.DatabaseIdParameter". Error: "'.\Mailbox Database
    0524114147.edb' is not a valid value for the identity.
    Parameter name: Identity"
        + CategoryInfo          : InvalidData: (:) [Move-DatabasePath], ParameterBindin...mationException
        + FullyQualifiedErrorId : ParameterArgumentTransformationError,Move-DatabasePath
        + PSComputerName        :

    16 Temmuz 2013 Salı 14:32
  • Orayıda takip ettimaynı hatayı alıyorum, kendi yerinde repair edemez miyim?

    [PS] C:\Program Files\Microsoft\Exchange Server\V15\Mailbox\Mailbox Database 0524114147>Move-DatabasePath ".\Mailbox Dat
    abase 0524114147.edb" -EdbFilePath "C:\repair\Mailbox Database 0524114147.edb" -LogFolderPath "C:\repair"
    Cannot process argument transformation on parameter 'Identity'. Cannot convert value ".\Mailbox Database
    0524114147.edb" to type "Microsoft.Exchange.Configuration.Tasks.DatabaseIdParameter". Error: "'.\Mailbox Database
    0524114147.edb' is not a valid value for the identity.
    Parameter name: Identity"
        + CategoryInfo          : InvalidData: (:) [Move-DatabasePath], ParameterBindin...mationException
        + FullyQualifiedErrorId : ParameterArgumentTransformationError,Move-DatabasePath
        + PSComputerName        :

    17 Temmuz 2013 Çarşamba 08:47
  • Direk repair işlemi başarılı olamayabilir diye bu seçeneği tarif etmiştim.Repiar yapmak için aşağıdaki komutu kullananın, sonrasında tekrar mh parametresi ile detabase'in durumunu check edin.

    eseutil /R E00 /l "c:\DBRecovery" /d "c:\DBRecovery\Mailbox Database 0436312751.edb"


    www.serhadmakbuloglu.com

    17 Temmuz 2013 Çarşamba 10:56
  • Bu komand çalışmadı. eseutil /p komutunu kullanarak clean shutdown konumuna getirdim, sonra log dosyalarını başka bir klasöre taşıyarak sistemi yeniden başlattım. Görünüşe göre şimdi mount etti ancak email gönderip almıyor. Eski emailleri görebiliyoruz. Sadece gönderip almada sorun var. Nasıl çözebileceğimize dair bir fikriniz var mı?
    17 Temmuz 2013 Çarşamba 14:42
  • Sunucunun servisleri ne durumda?

    https://www.testexchangeconnectivity.com/ mail gönderip alma testleri yapabilirmiyiz

    www.serhadmakbuloglu.com

    18 Temmuz 2013 Perşembe 06:02
  • Sunucunun servisleri çalışmakta ancak testi gerçekleştirdiğimde aşağıdaki hatayı alıyorum.

    

    mail.ugrl.gov.tr MX kullanılarak test@ugrl.gov.tr adlı kişiye test e-posta iletisi gönderilmeye çalışılıyor.

    Test e-posta iletisi teslim edilemedi.

    Ek Ayrıntılar

    Sunucu 451 - Error in processing. The server response was: 4.7.0 Temporary server error. Please try again later. PRX3 durum kodunu döndürdü
    Özel durum ayrıntıları:
    İleti: Error in processing. The server response was: 4.7.0 Temporary server error. Please try again later. PRX3
    Tür: System.Net.Mail.SmtpException
    Yığın izleme:
    at System.Net.Mail.DataStopCommand.CheckResponse(SmtpStatusCode statusCode, String serverResponse)
    at System.Net.Mail.DataStopCommand.Send(SmtpConnection conn)
    at System.Net.Mail.SmtpClient.Send(MailMessage message)
    at Microsoft.Exchange.Tools.ExRca.Tests.SmtpMessageTest.PerformTestReally()

    19 Temmuz 2013 Cuma 13:20
  • Şu sitede bir çözüm buldum:

    http://social.technet.microsoft.com/Forums/exchange/en-US/288e1619-ce56-4c3a-8bb1-4886835520fe/delivery-fails-the-server-response-was-470-temporary-server-error-please-try-again-later

    Ancak orada şöyle diyor:

    ...once I created another endpoint for 2525 then my tests started working.

    2525 için endpoint nasıl create edilir onu bulamadım.

    19 Temmuz 2013 Cuma 13:22
  • Ayrıca C:\Program Files\Microsoft\Exchange Server\V15\TransportRoles\Logs\FrontEnd\ProtocolLog\SmtpSend konumundaki loglarda aşağıdaki hatayı görüyorum.

    2013-06-20T00:26:37.457Z,Inbound Proxy Internal Send Connector,08D01E009CD1607B,0,,IP:2525,*,,attempting to connect
    2013-06-20T00:26:38.566Z,Inbound Proxy Internal Send Connector,08D01E009CD1607B,1,,IP:2525,*,,"Failed to connect. Error Code: 10061, Error Message: No connection could be made because the target machine actively refused it IP:2525"


    19 Temmuz 2013 Cuma 13:51
  • SMTP portunun açık olduğundan emin olalım, nereden internet hizmeti alıyorsunuz?

    www.serhadmakbuloglu.com

    20 Temmuz 2013 Cumartesi 19:57
  • ecp den send ve receive ayarlarını

    aynı zamanda smtp portlarını kontrol edermisiniz...


    MCT+MCITP+MCSA+MCTS

    22 Temmuz 2013 Pazartesi 15:07
  • Portu kontrol ettim 587 olarak gözüküyor. Send receive ayarlarıda benim gördüğüm kadarıyla normal. Bu ayarlarla çalışıyordu. ISP TTNET.
    23 Temmuz 2013 Salı 07:14
  • 587 local trafik içindir, internet tarafında 25 kullanılıyor.

    www.serhadmakbuloglu.com

    23 Temmuz 2013 Salı 09:25
  • Portlar şu şekilde tanımlı (receive connector'larda)

    Client Frontend         587

    Client Proxy              465

    Default Frontend       25

    Default                     2525

    Outbound Proxy Frontend      717

    23 Temmuz 2013 Salı 13:17
  • 2525 nedir? Sadece 25 kalması gerekiyor.

    www.serhadmakbuloglu.com

    24 Temmuz 2013 Çarşamba 06:15
    • Port 25 – This port just like in previous versions of Exchange is used for SMTP. Used by both External SMTP into the Front End Transport Service (FET), SMTP with Exchange 2007\2010 hub servers, between MBX servers, and also from the FET to the Transport Service. There is a receive connector named Default Frontend <servername> that listens on this port.
    • Port 587 – This port just like previous versions of Exchange is used for Client Connections (POP\IMAP). The CAS Server has a receive connection listening on this port name Client Frontend <servername>.
    • Port 717 – used for outbound proxy connections from the Transport service to the FET Service. When you create a Send connection you have the option to send mail destined for the Internet directly from the Transport Service to the Internet\Smart Host or relay that mail through the Front End Transport Service. There is a receive connector named Outbound Proxy Frontend <servername> that listens on this port.
    • Port 465 – used to accept proxied connections that were received on port 587 by the FET service for client connections. There is a receive connector named Client Proxy <servername> that listens on this port.
    • Port 475 – the Mailbox Transport Delivery Service listens on this ports for connections either from the transport service SMTP Send connector or SMTP from the Transport Service on other Mailbox Servers that need to send mail to users on this server.
    • Port 2525 – if the CAS and MBX servers are collocated on the same server the SMTP Receive connection for the Transport service will listen on 2525 instead of 25. This is because two services (FET and Transport Service) can’t listen on the same port.
    24 Temmuz 2013 Çarşamba 06:38