none
Build 14295: VMware Workstation Pro 12 thinks Hyper-V is installed RRS feed

  • السؤال

  • I upgraded Windows 10 Enterprise to build 14295; I had Hyper-V enabled and, because of my job, had to disable it and installed VMware Workstation 12.1 Pro. Everything seems to be fine, but I received this error message when I tried to run a VMware VM:

     "VMware Workstation and Hyper-V are not compatible. Remove the Hyper-V role from the system before running VMware Workstation" (Pic1).

     Hyper-V was disabled, of course, but I figured out that the Hyper-V Platform is greyed out (look at the Pic2).

     So... I reinstalled build 1511 (full updated), installed only VMware and it worked just fine. I then ran the upgrade to the 14295 again and just received the same error, even when I have not enabled Hyper-V at all.

     I cannot run VMware neither Hyper-V, because I am not able to enable the Hyper-V Platform again (everything is good in my BIOS).

     What can I do?

     I sent this issue using the Feedback Hub app, but I would like to find a workaround while another build is released.

    I tried the bcdedit /set hypervisorlaunchtype off but did not work.

    Update: I tried with the build 14316 and got the same issue.


    Blog | Twitter


    • تم التحرير بواسطة Sergio CalderónMVP 28/جمادى الثانية/1437 08:54 م Post update
    21/جمادى الثانية/1437 01:29 ص

جميع الردود

  • Hi Sergio and i thought i would be the only one with this problem. I have exactly the same problem which is really annoying because there seems no way to fix it.
    21/جمادى الثانية/1437 06:36 م
  • Hi Sergio,

    I've got the same issue.... Checked that the SLAT / CPU virtualization support was available on my device and that was also the case. I'm using a Surface Pro 3, which doesn't allow me to disable the virtualization support any way.

    What devices are you guys using? The issue might me related to Surface, but I'm not sure...

    /Peter


    Peter Selch Dahl - www.peterdahl.net - Blog: http://blog.peterdahl.net - Twitter @PeterSelchDahl

    21/جمادى الثانية/1437 09:23 م
  • I'm using a desktop PC. I think the workaround would be installing this build and then VMware Workstation. MSDN just released the ISO images for this build, so I am going to reinstall and I will let you know if that works.

    Blog | Twitter

    22/جمادى الثانية/1437 04:25 ص
  • Sounds great! I just did a downgrade using the Recovery function in Windows 10 to the previous Build (I'm on Fast Ring). The issue is also within BUILD 14291 or perhaps the rollback didn't work.

    Please share your findings... 


    Peter Selch Dahl - www.peterdahl.net - Blog: http://blog.peterdahl.net - Twitter @PeterSelchDahl

    22/جمادى الثانية/1437 07:46 ص
  • I actually run 14295 on my Dell M4700 and VMware Workstation 12.1 is working. It was also with 14291.
    Have you checked in Services that there's no Hyper-V related services running?

    On my computer, all services are stopped and Startup Type is configured as Manual (Trigger Start)

    Gerald



    22/جمادى الثانية/1437 08:07 ص
  • Peter: I think there is not way to workaround this issue once you get it.

    Gérald: They all are stopped and manual, just like you showed us.

    I suppose you agree that this is a bug, but, just like any other bug, it doesn't reproduce on all environments. I have a Gigabyte Z170X - Gaming 3.


    Blog | Twitter

    22/جمادى الثانية/1437 01:50 م
  • Agree... Should be a bug and seems difficult to reproduce it.
    Actually, the only problem I had with Insider previews and VMware Workstation is that I need to reset the Virtual Network after each upgrade because I loose the Bridged network.

    Did you tried to install a fresh 14295 from the MSDN DVD?

    22/جمادى الثانية/1437 02:40 م
  • Agree... Should be a bug and seems difficult to reproduce it.
    Actually, the only problem I had with Insider previews and VMware Workstation is that I need to reset the Virtual Network after each upgrade because I loose the Bridged network.

    Did you tried to install a fresh 14295 from the MSDN DVD?

    I just did a clean install and Windows shows Hyper-V Platform cannot be installed, like the second screenshot I showed. So... seems like this build is not fully compatible with my board/processor.

    The only way it worked was installing Hyper-V from 1511 and then upgrade to 14295.


    Blog | Twitter

    22/جمادى الثانية/1437 04:06 م
  • Look... according to Coreinfo, Windows even thinks VT and SLAT are not supported:


    Blog | Twitter

    22/جمادى الثانية/1437 04:25 م
  • I've been having a similar problem for a few builds now. Hyper-V is installed, probably triggered by the Visual Studio 2015 install. The Hyper-V services are all stopped, and I have set the hypervisorlaunchtype to off in bcdedit which is all I needed to do previously. Something has clearly changed. Anyone else find a workaround?
    24/جمادى الثانية/1437 02:32 ص
  • I could workaround this, but only could use Hyper-V. Just installed it using PowerShell and it worked. I will try VMware in the next build.

    Blog | Twitter

    26/جمادى الثانية/1437 04:02 م
  • Hi Sergio, did you tried it with the new build already?
    28/جمادى الثانية/1437 08:21 م
  • Hi Sergio, did you tried it with the new build already?

    Just tried. Same issue.

    Seems like Microsoft is not aware (or doesn't care yet) of this issue; after all, Hyper-V works fine.

    We will have to wait until VMWare itself reports the issue with these latest builds.


    Blog | Twitter

    28/جمادى الثانية/1437 08:51 م
  • Hi Sergio,

    i left the insider preview programm due to that bug. Today i recived an update to Build 14295.rs1_release.160318-1628. Just powered up the VMWare and it seems to run without any problems, so maybe they fixed the issue in that build.

    Lars

    03/رجب/1437 11:56 ص
  • Sergio,

    I recently upgraded my desktop from Win 10 ver 1511 Enterprise x64 to the anniversary update ver 1607. Prior to the upgrade VMware Workstation v. 12.1.1 was running fine. After the upgrade I am now getting this error. I have a second machine (Dell Latitude E7440) which was a clean-install of Windows 10 x 64 Enterprise ver. 1607 and VMware Workstation 12.1.1 is running fine. So it appears to be related to the upgrade process. I also confirmed that no Hyper-V components were active in Windows Components Add/Remove. I also have uninstalled/reinstalled VMware - no luck. I also tried turning off the Intetl VT-x features in BIOS. This did allow me to launch a Win XP SP3 (32-bit) VM. There were some complaints by VMware but it did run. Tried one of my Win 10 x64 VM's and could not get it to run...but also did not get the 'VMware not compatible with Hyper-V' messages either. Re-enabled the VT-x features in BIOS and am right back to where I started with the 'VMware and Hyper-V are not compatible' errors.

    07/ذو القعدة/1437 07:30 م
  • I have exactly the same problem. 

    (I bounce back and forth a few times per year between Hyper-V and VMWare Workstation to try and stay fluent in both as I encounter both with my customers. )
    21/ذو القعدة/1437 04:31 ص
  • From an Admin Command Prompt try the following to turn hypervisor on and off:

    bcdedit /set hypervisorlaunchtype off

    Reboot

    bcdedit /set hypervisorlaunchtype auto

    Reboot

    Worked for me.

    See the following YouTube video:

    https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&cad=rja&uact=8&ved=0ahUKEwjHpICc16PPAhUEGx4KHfCIA6UQtwIIHDAA&url=https%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DIrP4vlw5LUY&usg=AFQjCNHQEo1IVHQCvX1DzyW9QcC-1c50xw&sig2=hQwgbEGfixJ87FRQr21ZGw


    Lamar

    • تم الاقتراح كإجابة بواسطة Zunoe 30/ذو الحجة/1437 12:02 ص
    21/ذو الحجة/1437 07:53 م
  • From an Admin Command Prompt try the following to turn hypervisor on and off:

    bcdedit /set hypervisorlaunchtype off

    Reboot

    That part is spot on, but resetting it to auto is only going to cause the same error again for users.

    • تم الاقتراح كإجابة بواسطة dannyzzzzzzz 11/محرم/1438 02:00 م
    11/محرم/1438 02:00 م
  • Here I am, more than half a year after last post having this same problem.  Finally found the cause and work around in this post.  Hope it helps.

    https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2146361


    • تم التحرير بواسطة evbstv 24/رمضان/1438 02:22 م
    24/رمضان/1438 12:46 ص
  • Credential guard is the root of the problem. Thanks for the post!

    I was able to disable credential guard by using microsoft's Device Guard and Credential Guard hardware readiness tool: https://www.microsoft.com/en-us/download/details.aspx?id=53337

    First, make sure it isn't managed by group policy. Check local group policy for the following and disable:
    Computer configuration > Administrative Templates > System > Device Guard > Turn on Virtualization Based Security: disabled

    The tool is a powershell script so make sure to set your powershell exexution policy:
    Set-ExecutionPolicy -ExecutionPolicy RemoteSigned

    Then run the readiness tool with the disable flag:
    DG_Readiness_Tool_v3.2.ps1 -disable

    When you reboot you should get a preboot dialougue asking if you want to disable credential manager

    I would also make sure to have hyper-v disabled in windows features. 
    Disable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V –All

    You may also need to disable it from starting by using a command line command mentioned before:
    bcdedit /set hypervisorlaunchtype off

    I hope this helps everyone!


    • تم الاقتراح كإجابة بواسطة kush86g 23/ربيع الثاني/1439 10:50 ص
    13/ذو القعدة/1438 12:47 م
  • This worked for me.  BUT... It also says my Docker won't work.  I haven't tried it yet.  Why apps in 2017 cannot play well together is beyond me.

    Sigh...

    Steve

    08/صفر/1439 09:55 م
  • Thank you for this step by step.  I've been working on this problem all night and "DG_Readiness_Tool_v3.2.ps1 -disable" is the solution to fully disable Hyper-V.
    • تم الاقتراح كإجابة بواسطة kush86g 23/ربيع الثاني/1439 10:50 ص
    18/ربيع الثاني/1439 04:29 ص
  • Almost 2 years later this bug is still present on build 17074
    27/ربيع الثاني/1439 03:48 م
  • Please follow https://kb.vmware.com/s/article/2146361 in order to fix virtualization problem
    16/جمادى الأولى/1439 07:41 م
  • Please follow https://kb.vmware.com/s/article/2146361 in order to fix virtualization problem
    That's like chopping your foot off to fix an in growing toe nail. its not a fix, its a workaround, one that is taking a giant dump over your VM security.
    29/جمادى الأولى/1439 01:57 م
  • This total solution for me.

    12/رجب/1439 03:56 م
  • Hope this helps someone else! None of this fixed it for me. It appears Hyper-V possibly did not completely remove/disable itself in my case (after removing Hyper-V, some services were still starting automatically). I actually tried all suggestions here and it would give me either the Hyper-V compatibility error the OP shows, or the Credential Guard/Device Guard error no matter what I did.

    Here is what fixed it for me:

    1. Run>services.msc, set all Hyper-V services back to Manual (will show as "Manual(triggered)")
    2. Run>gpedit.msc, set Group Policy "Turn on Virtualization Based Security" back to "Not Configured" (mentioned here: https://kb.vmware.com/s/article/2146361)
    3. Went to "Turn Windows features on or off" and checked Hyper-V to add it back
    4. Reboot
    5. Verified Hyper-V was working (did not start a VM, just launched manager and saw it showed my computer name in the list)
    6. Went to "Turn Windows features on or off" and un-checked Hyper-V to remove it again
    7. Reboot
    8. After all this Hyper-V services no longer start automatically and VMWare starts without issue.
    9. Note: At some point in this mess I ran "bcdedit /set hypervisorlaunchtype off"...I attempted running VMWare with the "hypervisorlaunchtype" set to "auto" and got the Credential Guard/Device Guard error again. I opened up admin-cmd prompt and ran "bcdedit /deletevalue hypervisorlaunchtype" to just remove the setting because I know someday I will forget and it will prevent me from getting Hyper-V going, reboot after doing this, but at the very least it must be set to "off" in my case
    10. VMWare still working with "hypervisorlaunchtype" boot value deleted!

    VMWare Workstation v14.1.2 build-8497320

    01/شوال/1439 07:47 م
  • Actualy is not like chooping your foot of.  When you enable in virtualization support on your processor, or if it is already enabled,  Windows 10 also enable Credential Guard/Device Guard - that "use virtual capabilities of the processor" in order to improve security, by running some of processes like Edge for example in a separate environment.

    The alternative is not to use VMware Workstation or any other virtualization solution but  Hyper-V. Not sure how this fit on  Home edition of the OS.

    • تم الاقتراح كإجابة بواسطة ocean2706 25/ذو القعدة/1439 04:51 م
    25/ذو القعدة/1439 04:44 م
  • In order to check if you had disabled everything, check value of System Information ->System Summary->Virtualization-based Security (also if above instruction did not work, try Bing search on Disable Virtualization-based Security ). As a curiosity, you will still find some Hyper-V flags as enabled ( yes value) on same page, but having Virtualization-based Security disabled will do the trick.

    Also this https://docs.microsoft.com/en-us/windows/security/identity-protection/credential-guard/credential-guard-manage can help.

    • تم الاقتراح كإجابة بواسطة ocean2706 25/ذو القعدة/1439 04:51 م
    25/ذو القعدة/1439 04:51 م
  • That worked for me, too!

    When you reboot you should get a preboot dialougue asking if you want to disable credential manager

    There was no dialouge but anyway.. it's running :) thanks

    • تم الاقتراح كإجابة بواسطة peterbrendon 15/ربيع الأول/1440 09:18 م
    • تم إلغاء اقتراح كإجابة بواسطة peterbrendon 15/ربيع الأول/1440 09:18 م
    15/ذو الحجة/1439 08:16 م
  • Just to add a solution that worked for me:

    If you are using the basic Window 10 HOME updated to the latest 2018 build level, VMware will not function, because some elements of Hyper-V are included, although they cannot be controlled.

    In addition, many of the functions available in bcdedit and Powershell are not available with Windows 10 Home. For example, in Powershell, none of the vm cmdlts are available. Credential Guard/Device Guard are also not available. The Microsoft site solutions will not work. Even the so-called "Hypervisor readiness" do not run.

    In "Programs" "Windows Functions" there are no selections for Hyper-V. There is only a generic tickbox for "Windows Hypervisor Platform".

    However this sequence works:

    1. untick "Windows Hypervisor Platform"

    2. run bcdedit /set hypervisorlaunchtype off

    3. reboot

    4. steps 1-3 are not enough ! You must also deactivate the "Core Isolation" function in the Windows Defender Security Center.

    4. Reboot again.

    VMware will then function.

    It is strange but interesting that "Core Isolation" also has an effect on some system drivers. With Core Isolation activated, my laptop CD/DVD drive was dead, Windows would not recognise its own native driver cdrom.sys.  But everything returns to normal when Core Isolation is deactivated.

    15/ربيع الأول/1440 11:13 م
  • Just follow simple steps:

    1. Click on start

    2. search "Windows defender security center"

    3. Click on Device Security

    4. Go to core isolation and choose "Off" memory integrity

    5. Restart the computer.

    6. Start VMware with administrator privilege.

    21/ربيع الثاني/1440 12:30 م
  • This worked for me on Server 2016
    08/ذو الحجة/1440 03:10 م
  • Finally that worked for me. Thank you !!
    27/محرم/1441 07:39 ص