none
Hyper-V Ubuntu can't connect to internet RRS feed

  • السؤال

  • I have an instance of Ubuntu 18.04 running on Hyper-V on Windows 10. Windows 10 connects to the internet through our office LAN over Ethernet just fine - I am using it to post this question - but Ubuntu isn't receiving the internet connection.

    How do I make the virtual machine connect?

    Here's a screen print of the ipconfig for the Windows machine (with identifications redacted):

    I first tried using the Hyper-V virtual switch set to the default virtual switch, with no success. Here are screen prints for the ipconfig for the default virtual switch and the corresponding Ubuntu command along with the configurations used in the virtual machine, followed by the resulting screen print showing the connection failed:

    I next tried using the Hyper-V virtual switch to create a new virtual switch, with no success. Here are screen prints for the ipconfig for the new virtual switch and the corresponding Ubuntu command along with the configurations used in the virtual machine, followed by the resulting screen print showing the connection failed with this configuration as well:

    Note: While I've redacted, I note that the ipconfig result for DHCPv6 Client DUID and DNS Servers, and the GENERAL.HWADDR for the Ubuntu command in the new switch are identical to that of the default switch.

    And finally here are the network connections:


    • تم التحرير بواسطة Charles Belov [SFMTA] 03/محرم/1440 01:15 ص explain green-color redactions
    03/محرم/1440 01:10 ص

الإجابات

  • Solved!

    When I initially installed Ubuntu, I specified the following two options:

    • Encrypted install
    • Minimal install

    On a hunch, I decided to try a new virtual machine with the following options:

    • No encryption
    • Normal install

    This time I have connectivity.

    So it appears to be one of my original options that blocked connectivity.

    03/محرم/1440 07:46 م

جميع الردود

  • Solved!

    When I initially installed Ubuntu, I specified the following two options:

    • Encrypted install
    • Minimal install

    On a hunch, I decided to try a new virtual machine with the following options:

    • No encryption
    • Normal install

    This time I have connectivity.

    So it appears to be one of my original options that blocked connectivity.

    03/محرم/1440 07:46 م
  • I realize this forum post is a year old at this point but still seems relevant in terms of it having to do with ubuntu 18.04 distribution running in windows 10 hyper-v environment and having problems with the network connection being able to see the internet.

    I just tested installing ubuntu 18.04.2 using windows 10 1903 (18362.10019) hyper-v and its quick create > ubuntu 18.04.2 lts option and also using https://ubuntu.com/download/desktop > 18.04.3 lts iso download installer.

    In both cases when the ubuntu install came up and i signed in the network adapter, using hyper-v default switch [ / nat ] connection, showed details of having pulled an appropriate address and dns settings but wasn't showing as connected.  I tried manually applying ipv4 dns address and turning off & back on the adapter to have those settings take and no change.

    The process i found to get things working was to first change the hyper-v switch setting to use of an external switch [ / bridged ??? ] connection. After that the ubuntu network adapter connection was working at which point i ran "sudo apt-get update", "sudo apt update" and finally software updater offered updates and a reboot. 

    With these changes in place i tested switching back to hyper-v preferred default switch [ / nat ] setting for the network adapter and still no success but this time if i manually applied dns settings overriding the dhcp pulled ones and turned off and back on the network connection then it worked. 

    This leaves me wondering if there is something in the current non-updated 18.04 LTS distribution, and an updated one, that has issues with use of the hyper-v default switch [ / nat ] and after updates are in place the dhcp pulled dns settings.  Note that i can boot a windows 10 vm on this same system configured to use the hyper-v default switch [ / nat ] and it works fine.



    • تم التحرير بواسطة myusrn 22/محرم/1441 05:04 م text correction
    22/محرم/1441 05:03 م