none
SUP Sync fails with error SUSDB is read-only RRS feed

  • السؤال

  • Hello,

    I am running a SCCM 1710 with remote SQL instance on AG. Since last week SUP role on primary started throwing error stating SUSDB is read-only mode and today the Sync failed with the same error. Also observed that on WSUS console, it marks the WSUS service is not running when in actual its running. Have tried restarting the services and server a couple of times now.

    Any direction to trouble shooting is highly appreciated.

    Error on wsyncmgr log-> Sync failed: Failed to update database "SUSDB" because the database is read-only. Source: Microsoft.UpdateServices.Internal.BaseApi.SoapExceptionProcessor.DeserializeAndThrow

    12/ذو الحجة/1440 05:26 م

الإجابات

  • The message you posted above is pretty clear as to the root cause: "because the database is read-only". You need to work with your DBAs to figure out why the DB is read-only and correct this. Also, keep in mind that technically, the SUSDB DB is not supported in a SQL AG (even though is generally works fine).

    Jason | https://home.configmgrftw.com | @jasonsandys

    • تم وضع علامة كإجابة بواسطة SVJV 13/ذو الحجة/1440 03:24 م
    12/ذو الحجة/1440 07:47 م

جميع الردود