none
Sever 2012r2 - .NET Runtime RRS feed

  • السؤال

  • Hi,

    Recently Vertias backup exec wont load on our 2012r2 Server. It just says Backup Exec has stopped working.

    I have been running this server for about 5 years now and Backup Exec has been fine until now. I now get an error when trying to load the software. The Problem ID is CLR20r3.

    I have completely removed the software off the server and then restarted the server. Then I have installed fresh + run Live updates as admin. – No joy. I have also repeated the process but using a different install path. – no joy. I can’t uninstall .Net from the roles as the server is used this for Sims and I can risk it breaking that. I have tried the .Net repair tool too. - No joy!

    In Windows event logs I get 3 events which trigger shortly after the crash..

    1. .Net Runtime  -  Event ID 1026

    Application: BackupExec.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.Reflection.AmbiguousMatchException
       at System.RuntimeType.GetMethodImpl(System.String, System.Reflection.BindingFlags, System.Reflection.Binder, System.Reflection.CallingConventions, System.Type[], System.Reflection.ParameterModifier[])
       at System.Type.GetMethod(System.String, System.Reflection.BindingFlags)
       at BackupExec.ThemeManager..cctor()

    Exception Info: System.TypeInitializationException
       at BackupExec.ThemeManager.ChangeTheme(System.String, System.String)
       at BackupExec.App..ctor()
       at BackupExec.App.Main()

    2. Application Error  -  Event ID 1000

    Faulting application name: BackupExec.exe, version: 14.1.1786.0, time stamp: 0x5371d883
    Faulting module name: KERNELBASE.dll, version: 6.3.9600.19425, time stamp: 0x5d26b6e9
    Exception code: 0xe0434352
    Fault offset: 0x000000000000908c
    Faulting process id: 0x3ab8
    Faulting application start time: 0x01d5670c3b040941
    Faulting application path: C:\Program Files\Symantec2\Backup Exec\BackupExec.exe
    Faulting module path: C:\Windows\system32\KERNELBASE.dll
    Report Id: 78c5648f-d2ff-11e9-811b-2047477c4e2a
    Faulting package full name: 
    Faulting package-relative application ID: 

    3. Perflib - Event ID 1023

    Windows cannot load the extensible counter DLL SQLAgent$BKUPEXEC. The first four bytes (DWORD) of the Data section contains the Windows error code.

    All advice i can find from Google/Symantec forums is just what I've already tried.

    Any Help would be appreciated.

    Cheers

    Mick


    Mikehawo


    • تم التحرير بواسطة Mikehawo 10/محرم/1441 01:34 م
    10/محرم/1441 01:19 م

جميع الردود

  • Hello Mick,

    Did you ask in the Veritas BackupExec forums? Since BackupExec is now part of Veritas.

    Which .NET Framework version are you running?

    Looks to me like an incompatible .NET Framework version, you’re receiving the same error as mentioned here:

    https://www.veritas.com/support/en_US/article.100045500

    Check what changes have been done lately to your server, for example any updates and such.

    Best regards,

    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    10/محرم/1441 01:32 م
  • Hey thanks for getting back to me. There has been recent updates yes, but then I only role out the MS patches every month as normal. The article you have referred me to doesn't give you the download - just sends you to a page that's says The document you are seeking is no longer available - lol

    I have just removed update, KB4486105 and restarted the server and i can confirm this has fixed the problem!!!

    I did spot this article before but i must have missed the bit at the bottom about the specific Windows updates. For others reading this i didn't have to remove .net 4.8 i just searched for the update and removed it, then restarted. BOOM!

    Thank you very much Leon! 



    Mikehawo


    • تم التحرير بواسطة Mikehawo 10/محرم/1441 02:43 م
    10/محرم/1441 02:34 م
  • Weird the link works here, the link also states the following:

    "Temporary workaround:

    1. Uninstall .NET Framework 4.8 and reboot server. This update will be listed as KB4486105 (Windows 2012 R2), KB4486081 (Windows 2012), KB4486129 (Windows 2016), KB4486153 (Windows 2019) in the list of installed updates."

    Anyways, I'm glad to hear that uninstalling the KB4486105 helped you resolve the issue!

    (Please don't forget to mark helpful replies as answer, thank you!)


    Blog: https://thesystemcenterblog.com LinkedIn:

    10/محرم/1441 02:38 م
  • Thanks! This worked for me!!!!
    22/صفر/1441 07:34 م