none
2nd Monitor on restart only RRS feed

  • Dotaz

  • After years of working with 2 monitors - all of a sudden the 2nd monitor is not working off a cold boot (pressing the 'on' button).  I see it come to life during the early part of the boot but then goes into 'no signal' mode.

    Once the PC is fully booted and working with 1 monitor - then I can do the restart - and this time it includes the 2nd monitor and all is well.

    So I imagine I am going to get the advice to uninstall the device and reinstall it, as well as advice on upgrading the drivers.  But clearly the behavior is due to the boot sequence.  Any thoughts on that?

    úterý 19. září 2017 12:33

Odpovědi

  • Hi,

    Did you install any update packages in those several days?

    Have you enabled fast boot?

    Because Windows 10 will enable fast boot by default. When you boot through pressing power button, hibernate combined profile would be saved. However, when you restart the computer, that typically means that you want a completely new Windows state,  it will perform a full boot cycle.

    So let’s narrow down the issue by disable fast boot through Control Panel\Power Options\Choose what the power buttons do\Change settings that are currently unavailable\untick "Turn on fast startup".

    If the option is missing, try to run command "powercfg /hibernate on" as administrator to enable hibernate, then the option will show up.

    If the symptom disappear, it means that the issue is related with boot sequence. Please test on your side and feedback the result.

    Best regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    středa 20. září 2017 10:02
    Moderátor
  • The only mode to reactivate it is on screen settings and deactivating/reactivating the second monitor.

    Others are taking even more extreme workarounds such as unplugging and replugging their connectors.  Spare your hardware from such misuse and try to find a software workaround instead.  E.g. perhaps the Win+Ctrl+Shift+B  procedure could be your "magic bullet".  The problem is that we have no simple way of requesting the video support to try again than by the workarounds that we have been able to find or devise so far.


    Robert Aldwinckle
    ---

    • Navržen jako odpověď Mark66F středa 20. září 2017 17:42
    • Označen jako odpověď msdnPublicIdentity čtvrtek 21. září 2017 10:41
    středa 20. září 2017 16:41
  • Here is a further update plus a shout out to JQ in thanks...

    per my prior post RA gave a great solution on how to wake up the 2nd monitor via Win + Ctl + Shift + b   

    never did a 4 finger entry but it works...

    still I wanted that 2nd monitor to work off the boot so I revisited JQ's advice and while I couldn't find it at first I went back and forth methodically in the Power area of Win 10 checking every hot link and option and eventually found the option for the Fast Boot - the layout of this area really is a kludge

    anyway.... I unchecked the Fast Boot

    also because I have another dual screen set up that doesn't have this problem and that set up never goes into hibernate - and so just to compare apples to apples I also changed the option so that the problem PC did not go into hibernate

    now when I cold boot both monitors work.

    pátek 22. září 2017 11:53

Všechny reakce

  • Hi,

    Did you install any update packages in those several days?

    Have you enabled fast boot?

    Because Windows 10 will enable fast boot by default. When you boot through pressing power button, hibernate combined profile would be saved. However, when you restart the computer, that typically means that you want a completely new Windows state,  it will perform a full boot cycle.

    So let’s narrow down the issue by disable fast boot through Control Panel\Power Options\Choose what the power buttons do\Change settings that are currently unavailable\untick "Turn on fast startup".

    If the option is missing, try to run command "powercfg /hibernate on" as administrator to enable hibernate, then the option will show up.

    If the symptom disappear, it means that the issue is related with boot sequence. Please test on your side and feedback the result.

    Best regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    středa 20. září 2017 10:02
    Moderátor
  • I have the same issue on two differet system

    After install KB4038788 update, on boot after shutdown (not after restart) the second monitor remains in stand by. On both system, I see the win logo and on login the right monitor go in stand by mode. One system is configurated with primary monitor on left and secondary on right, second with primary on right and secondary on left. In both system the right monitor start in stand-by. The only mode to reactivate it is on screen settings and deactivating/reactivating the second monitor.
    In one system i have uninstall the update and it has returned normal, but in the other the uninstall procedure has not been successful.
    Both graphic board are Radeon HD with default microsoft driver.
    Any idea or suggestion to solve the problem?
    Thank's in advance

    středa 20. září 2017 10:11
  • thanks JQ on the advice - will give it a try and report back later today

    M66 - yes my experience is exactly the same

    I do updates whenever MS passes them out and do believe it is update related.  Yet at the same time I have another dual screen set up that has no problem at all.  And I let every PC update whenever MS passes one out....and so why it affects one and not the other is a bit of a mystery.  They are not identical hardware however.

    I will add one point that may be relevant: the set up with the problem goes into hibernate after about 1 hr inactive - the power light blinks, the monitors are dark - and then I half-press the power button to wake it up.  The PC without a problem does not go into hibernate ever.  While I did not originally connect this to the current issue - perhaps it is.

    středa 20. září 2017 12:47
  • I see it come to life during the early part of the boot but then goes into 'no signal' mode.

    On an HDMI monitor which I normally use as Second Screen Only attached to my Surface 2 Pro I frequently see "HDMI 2 No Signal".  I don't know if I would see the first part of your symptom description because there are 3 ports on my monitor and one of the others is always showing first.

    My workaround for getting it back is to use Project (Win-P) optionally accompanied by Narrator.  E.g. I can start Narrator (Win+Ctrl+Enter) then press Win+P  End Enter to switch to Second Screen Only.  Then I have to be quick (but not too quick) with CursorLeft, Enter in order to accept the "Keep this setting?" prompt sight unseen (since it disappears too quickly otherwise) and then switch to the correct HDMI port.  Sometimes that doesn't work and it reverts to the PC Screen Only or sometimes it does work but the HDMI screen is a mess of swirling grey while static noise emanates from my speakers.  Then I have to switch back manually to PC Screen Only (e.g. using Win-P, Home, Enter) and try again.

    In my case this is not restricted to doing a cold boot though.  I have to do it even just resuming from Sleep.  Pressing  Win+Ctrl+Shift+B is rarely useful as a general procedure but I wish I could remember about it as a possibility because I think it might be a better choice than the Win+P, Home, Enter sequence that I usually do to initiate a retry.

    BTW I originally was using a VGA connection (using a converter) and using both my monitor and my tablet screen since that combination worked best and I found the HDMI connection more problematic.  But I have switched to the above configuration so I can see and attest to all the problem symptoms which are being reported with HDMI support.   (And it's not just this.)



    Robert Aldwinckle
    ---

    středa 20. září 2017 16:31
  • The only mode to reactivate it is on screen settings and deactivating/reactivating the second monitor.

    Others are taking even more extreme workarounds such as unplugging and replugging their connectors.  Spare your hardware from such misuse and try to find a software workaround instead.  E.g. perhaps the Win+Ctrl+Shift+B  procedure could be your "magic bullet".  The problem is that we have no simple way of requesting the video support to try again than by the workarounds that we have been able to find or devise so far.


    Robert Aldwinckle
    ---

    • Navržen jako odpověď Mark66F středa 20. září 2017 17:42
    • Označen jako odpověď msdnPublicIdentity čtvrtek 21. září 2017 10:41
    středa 20. září 2017 16:41
  • Win+Ctrl+Shift+B  procedure could be your "magic bullet". 

      Hi Robert
    Thanks a lot for the suggestion, I tried the win + Ctrl + Shift + B combination at win login and this "awakened" the monitor in standby without go from the control panel.
    Do you think there is hope that this problem will be corrected in the future? I hope so...
    středa 20. září 2017 17:41
  • I can report also that the Win + Ctrl + Shift +B did successfully waken my second monitor.  So thank you RA on that hint.

    JQ - There was no option as you describe in Power Options.  Also I could not figure out "powercfg /hibernate on" - I tried it in Run and Command Prompt.  Although I am the owner and sole user of the PC I could not seem to locate any run-as-administrator option.....

    čtvrtek 21. září 2017 10:40
  • could not seem to locate any run-as-administrator option.....

    Press Win-x A

    You can use either an elevated cmd or PowerShell command line to enter the suggested command and expect it to be run elevated too.

    BTW there is a potential problem with the simple syntax you were given.  E.g. you might get a too small hiberfil.sys to do a real Hibernate.  Use   powercfg.exe  -h  -?   to see the full syntax you could try.

    FYI



    Robert Aldwinckle
    ---

    čtvrtek 21. září 2017 11:23
  • what/how is Win-x ? not familiar with that

    Tried Win + A and it opens the action center pane on right....also tried Win +x +A.... same thing - am thinking that is not what you mean I should do...

    should I get that step done - - am not clear what next I am to do or really what the concept is that I am trying to accomplish in this system area which is unfamiliar to me ....(except of course that the 2nd monitor boots up the first time...)

    čtvrtek 21. září 2017 11:29
  • what/how is Win-x ?

    It's an equivalent to doing a right-click on the Start Menu button.


    Robert Aldwinckle
    ---

    čtvrtek 21. září 2017 13:03
  • I facing the same issue too within this week.

    Restart will fix it and also Sign Out and Login again also works too.

    Might have something to do with the latest windows updates.
    pátek 22. září 2017 1:17
  • Here is a further update plus a shout out to JQ in thanks...

    per my prior post RA gave a great solution on how to wake up the 2nd monitor via Win + Ctl + Shift + b   

    never did a 4 finger entry but it works...

    still I wanted that 2nd monitor to work off the boot so I revisited JQ's advice and while I couldn't find it at first I went back and forth methodically in the Power area of Win 10 checking every hot link and option and eventually found the option for the Fast Boot - the layout of this area really is a kludge

    anyway.... I unchecked the Fast Boot

    also because I have another dual screen set up that doesn't have this problem and that set up never goes into hibernate - and so just to compare apples to apples I also changed the option so that the problem PC did not go into hibernate

    now when I cold boot both monitors work.

    pátek 22. září 2017 11:53
  • I have done the same verification, disabling the fast boot option both monitors work by starting a cold boot
    pátek 22. září 2017 15:07
  • Even after KB4040724 (build 15063.632) update, the issue persists (for me). For the time, the only solution is disable fast boot option
    středa 27. září 2017 12:40
  • I too have been having this exact same problem. Thinking it was a driver to hardware problem, I am surprised to read it may have been a Windows update to compliment the many billions of lost man hours the blue screens of death use to impose on productivity.

    Rebooting is a pain and frustrating at the most inconvenient of times when one really needs that second monitor displayed.

    Is there a fix yet or are we still at the audible *crickets* stage?


    úterý 9. října 2018 14:28
  • Disabling the fast boot option didn't work for me.

    2'nd monitor is still not working after cold boot, only after restart.

    středa 13. února 2019 11:13
  • I think I've found a solution: decided on a whim to set up a customized power plan utilizing Hibernate when I close lid on my Dell laptop. You will need to go through the various scenarios eg notifications, critical actions etc but Eureka! I verily set my laptop to go into Hibernate mode when closing lid (Sleep and Power off using Windows Power button), the laptop screen and external HDMI monitor close down simultaneously but furthermore both displays reawaken when I restart by pressing my laptop Power button

    • Upravený geebs46 pátek 16. srpna 2019 17:38
    • Navržen jako odpověď geebs46 pátek 16. srpna 2019 17:41
    pátek 16. srpna 2019 17:32