none
New Windows 10 machine, ethernet is only slow on internet, but fast on LAN, but WIFI is fast on internet. RRS feed

  • Dotaz

  • I just got a brand new Dell Windows 10 box.  Ethernet card is Killer E2400.  When I connect via a known good network cable (previous machine connected to the cable was fast and no issues), I can transfer files on the internal network at Gigabit speed no problem (about 80 MB/s from a USB 3.0 drive connected to another machine), but Internet browsing is sluggist, and speedtest.net showed only 2 Mb/s download and upload speed, though ping time is okay around 12 to 15.  When I unplugged the network cable, and run off the wifi adapter on the new machine, speedtest.net showed 50 Mb/s download and browsing experience is noticeable faster.  

    Not sure what's going.  Even tried to connect the network cable to a Ethernet to USB 3.0 adapter, then plugged that into a USB 3.0 port and still get the same slow internet speed but fast LAN speed.  

    Tried to do the network reset within Windows, no cigar.  Tried to disable IPv6, tried to disable Large Sendn Offload v2 for both IPv4 and IPv6, have the latest Killer driver and control center software.  Nothing so far have made any difference.  

    neděle 22. září 2019 1:59

Všechny reakce

  • If rest of the things are okay then call your ISP provider and report the problem.

    S.Sengupta,Microsoft MVP Windows and Devices for IT, Windows Insider MVP

    neděle 22. září 2019 5:10
  • Hi ,

    Just want to confirm the current situations.

    Please feel free to let us know if you need further assistance.                   

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    středa 25. září 2019 6:04
  • Hi ,

    You could mark the useful reply as answer if you want to end this thread up.

    If there is anything else we can do for you, please feel free to post in the forum.

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    pátek 27. září 2019 4:24
  • "Killer" network: I would try to use an other card.
    The Killer drivers are known for problems, so wouldn't surprise me if they are behind this strange behaviour.
    pátek 27. září 2019 5:53